Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-20-10, 04:07 AM   #1
Lemmiwinks
Registered User
 
Join Date: Apr 2009
Location: Germany
Posts: 75
Default options nvidia NVreg_EnableMSI=1 not being applied by Ubuntu 10.10

Hi there!
I would like to use "options nvidia NVreg_EnableMSI=1" on my Ubuntu 10.10 Maverick, but it is somehow not applied by the system on startup. I created the options.conf file in /etc/modprobe.d/ and put the command in there. I am using the nvidia driver provided by the distributions repositories, it is version 260.19.06.

Any suggestions?
__________________
GF 8600M GT, core 2 duo 1.8ghz, Ubuntu 12.04, driver 304.37
Lemmiwinks is offline   Reply With Quote
Old 10-20-10, 04:37 AM   #2
Fackamato
User
 
Join Date: Mar 2005
Posts: 366
Default Re: options nvidia NVreg_EnableMSI=1 not being applied by Ubuntu 10.10

I think you need to regenerate the initrd so the new file is included.
Fackamato is offline   Reply With Quote
Old 10-20-10, 04:49 AM   #3
Lemmiwinks
Registered User
 
Join Date: Apr 2009
Location: Germany
Posts: 75
Default Re: options nvidia NVreg_EnableMSI=1 not being applied by Ubuntu 10.10

I already ran sudo update-initramfs -u , but unfortunately it still does not work.
Do I need a different command?
__________________
GF 8600M GT, core 2 duo 1.8ghz, Ubuntu 12.04, driver 304.37
Lemmiwinks is offline   Reply With Quote
Old 10-20-10, 05:05 AM   #4
Lemmiwinks
Registered User
 
Join Date: Apr 2009
Location: Germany
Posts: 75
Default Re: options nvidia NVreg_EnableMSI=1 not being applied by Ubuntu 10.10

This is the output of cat /proc/interrupts :
Code:
           CPU0       CPU1       
  0:       4150       4340   IO-APIC-edge      timer
  1:         38         45   IO-APIC-edge      i8042
  8:          1          0   IO-APIC-edge      rtc0
  9:          0          1   IO-APIC-fasteoi   acpi
 12:         75         73   IO-APIC-edge      i8042
 14:         87         83   IO-APIC-edge      ata_piix
 15:          0          0   IO-APIC-edge      ata_piix
 16:        576        563   IO-APIC-fasteoi   nvidia
 17:          0          0   IO-APIC-fasteoi   eth0
 18:         10          3   IO-APIC-fasteoi   mmc0, r852
 19:          1          0   IO-APIC-fasteoi   firewire_ohci
 20:        280        240   IO-APIC-fasteoi   ehci_hcd:usb2, uhci_hcd:usb3, uhci_hcd:usb5
 21:          0          0   IO-APIC-fasteoi   uhci_hcd:usb4, uhci_hcd:usb6
 22:          1          1   IO-APIC-fasteoi   ehci_hcd:usb1, uhci_hcd:usb7
 44:       3230       3091   PCI-MSI-edge      ahci
 45:        281        293   PCI-MSI-edge      hda_intel
 46:        284        283   PCI-MSI-edge      iwl3945
NMI:          0          0   Non-maskable interrupts
LOC:       3121       3043   Local timer interrupts
SPU:          0          0   Spurious interrupts
PMI:          0          0   Performance monitoring interrupts
PND:          0          0   Performance pending work
RES:        897       1245   Rescheduling interrupts
CAL:         87       1042   Function call interrupts
TLB:        201        210   TLB shootdowns
TRM:          0          0   Thermal event interrupts
THR:          0          0   Threshold APIC interrupts
MCE:          0          0   Machine check exceptions
MCP:          1          1   Machine check polls
ERR:          1
MIS:          0
__________________
GF 8600M GT, core 2 duo 1.8ghz, Ubuntu 12.04, driver 304.37
Lemmiwinks is offline   Reply With Quote
Old 10-20-10, 10:02 AM   #5
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: options nvidia NVreg_EnableMSI=1 not being applied by Ubuntu 10.10

What is the content of the nvidia modprobe file?
mooninite is offline   Reply With Quote
Old 10-20-10, 06:05 PM   #6
artem
Registered User
 
Join Date: Jun 2006
Posts: 705
Default Re: options nvidia NVreg_EnableMSI=1 not being applied by Ubuntu 10.10

Aaron (the core NVIDIA Linux driver developer): "I talked to our kernel guy and he said that MSI is notoriously problematic throughout the hardware and software stack, and he recommended that you just stick with traditional interrupts."
artem is offline   Reply With Quote
Old 04-18-11, 12:42 PM   #7
voyager6868
Registered User
 
Join Date: Sep 2006
Posts: 11
Default Re: options nvidia NVreg_EnableMSI=1 not being applied by Ubuntu 10.10

It's possible that you need to reference the module with the name 'nvidia-current' instead of 'nvidia'.

One way to verify is to run 'modinfo nvidia'. If it says something like 'can't find module' then, try 'modinfo nvidia-current'. If that doesn't work, you need to find the name of the module being used (under /lib/modules) and reference that name.

For me, placing
options nvidia-current NVreg_EnableMSI=1
in nvidia.conf under /etc/modprobe.d works. No other commands like update-initramfs need to be run.
voyager6868 is offline   Reply With Quote
Old 04-19-11, 08:19 AM   #8
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: options nvidia NVreg_EnableMSI=1 not being applied by Ubuntu 10.10

Quote:
Originally Posted by artem View Post
Aaron (the core NVIDIA Linux driver developer): "I talked to our kernel guy and he said that MSI is notoriously problematic throughout the hardware and software stack, and he recommended that you just stick with traditional interrupts."
Instead telling people to use traditional interrupts or pushing driver developers Nvidia should Nvidia hardware "engineers" who create buggy hardware to stop doing this. Here are some facts:
My Geforce 8200 (iGPU+chipset - full Nvidia design) release year 2007
MSI mode - introduced with PCI 2.2 year 1998
APIC mode - introduced in 1997
XT PIC mode - introduced in 1981 with IBM XT
My Nvidia 8200 GPU hangs in MSI mode on Nvidia only mainboard - no 3rd party hardware - only Nvidia chips and AMD CPU:
Code:
00:00.0 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a2)
00:01.0 ISA bridge: nVidia Corporation MCP78S [GeForce 8200] LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP78S [GeForce 8200] SMBus (rev a1)
00:01.2 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:01.3 Co-processor: nVidia Corporation MCP78S [GeForce 8200] Co-Processor (rev a2)
00:01.4 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:02.0 USB Controller: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:04.0 USB Controller: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:04.1 USB Controller: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:07.0 Audio device: nVidia Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)
00:08.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:09.0 SATA controller: nVidia Corporation MCP78S [GeForce 8200] AHCI Controller (rev a2)
00:0a.0 Ethernet controller: nVidia Corporation MCP77 Ethernet (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:12.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:13.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
02:00.0 VGA compatible controller: nVidia Corporation C77 [GeForce 8200] (rev a2)
So I do not use MSI - bring your 2007 Nvidia hardware back to year 1997 and use APIC (enabled by default in any Linux distro and Windows). No APIC off switch in BIOS so enabled by default. But no. Nvidia USB 1.1 OHCI controller will hang USB completely after few minutes of use if you use APIC interrupts 'fasteoi' on Linux. You have to use noapic kernel boot parameter to bring your 2007 hardware back to year 1981. Wow now works and nothing hangs. Hurray! You pay in 2008 money to Nvidia for new hardware just to learn at work/home that Nvidia funded you for these money a historic journey back to the year 1981. Thank you Nvidia for a crap you sold me!

Today we have year 2011. Nvidia knows that MSI hangs since I bought Geforce 8200 - year 2008. USB hanging bug - Nvidia looks for a fix since year 2009 or even earlier because I analyzed the problem and posted about this bug earlier. No patches no fixes. Nothing. Just grab the money and run away before customer finds out what he bought.

I really thank Intel for ripping off Nvidia from mainboard market. There will be less evil this way.

I had before nForce2-T (the most expensive version with Soundstorm2 and optical out), later Geforce 6150+nForce430. Both run fine (except MSI). So it looks Nvidia is degrading over time.
zbiggy is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:52 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.