Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-16-11, 04:28 AM   #1
terau
Registered User
 
Join Date: Aug 2010
Posts: 19
Default Please add an option to configure powermizer sensitivity

Both my desktop GTX460 and the GT320M on my laptop have this problem.

Whatever the version of the driver, the lowest performance state is not able to keep the composited desktop (In certain resolutions) or video (all outputs, gl, xv, vdpau) tear free. The driver is not smart enough to get out of P0 in many situations.

The powermizer strategy for adjusting p-states in linux is clearly broken on some cards. I know that you can use a fixed frequency with RegistryDwords, but this is a workaround that raises minimum (completely idle) power-consumption and temperatures.

Adding a simple config option like linux-cpufreq's "up_threshold" will solve this problem completely for all users.

Thanks.
terau is offline   Reply With Quote
Old 02-17-11, 03:17 AM   #2
szwagros
Registered User
 
Join Date: Mar 2005
Posts: 3
Default Re: Please add an option to configure powermizer sensitivity

+1
I alse have this problem with GTX460 as pointed in this thread http://www.nvnews.net/vbulletin/showthread.php?t=158870
szwagros is offline   Reply With Quote
Old 02-17-11, 03:29 AM   #3
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: Please add an option to configure powermizer sensitivity

Quote:
Originally Posted by terau View Post
Both my desktop GTX460 and the GT320M on my laptop have this problem.

Whatever the version of the driver, the lowest performance state is not able to keep the composited desktop (In certain resolutions) or video (all outputs, gl, xv, vdpau) tear free. The driver is not smart enough to get out of P0 in many situations.

The powermizer strategy for adjusting p-states in linux is clearly broken on some cards. I know that you can use a fixed frequency with RegistryDwords, but this is a workaround that raises minimum (completely idle) power-consumption and temperatures.

Adding a simple config option like linux-cpufreq's "up_threshold" will solve this problem completely for all users.

Thanks.
Adding random options isn't a fix if it doesn't scale up even if it should well that bug should be fixed.
Dragoran is offline   Reply With Quote
Old 02-17-11, 04:22 AM   #4
terau
Registered User
 
Join Date: Aug 2010
Posts: 19
Default Re: Please add an option to configure powermizer sensitivity

Quote:
Originally Posted by Dragoran View Post
Adding random options isn't a fix if it doesn't scale up even if it should well that bug should be fixed.
nvidia says that sync to vblank in blit mode videos, (which means everything composite) is not guaranteed to work by design, so I don't think that is a bug for them.

Configuring powermizer sensitivity seems to be the only good option that will eventually satisfy everyone.
terau is offline   Reply With Quote
Old 02-18-11, 07:39 AM   #5
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: Please add an option to configure powermizer sensitivity

Quote:
Originally Posted by terau View Post
nvidia says that sync to vblank in blit mode videos, (which means everything composite) is not guaranteed to work by design, so I don't think that is a bug for them.

Configuring powermizer sensitivity seems to be the only good option that will eventually satisfy everyone.
Yes because powermizer has anything to do with vsynv .. oh wait
Dragoran is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:52 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.