Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-05-11, 05:34 PM   #1
tarakbumba
Registered User
 
Join Date: Nov 2006
Posts: 2
Unhappy VDPAU wont work on my 9600gt

Hi, i have a Palit GeForce 9600gt Sonic graphics card. I'd like to use vdpau on my Arch Linux install. But it seems i can't get it to work with recent drivers (from 256xx upto 270.30) and looking for a help:

Code:
01:24 atilla@tarakbumba:~$ vdpauinfo 
display: :0   screen: 0
VDPAU capture: Enabled
vdp_imp_device_create_x11(0xaef010, 0, -, -)
VDPAU nvidia: Version: NVIDIA VDPAU Driver Shared Library  270.30  Fri Feb 25 14:54:19 PST 2011
VDPAU nvidia: Error detected 10 296  5
VDPAU nvidia: Backtrace:
--: /usr/lib/vdpau/libvdpau_nvidia.so.1 [0x7f301904b000] DSO load base
00: /usr/lib/vdpau/libvdpau_nvidia.so.1 [0x7f301907ed2d] 
01: /usr/lib/vdpau/libvdpau_nvidia.so.1 [0x7f301906ed2a] 
02: /usr/lib/vdpau/libvdpau_nvidia.so.1 [0x7f3019053c3e] vdp_imp_device_create_x11
    -> 1
Error creating VDPAU device: 1
nvidia-bug report file attached.
Attached Files
File Type: gz nvidia-bug-report.log.gz (33.7 KB, 69 views)
tarakbumba is offline   Reply With Quote
Old 04-08-11, 05:25 AM   #2
tarakbumba
Registered User
 
Join Date: Nov 2006
Posts: 2
Default Re: VDPAU wont work on my 9600gt

Bump ??
tarakbumba is offline   Reply With Quote
Old 12-15-11, 02:47 PM   #3
torgi
Registered User
 
Join Date: Dec 2011
Posts: 4
Default Re: VDPAU wont work on my 9600gt

same error here.
Code:
display: :0.0   screen: 0
VDPAU capture: Enabled
vdp_imp_device_create_x11(0x1a28010, 0, -, -)
VDPAU nvidia: Version: NVIDIA VDPAU Driver Shared Library  290.10  Wed Nov 16 18:06:51 PST 2011
VDPAU nvidia: Error detected 10 296  5
VDPAU nvidia: Backtrace:
--: /usr/lib64/libvdpau_nvidia.so [0x7fc948d7f000] DSO load base
00: /usr/lib64/libvdpau_nvidia.so [0x7fc948db736f] 
01: /usr/lib64/libvdpau_nvidia.so [0x7fc948da73ca] 
02: /usr/lib64/libvdpau_nvidia.so [0x7fc948d8851c] vdp_imp_device_create_x11
    -> 1
Error creating VDPAU device: 1
same chip
Code:
01:00.0 VGA compatible controller: nVidia Corporation G94 [GeForce 9600 GT] (rev a1)
but the card is a gainward.
torgi is offline   Reply With Quote
Old 12-15-11, 05:05 PM   #4
tecknurd
Registered User
 
Join Date: Mar 2011
Posts: 11
Default Re: VDPAU wont work on my 9600gt

Try disable Composite and Compiz. If that does not work, downgrade the nvidia module to something like 180.x or 190.x.

I have problems too with VDPAU even though my video card model is Geforce8 8400M GS. Since VDPAU is unstable for me and OpenGL makes my screen goes dark or blank for about 10 seconds, I use XVideo for video playback as a work around. Luckily H.264 codec is threaded, so I do not have to care too much for VDPAU.

IMHO, the 2xx.x nVidia modules are mainly for GT and Fermi only and not supposed to work for GeForce 8 and Geforce 9.

torgi, just a heads up, 290.10 crashes programs upon start up like Chromium and Xfce Terminal if using nVidia OpenGL libraries. The 290.10 crashes multiple programs on my setup when I tried using it.
tecknurd is offline   Reply With Quote
Old 12-15-11, 05:21 PM   #5
Plagman
NVIDIA Corporation
 
Plagman's Avatar
 
Join Date: Sep 2007
Posts: 254
Default Re: VDPAU wont work on my 9600gt

The latest release series are intended to fully support all NVIDIA products from GeForce 6 onwards. If you're running into a crashing issue with OpenGL apps on 290.10, please do report it in a separate so that it can be investigated.

I'm not able to replicate the VDPAU failure on a 9600GT. Can you clarify whether connecting other X11 clients from the same terminal where attempting to start 'vdpauinfo' works, such as 'xdpyinfo' or 'glxgears'?
Plagman is offline   Reply With Quote
Old 12-15-11, 05:42 PM   #6
torgi
Registered User
 
Join Date: Dec 2011
Posts: 4
Default Re: VDPAU wont work on my 9600gt

Code:
kiste torgi # glxgears
68809 frames in 5.0 seconds = 13761.621 FPS
68729 frames in 5.0 seconds = 13745.622 FPS
68785 frames in 5.0 seconds = 13756.979 FPS
68685 frames in 5.0 seconds = 13736.909 FPS
68713 frames in 5.0 seconds = 13742.412 FPS
and xdpyinfo runs too.
nvidia-bug-report.log.gz
torgi is offline   Reply With Quote
Old 12-19-11, 05:21 PM   #7
torgi
Registered User
 
Join Date: Dec 2011
Posts: 4
Default Re: VDPAU wont work on my 9600gt

??
torgi is offline   Reply With Quote
Old 12-19-11, 11:39 PM   #8
poltsy
Registered User
 
Join Date: Jan 2010
Posts: 26
Default Re: VDPAU wont work on my 9600gt

Code:
[    23.975] (II) LoadModule: "dri2"
[    23.975] (WW) Warning, couldn't open module dri2
[    23.975] (II) UnloadModule: "dri2"
[    23.976] (II) Unloading dri2
[    23.976] (EE) NVIDIA: Failed to load module "dri2" (module does not exist, 0)
[    23.976] (II) NVIDIA(0): The X server will not be able to send the VDPAU driver name to
[    23.976] (II) NVIDIA(0):     libvdpau.
Not sure if that's related but it sure looks mighty suspicious.
poltsy is offline   Reply With Quote

Old 12-20-11, 12:16 PM   #9
torgi
Registered User
 
Join Date: Dec 2011
Posts: 4
Default Re: VDPAU wont work on my 9600gt

i think nvidia doesnt use the xorg dri, so that cant be the problem
torgi is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:42 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.