Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-07-11, 03:29 PM   #1
kszewczyk
Registered User
 
Join Date: Apr 2011
Posts: 3
Default KDE fails on second screen

Hello i have a problem with configuration of xorg. I have two screens, my problem is that i cannot start kde on one of them (for example on first screen kde startup normally, but on second screen only xserver is running).

I get following message
Code:
 (WW) NVIDIA(1): TwinView requested, but only 1 display devices found.
but i dont know how to deal with it.

This is my xorg.conf
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 260.19.29  (buildmeister@swio-display-x86-rhel47-08.nvidia.com)  Wed Dec  8 12:28:55 PST 2010

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 260.19.29  (buildmeister@swio-display-x86-rhel47-08.nvidia.com)  Wed Dec  8 12:28:43 PST 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
                                                                                
    # HorizSync source: edid, VertRefresh source: edid                          
    Identifier     "Monitor1"                                                   
    VendorName     "Unknown"                                                    
    ModelName      "Samsung SMB2230N"                                           
    HorizSync       31.0 - 80.0                                                 
    VertRefresh     56.0 - 75.0
    Option         "DPMS"                                                                                                                                                                                                                                                      
EndSection                                                                                                                                                                                                                                                                     
                                                                                                                                                                                                                                                                               
Section "Monitor"                                                                                                                                                                                                                                                              
                                                                                                                                                                                                                                                                               
    # HorizSync source: edid, VertRefresh source: edid                                                                                                                                                                                                                         
    Identifier     "Monitor0"                                                                                                                                                                                                                                                  
    VendorName     "Unknown"                                                                                                                                                                                                                                                   
    ModelName      "Samsung SMB2230N"                                                                                                                                                                                                                                          
    HorizSync       31.0 - 80.0                                                                                                                                                                                                                                                
    VertRefresh     56.0 - 75.0                                                                                                                                                                                                                                                
    Option         "DPMS"                                                                                                                                                                                                                                                      
EndSection                                                                                                                                                                                                                                                                     
                                                                                                                                                                                                                                                                               
Section "Device"                                                                                                                                                                                                                                                               
    Identifier     "RightScreen"                                                                                                                                                                                                                                               
    Driver         "nvidia"                                                                                                                                                                                                                                                    
    VendorName     "NVIDIA Corporation"                                                                                                                                                                                                                                        
    BoardName      "GeForce GTX 460"                                                                                                                                                                                                                                           
    BusID          "PCI:1:0:0"                                                                                                                                                                                                                                                 
    Option         "UseDisplayDevice" "CRT-1"                                                                                                                                                                                                                                  
    Screen          1
EndSection

Section "Device"
    Identifier     "LeftScreen"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 460"
    BusID          "PCI:1:0:0"
    Option         "UseDisplayDevice" "CRT-0"
    Screen         0
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "RightScreen"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "True"
   # Option         "MetaModes" "nvidia-auto-select, nvidia-auto-select"
    Option          "MetaModes"  "CRT-1: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"

# Removed Option "TwinView" "0"
# Removed Option "metamodes" "CRT-0: nvidia-auto-select +0+0"
    Identifier     "Screen0"
    Device         "LeftScreen"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "TwinView" "True"
    Option         "MetaModes" "CRT-0: nvidia-auto-select +0+0, CRT-1: nvidia-auto-select +1920+0"
    SubSection      "Display"
        Depth       24
    EndSubSection
EndSection
and entire Xorg log
Code:
X.Org X Server 1.9.4
Release Date: 2011-02-04
[   124.487] X Protocol Version 11, Revision 0
[   124.488] Build Operating System: Linux 2.6.36-gentoo-r5 i686 Gentoo
[   124.488] Current Operating System: Linux zuzia 2.6.36-gentoo-r5 #6 SMP Tue Apr 5 18:18:45 CEST 2011 i686
[   124.489] Kernel command line: root=/dev/sda3
[   124.489] Build Date: 13 March 2011  07:33:04PM
[   124.489]  
[   124.490] Current version of pixman: 0.20.2
[   124.490]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[   124.491] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   124.493] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr  7 21:06:46 2011
[   124.493] (==) Using config file: "/etc/X11/xorg.conf"
[   124.493] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   124.494] (==) ServerLayout "Layout0"
[   124.494] (**) |-->Screen "Screen0" (0)
[   124.494] (**) |   |-->Monitor "Monitor0"
[   124.494] (**) |   |-->Device "LeftScreen"
[   124.494] (**) |-->Screen "Screen1" (1)
[   124.494] (**) |   |-->Monitor "Monitor1"
[   124.494] (**) |   |-->Device "RightScreen"
[   124.494] (**) |-->Input Device "Keyboard0"
[   124.494] (**) |-->Input Device "Mouse0"
[   124.494] (**) Option "Xinerama" "0"
[   124.494] (==) Automatically adding devices
[   124.494] (==) Automatically enabling devices
[   124.527] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[   124.527]    Entry deleted from font path.
[   124.527] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   124.527]    Entry deleted from font path.
[   124.527] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[   124.527]    Entry deleted from font path.
[   124.527] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[   124.527]    Entry deleted from font path.
[   124.527]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[   124.527] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[   124.527]    Entry deleted from font path.
[   124.527]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[   124.527] (==) FontPath set to:
        /usr/share/fonts/misc/
[   124.527] (==) ModulePath set to "/usr/lib/xorg/modules"
[   124.527] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   124.527] (WW) Disabling Keyboard0
[   124.527] (WW) Disabling Mouse0
[   124.527] (II) Loader magic: 0x8200de0
[   124.527] (II) Module ABI versions:
[   124.527]    X.Org ANSI C Emulation: 0.4
[   124.528]    X.Org Video Driver: 8.0
[   124.528]    X.Org XInput driver : 11.0
[   124.528]    X.Org Server Extension : 4.0
[   124.528] (--) PCI:*(0:1:0:0) 10de:0e22:1458:34fc rev 161, Mem @ 0xf4000000/33554432, 0xe8000000/134217728, 0xe4000000/67108864, I/O @ 0x0000cc00/128, BIOS @ 0x????????/524288
[   124.528] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   124.528] (II) LoadModule: "extmod"
[   124.605] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   124.615] (II) Module extmod: vendor="X.Org Foundation"
[   124.615]    compiled for 1.9.4, module version = 1.0.0
[   124.615]    Module class: X.Org Server Extension
[   124.615]    ABI class: X.Org Server Extension, version 4.0
[   124.615] (II) Loading extension MIT-SCREEN-SAVER
[   124.615] (II) Loading extension XFree86-VidModeExtension
[   124.615] (II) Loading extension XFree86-DGA
[   124.615] (II) Loading extension DPMS
[   124.615] (II) Loading extension XVideo
[   124.615] (II) Loading extension XVideo-MotionCompensation
[   124.615] (II) Loading extension X-Resource
[   124.615] (II) LoadModule: "dbe"
[   124.615] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   124.625] (II) Module dbe: vendor="X.Org Foundation"
[   124.625]    compiled for 1.9.4, module version = 1.0.0
[   124.625]    Module class: X.Org Server Extension
[   124.625]    ABI class: X.Org Server Extension, version 4.0
[   124.625] (II) Loading extension DOUBLE-BUFFER
[   124.625] (II) LoadModule: "glx"
[   124.657] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   125.216] (II) Module glx: vendor="NVIDIA Corporation"
[   125.216]    compiled for 4.0.2, module version = 1.0.0
[   125.216]    Module class: X.Org Server Extension
[   125.216] (II) NVIDIA GLX Module  260.19.29  Wed Dec  8 12:25:40 PST 2010
[   125.216] (II) Loading extension GLX
[   125.216] (II) LoadModule: "record"
[   125.216] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   125.221] (II) Module record: vendor="X.Org Foundation"
[   125.221]    compiled for 1.9.4, module version = 1.13.0
[   125.221]    Module class: X.Org Server Extension
[   125.221]    ABI class: X.Org Server Extension, version 4.0
[   125.221] (II) Loading extension RECORD
[   125.221] (II) LoadModule: "dri"
[   125.222] (WW) Warning, couldn't open module dri
[   125.222] (II) UnloadModule: "dri"
[   125.222] (EE) Failed to load module "dri" (module does not exist, 0)
[   125.222] (II) LoadModule: "dri2"
[   125.222] (WW) Warning, couldn't open module dri2
[   125.222] (II) UnloadModule: "dri2"
[   125.222] (EE) Failed to load module "dri2" (module does not exist, 0)
[   125.223] (II) LoadModule: "nvidia"
[   125.223] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   125.277] (II) Module nvidia: vendor="NVIDIA Corporation"
[   125.278]    compiled for 4.0.2, module version = 1.0.0
[   125.278]    Module class: X.Org Video Driver
[   125.288] (II) NVIDIA dlloader X Driver  260.19.29  Wed Dec  8 12:10:28 PST 2010
[   125.294] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   125.294] (--) using VT number 7

[   125.308] (II) Loading sub module "fb"
[   125.308] (II) LoadModule: "fb"
[   125.308] (II) Loading /usr/lib/xorg/modules/libfb.so
[   125.318] (II) Module fb: vendor="X.Org Foundation"
[   125.318]    compiled for 1.9.4, module version = 1.0.0
[   125.318]    ABI class: X.Org ANSI C Emulation, version 0.4
[   125.318] (II) Loading sub module "wfb"
[   125.318] (II) LoadModule: "wfb"
[   125.319] (II) Loading /usr/lib/xorg/modules/libwfb.so
[   125.324] (II) Module wfb: vendor="X.Org Foundation"
[   125.324]    compiled for 1.9.4, module version = 1.0.0
[   125.324]    ABI class: X.Org ANSI C Emulation, version 0.4
[   125.324] (II) Loading sub module "ramdac"
[   125.324] (II) LoadModule: "ramdac"
[   125.324] (II) Module "ramdac" already built-in
[   125.345] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[   125.345] (==) NVIDIA(0): RGB weight 888
[   125.345] (==) NVIDIA(0): Default visual is TrueColor
[   125.345] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   125.346] (**) NVIDIA(0): Option "TwinView" "True"
[   125.346] (**) NVIDIA(0): Option "MetaModes" "CRT-0: nvidia-auto-select +0+0, CRT-1: nvidia-auto-select +1920+0"
[   125.346] (**) NVIDIA(0): Option "TwinViewXineramaInfoOrder" "CRT-0"
[   125.346] (**) NVIDIA(0): Option "UseDisplayDevice" "CRT-0"
[   125.346] (**) NVIDIA(0): Enabling RENDER acceleration
[   125.346] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
[   125.346] (II) NVIDIA(0):     enabled.
[   126.063] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 460 (GF104) at PCI:1:0:0 (GPU-0)
[   126.063] (--) NVIDIA(0): Memory: 1048576 kBytes
[   126.063] (--) NVIDIA(0): VideoBIOS: 70.04.1b.00.02
[   126.063] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   126.063] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[   126.064] (--) NVIDIA(0): Connected display device(s) on GeForce GTX 460 at PCI:1:0:0
[   126.064] (--) NVIDIA(0):     Samsung SMB2230N (CRT-0)
[   126.064] (--) NVIDIA(0):     Samsung SMB2230N (CRT-1)
[   126.064] (--) NVIDIA(0): Samsung SMB2230N (CRT-0): 400.0 MHz maximum pixel clock
[   126.064] (--) NVIDIA(0): Samsung SMB2230N (CRT-1): 400.0 MHz maximum pixel clock
[   126.067] (**) NVIDIA(0): TwinView enabled
[   126.067] (WW) NVIDIA(0): TwinView requested, but only 1 display devices found.
[   126.072] (II) NVIDIA(0): Assigned Display Device: CRT-0
[   126.072] (WW) NVIDIA(0): Invalid display device in Mode Description
[   126.072] (WW) NVIDIA(0):     "CRT-1:nvidia-auto-select+1920+0"
[   126.072] (WW) NVIDIA(0): Not using mode description "CRT-1:nvidia-auto-select+1920+0";
[   126.072] (WW) NVIDIA(0):     unable to map to display device
[   126.072] (II) NVIDIA(0): Validated modes:
[   126.072] (II) NVIDIA(0):    
[   126.072] (II) NVIDIA(0):     "CRT-0:nvidia-auto-select+0+0,CRT-1:nvidia-auto-select+1920+0"
[   126.072] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[   126.095] (--) NVIDIA(0): DPI set to (101, 101); computed from "UseEdidDpi" X config
[   126.095] (--) NVIDIA(0):     option
[   126.095] (==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
[   126.095] (**) NVIDIA(1): Depth 24, (--) framebuffer bpp 32
[   126.095] (==) NVIDIA(1): RGB weight 888
[   126.095] (==) NVIDIA(1): Default visual is TrueColor
[   126.095] (==) NVIDIA(1): Using gamma correction (1.0, 1.0, 1.0)
[   126.095] (**) NVIDIA(1): Option "TwinView" "True"
[   126.095] (**) NVIDIA(1): Option "MetaModes" "CRT-1: nvidia-auto-select +0+0"
[   126.095] (**) NVIDIA(1): Option "UseDisplayDevice" "CRT-1"
[   126.095] (**) NVIDIA(1): Enabling RENDER acceleration
[   126.095] (II) NVIDIA(1): NVIDIA GPU GeForce GTX 460 (GF104) at PCI:1:0:0 (GPU-0)
[   126.095] (--) NVIDIA(1): Memory: 1048576 kBytes
[   126.095] (--) NVIDIA(1): VideoBIOS: 70.04.1b.00.02
[   126.095] (II) NVIDIA(1): Detected PCI Express Link width: 16X
[   126.095] (--) NVIDIA(1): Interlaced video modes are supported on this GPU
[   126.095] (--) NVIDIA(1): Connected display device(s) on GeForce GTX 460 at PCI:1:0:0
[   126.095] (--) NVIDIA(1):     Samsung SMB2230N (CRT-0)
[   126.095] (--) NVIDIA(1):     Samsung SMB2230N (CRT-1)
[   126.095] (--) NVIDIA(1): Samsung SMB2230N (CRT-0): 400.0 MHz maximum pixel clock
[   126.095] (--) NVIDIA(1): Samsung SMB2230N (CRT-1): 400.0 MHz maximum pixel clock
[   126.098] (**) NVIDIA(1): TwinView enabled
[   126.098] (WW) NVIDIA(1): TwinView requested, but only 1 display devices found.
[   126.102] (II) NVIDIA(1): Assigned Display Device: CRT-1
[   126.102] (II) NVIDIA(1): Validated modes:
[   126.102] (II) NVIDIA(1):     "CRT-1:nvidia-auto-select+0+0"
[   126.102] (II) NVIDIA(1): Virtual screen size determined to be 1920 x 1080
[   126.103] (--) NVIDIA(1): DPI set to (101, 101); computed from "UseEdidDpi" X config
[   126.103] (--) NVIDIA(1):     option
[   126.103] (==) NVIDIA(1): Enabling 32-bit ARGB GLX visuals.
[   126.103] (--) Depth 24 pixmap format is 32 bpp
[   126.103] (II) NVIDIA: Using 1024.00 MB of virtual memory for indirect memory
[   126.103] (II) NVIDIA:     access.
[   126.104] (II) NVIDIA(0): Initialized GPU GART.
[   126.110] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[   126.110] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[   126.110] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[   126.110] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[   126.110] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[   126.110] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[   126.110] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[   126.110] (II) NVIDIA(0):     Config Options in the README.
[   126.112] (II) NVIDIA(0): Setting mode
[   126.112] (II) NVIDIA(0):     "CRT-0:nvidia-auto-select+0+0,CRT-1:nvidia-auto-select+1920+0"
[   126.175] (II) Loading extension NV-GLX
[   126.236] (II) NVIDIA(0): Initialized OpenGL Acceleration
[   126.252] (==) NVIDIA(0): Disabling shared memory pixmaps
[   126.252] (II) NVIDIA(0): Initialized X Rendering Acceleration
[   126.252] (==) NVIDIA(0): Backing store disabled
[   126.252] (==) NVIDIA(0): Silken mouse enabled
[   126.266] (**) NVIDIA(0): DPMS enabled
[   126.266] (II) Loading extension NV-CONTROL
[   126.266] (II) Loading extension XINERAMA
[   126.266] (II) Loading sub module "dri2"
[   126.266] (II) LoadModule: "dri2"
[   126.267] (WW) Warning, couldn't open module dri2
[   126.267] (II) UnloadModule: "dri2"
[   126.267] (EE) NVIDIA: Failed to load module "dri2" (module does not exist, 0)
[   126.267] (II) NVIDIA(0): The X server will not be able to send the VDPAU driver name to
[   126.267] (II) NVIDIA(0):     libvdpau.
[   126.267] (==) RandR enabled
[   126.268] (II) NVIDIA(1): Initialized GPU GART.
[   126.273] (II) NVIDIA(1): ACPI: failed to connect to the ACPI event daemon; the daemon
[   126.273] (II) NVIDIA(1):     may not be running or the "AcpidSocketPath" X
[   126.273] (II) NVIDIA(1):     configuration option may not be set correctly.  When the
[   126.273] (II) NVIDIA(1):     ACPI event daemon is available, the NVIDIA X driver will
[   126.273] (II) NVIDIA(1):     try to use it to receive ACPI event notifications.  For
[   126.273] (II) NVIDIA(1):     details, please see the "ConnectToAcpid" and
[   126.273] (II) NVIDIA(1):     "AcpidSocketPath" X configuration options in Appendix B: X
[   126.273] (II) NVIDIA(1):     Config Options in the README.
[   126.273] (II) NVIDIA(1): Setting mode "CRT-1:nvidia-auto-select+0+0"
[   126.471] (II) NVIDIA(1): Initialized OpenGL Acceleration
[   126.474] (==) NVIDIA(1): Disabling shared memory pixmaps
[   126.474] (II) NVIDIA(1): Initialized X Rendering Acceleration
[   126.474] (==) NVIDIA(1): Backing store disabled
[   126.474] (==) NVIDIA(1): Silken mouse enabled
[   126.483] (**) NVIDIA(1): DPMS enabled
[   126.483] (II) Loading sub module "dri2"
[   126.483] (II) LoadModule: "dri2"
[   126.483] (WW) Warning, couldn't open module dri2
[   126.483] (II) UnloadModule: "dri2"
[   126.483] (EE) NVIDIA: Failed to load module "dri2" (module does not exist, 0)
[   126.483] (II) NVIDIA(1): The X server will not be able to send the VDPAU driver name to
[   126.483] (II) NVIDIA(1):     libvdpau.
[   126.483] (==) RandR enabled
[   126.483] (II) Initializing built-in extension Generic Event Extension
[   126.483] (II) Initializing built-in extension SHAPE
[   126.483] (II) Initializing built-in extension MIT-SHM
[   126.483] (II) Initializing built-in extension XInputExtension
[   126.483] (II) Initializing built-in extension XTEST
[   126.483] (II) Initializing built-in extension BIG-REQUESTS
[   126.483] (II) Initializing built-in extension SYNC
[   126.483] (II) Initializing built-in extension XKEYBOARD
[   126.483] (II) Initializing built-in extension XC-MISC
[   126.483] (II) Initializing built-in extension XINERAMA
[   126.483] (II) Initializing built-in extension XFIXES
[   126.483] (II) Initializing built-in extension RENDER
[   126.483] (II) Initializing built-in extension RANDR
[   126.483] (II) Initializing built-in extension COMPOSITE
[   126.483] (II) Initializing built-in extension DAMAGE
[   126.486] (II) Initializing extension GLX
[   126.713] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[   126.713] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   126.713] (II) LoadModule: "evdev"
[   126.713] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[   126.725] (II) Module evdev: vendor="X.Org Foundation"
[   126.725]    compiled for 1.9.4, module version = 2.6.0
[   126.725]    Module class: X.Org XInput Driver
[   126.725]    ABI class: X.Org XInput driver, version 11.0
[   126.725] (**) Power Button: always reports core events
[   126.725] (**) Power Button: Device: "/dev/input/event1"
[   126.731] (--) Power Button: Found keys
[   126.731] (II) Power Button: Configuring as keyboard
[   126.731] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[   126.731] (**) Option "xkb_rules" "evdev"
[   126.731] (**) Option "xkb_model" "evdev"
[   126.731] (**) Option "xkb_layout" "us"
[   126.750] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[   126.750] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   126.750] (**) Power Button: always reports core events
[   126.750] (**) Power Button: Device: "/dev/input/event0"
[   126.759] (--) Power Button: Found keys
[   126.759] (II) Power Button: Configuring as keyboard
[   126.759] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[   126.759] (**) Option "xkb_rules" "evdev"
[   126.759] (**) Option "xkb_model" "evdev"
[   126.759] (**) Option "xkb_layout" "us"
[   126.762] (II) config/udev: Adding input device A4Tech USB Full Speed (/dev/input/event2)
[   126.762] (**) A4Tech USB Full Speed: Applying InputClass "evdev pointer catchall"
[   126.762] (**) A4Tech USB Full Speed: always reports core events
[   126.762] (**) A4Tech USB Full Speed: Device: "/dev/input/event2"
[   126.771] (--) A4Tech USB Full Speed: Found 20 mouse buttons
[   126.771] (--) A4Tech USB Full Speed: Found scroll wheel(s)
[   126.771] (--) A4Tech USB Full Speed: Found relative axes
[   126.771] (--) A4Tech USB Full Speed: Found x and y relative axes
[   126.771] (II) A4Tech USB Full Speed: Configuring as mouse
[   126.771] (II) A4Tech USB Full Speed: Adding scrollwheel support
[   126.771] (**) A4Tech USB Full Speed: YAxisMapping: buttons 4 and 5
[   126.771] (**) A4Tech USB Full Speed: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   126.771] (II) XINPUT: Adding extended input device "A4Tech USB Full Speed" (type: MOUSE)
[   126.771] (**) A4Tech USB Full Speed: (accel) keeping acceleration scheme 1
[   126.771] (**) A4Tech USB Full Speed: (accel) acceleration profile 0
[   126.771] (**) A4Tech USB Full Speed: (accel) acceleration factor: 2.000
[   126.771] (**) A4Tech USB Full Speed: (accel) acceleration threshold: 4
[   126.771] (II) A4Tech USB Full Speed: initialized for relative axes.
[   126.771] (II) config/udev: Adding input device A4Tech USB Full Speed (/dev/input/mouse0)
[   126.771] (II) No input driver/identifier specified (ignoring)
[   126.772] (II) config/udev: Adding input device A4Tech USB Full Speed (/dev/input/event3)
[   126.772] (**) A4Tech USB Full Speed: Applying InputClass "evdev keyboard catchall"
[   126.772] (**) A4Tech USB Full Speed: always reports core events
[   126.772] (**) A4Tech USB Full Speed: Device: "/dev/input/event3"
[   126.782] (--) A4Tech USB Full Speed: Found 1 mouse buttons
[   126.782] (--) A4Tech USB Full Speed: Found scroll wheel(s)
[   126.782] (--) A4Tech USB Full Speed: Found relative axes
[   126.782] (--) A4Tech USB Full Speed: Found absolute axes
[   126.782] (--) A4Tech USB Full Speed: Found x and y absolute axes
[   126.782] (--) A4Tech USB Full Speed: Found keys
[   126.782] (II) A4Tech USB Full Speed: Configuring as mouse
[   126.782] (II) A4Tech USB Full Speed: Configuring as keyboard
[   126.782] (II) A4Tech USB Full Speed: Adding scrollwheel support
[   126.782] (**) A4Tech USB Full Speed: YAxisMapping: buttons 4 and 5
[   126.782] (**) A4Tech USB Full Speed: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   126.782] (II) XINPUT: Adding extended input device "A4Tech USB Full Speed" (type: KEYBOARD)
[   126.782] (**) Option "xkb_rules" "evdev"
[   126.782] (**) Option "xkb_model" "evdev"
[   126.782] (**) Option "xkb_layout" "us"
[   126.782] (EE) A4Tech USB Full Speed: failed to initialize for relative axes.
[   126.782] (WW) A4Tech USB Full Speed: found 37 axes, limiting to 36.
[   126.782] (II) A4Tech USB Full Speed: initialized for absolute axes.
[   126.782] (II) config/udev: Adding input device NOVATEK USB Keyboard (/dev/input/event4)
[   126.782] (**) NOVATEK USB Keyboard: Applying InputClass "evdev keyboard catchall"
[   126.782] (**) NOVATEK USB Keyboard: always reports core events
[   126.782] (**) NOVATEK USB Keyboard: Device: "/dev/input/event4"
[   126.790] (--) NOVATEK USB Keyboard: Found keys
[   126.790] (II) NOVATEK USB Keyboard: Configuring as keyboard
[   126.790] (II) XINPUT: Adding extended input device "NOVATEK USB Keyboard" (type: KEYBOARD)
[   126.790] (**) Option "xkb_rules" "evdev"
[   126.790] (**) Option "xkb_model" "evdev"
[   126.790] (**) Option "xkb_layout" "us"
[   126.790] (II) config/udev: Adding input device NOVATEK USB Keyboard (/dev/input/event5)
[   126.790] (**) NOVATEK USB Keyboard: Applying InputClass "evdev keyboard catchall"
[   126.790] (**) NOVATEK USB Keyboard: always reports core events
[   126.790] (**) NOVATEK USB Keyboard: Device: "/dev/input/event5"
[   126.798] (--) NOVATEK USB Keyboard: Found 20 mouse buttons
[   126.798] (--) NOVATEK USB Keyboard: Found keys
[   126.798] (II) NOVATEK USB Keyboard: Configuring as mouse
[   126.798] (II) NOVATEK USB Keyboard: Configuring as keyboard
[   126.798] (**) NOVATEK USB Keyboard: YAxisMapping: buttons 4 and 5
[   126.798] (**) NOVATEK USB Keyboard: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   126.798] (II) XINPUT: Adding extended input device "NOVATEK USB Keyboard" (type: KEYBOARD)
[   126.798] (**) Option "xkb_rules" "evdev"
[   126.798] (**) Option "xkb_model" "evdev"
[   126.798] (**) Option "xkb_layout" "us"
please help.
kszewczyk is offline   Reply With Quote
Old 04-07-11, 04:34 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: KDE fails on second screen

You're trying to configure both separate X screens and TwinView at the same time. I'd suggest letting nvidia-xconfig regenerate the configuration for just TwinView:
Code:
sudo nvidia-xconfig -a --twinview
AaronP is offline   Reply With Quote
Old 04-08-11, 01:34 AM   #3
kszewczyk
Registered User
 
Join Date: Apr 2011
Posts: 3
Default Re: KDE fails on second screen

My goal is to have separate X screens, i am a bit confused right now becouse at work i run ubuntu and i have xorg.conf like this:

Code:
# nvidia-settings:  version 260.19.06  (buildd@palmer)  Mon Oct  4 16:01:38 UTC 2010

#ngs: X configuration file generated by nvidia-settings
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 260.19.06  (buildmeister@builder101)  Mon Sep 13 07:06:38 PDT 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

        # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-0"                                                                                                                                                                                 
    HorizSync       30.0 - 75.0                                                                                                                                                                            
    VertRefresh     48.0 - 70.0                                                                                                                                                                            
    Option         "DPMS"                                                                                                                                                                                  
EndSection                                                                                                                                                                                                 
                                                                                                                                                                                                           
Section "Device"                                                                                                                                                                                           
                                                                                                                                                                                                           
# Removed Option "TwinView" "True"
# Removed Option "MetaModes" "1280x1024,1280x1024; 1024x768,1024x768"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
    Option         "TwinViewOrientation" "RightOf"
    Option         "UseEdidFreqs" "True"
EndSection

Section "Screen"
# Removed Option "metamodes" "CRT-0: nvidia-auto-select +1600+0, CRT-1: 1600x900 +0+0; CRT-0: NULL, CRT-1: 1900x1200 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "NoLogo" "True"
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT-0: 1920x1080 +1600+0, CRT-1: 1600x900 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
and basicly it behave like separate screens , so I didnt really bothered about it as long as it was working.

At home I run gentoo and when I bought second screen I tried to configure in the same way as in work but nothing is this same twinView stretch desktop on two screens but I dont want this behavior (thats why I made changes in xorg.conf).

Naturally I tried separate X screen configurations generated by nvidia-settings, but result is that the second screen is whole black, I checked Xorg log and nothing look suspiciously (no EE ot WW), i dont know what to do next ?


P.S
Sorry for my bad english
kszewczyk is offline   Reply With Quote
Old 04-08-11, 03:28 AM   #4
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: KDE fails on second screen

What do you want to do with the second screen? You do not want it to be used by KDE ("twinView stretch desktop on two screens but I dont want this behavior") and you want it to be used at the same time ("but result is that the second screen is whole black").
Lysius is offline   Reply With Quote
Old 04-08-11, 03:35 AM   #5
kszewczyk
Registered User
 
Join Date: Apr 2011
Posts: 3
Default Re: KDE fails on second screen

I want to be use by KDE, but each screen has to be different desktop.
kszewczyk is offline   Reply With Quote
Old 04-08-11, 09:32 AM   #6
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: KDE fails on second screen

KDE 4 does not support separate X screens. See https://bugs.kde.org/show_bug.cgi?id=256242
AaronP is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:42 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.