Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-14-11, 06:23 PM   #1
oal
Registered User
 
Join Date: Apr 2011
Posts: 4
Default Geforce7600GT, Gnome3: screen corruption on resume with second screen

Card: Geforce7600GT
Kernel: 2.6.38
Driver: 270.41.03
Xorg: X.Org X Server 1.10.0.902
Gnome3
Dual Screen

The background area has screen artifacts (see attached screenshot), mostly after the second time I resume from suspend. Sometimes other screen elements are affected too.

The system appears to be stable afterwards, restarting Xorg seems to fix the problem.

This happened since I started using Gnome3 but did not happen with Gnome2 and compositing enabled.

I haven't been able to reproduce this with only one screen attached.

Thanks for your help.
Attached Thumbnails
Click image for larger version

Name:	Screenshot-3.jpg
Views:	202
Size:	101.0 KB
ID:	42591  
Attached Files
File Type: gz nvidia-bug-report.log.gz (97.9 KB, 65 views)
oal is offline   Reply With Quote
Old 04-14-11, 07:26 PM   #2
Plagman
NVIDIA Corporation
 
Plagman's Avatar
 
Join Date: Sep 2007
Posts: 254
Default Re: Geforce7600GT, Gnome3: screen corruption on resume with second screen

Hi, I don't see anything attached. Can you upload your screenshot somewhere?

Thanks,
- Pierre-Loup
Plagman is offline   Reply With Quote
Old 04-15-11, 04:40 AM   #3
oal
Registered User
 
Join Date: Apr 2011
Posts: 4
Default Re: Geforce7600GT, Gnome3: screen corruption on resume with second screen

Sorry, I messed up the attachments. I added them back to the original post.
oal is offline   Reply With Quote
Old 04-22-11, 04:22 AM   #4
oal
Registered User
 
Join Date: Apr 2011
Posts: 4
Default Re: Geforce7600GT, Gnome3: screen corruption on resume with second screen

Disabling and enabling a screen with nvidia-settings also removes the artifacts.

Is there anything else I can do to help fix the problem?
oal is offline   Reply With Quote
Old 05-14-11, 07:49 PM   #5
oal
Registered User
 
Join Date: Apr 2011
Posts: 4
Default Re: Geforce7600GT, Gnome3: screen corruption on resume with second screen

I have found another failure mode when switching users.

1) From user A, use the "switch user" function
2) logon as user B at gdm screen
3) use the "switch user" function
4) logon as user A again
5) => screen corruption on both logins

the intermediary gdm screen is uncorrupted
oal is offline   Reply With Quote
Old 05-15-11, 05:23 PM   #6
markz79
Registered User
 
Join Date: May 2010
Posts: 1
Default Re: Geforce7600GT, Gnome3: screen corruption on resume with second screen

I also experience screen corruption when resuming from suspend, but only using one display. Other people with the same issue here:
https://bbs.archlinux.org/viewtopic.php?id=118077

If you need further details or help debugging let me know.

Details
=====

Kernel 2.6.38-6
Dell XPS M1530
01:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8600M GT] (rev a1)
nvidia 270.41.06-1
markz79 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:01 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.