Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-06-11, 01:51 PM   #49
artem
Registered User
 
Join Date: Jun 2006
Posts: 704
Default Re: NVIDIA, please, fix Adobe Flash 10.2.x and 10.3.x

Quote:
Originally Posted by MaDDeePee View Post
Hi,
how do you determine if its enabled or not? Is there any testing tool?
You need to create a /etc/adobe/mms.cfg file and fill it with
Code:
EnableLinuxHWVideoDecode=1
OverrideGPUValidation=true
Then find any HD YouTube video, start playing it, right mouse click it and choose "Show video info".

If VDPAU acceleration is actually used, you'll see "accelerated output", if it's not enabled you'll see "software renderer".
artem is offline   Reply With Quote
Old 06-06-11, 06:58 PM   #50
Salem
Registered User
 
Join Date: Jun 2011
Posts: 1
Default Re: NVIDIA, please, fix Adobe Flash 10.2.x and 10.3.x

Hi, have a smiliar problem here:

Code:
Jun  7 00:59:17 veerle kernel: [16120.720913] npviewer.bin[24325]: segfault at 218 ip 00000000f4795806 sp 00000000ffe17498 error 6 in libflashplayer.so[f4519000+bc1000]
Jun  7 00:59:32 veerle kernel: [16135.168867] NVRM: Xid (0000:07:00): 8, Channel 00000004   
Jun  7 00:59:34 veerle kernel: [16137.165611] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
Jun  7 00:59:48 veerle kernel: [16151.152744] NVRM: Xid (0000:07:00): 13, 0001 00000000 00008397 000015e0 00000000 00000080
Opened a Flash website with Chromium, after ~5 seconds X freezed. I tried to kill chromium/X, but only a restart (via SysRq) fixed the problem.

Versions:
nvidia: 270.41.06
X: 1.9.5
Flash: 10.3.181.14-r1
Kernel: 2.6.38

Hope it's really a software and not a hardware problem :-(
Salem is offline   Reply With Quote
Old 06-07-11, 09:47 AM   #51
artem
Registered User
 
Join Date: Jun 2006
Posts: 704
Default Re: NVIDIA, please, fix Adobe Flash 10.2.x and 10.3.x

It's a software problem, alas, NVIDIA and Adobe don't even try to solve it.
artem is offline   Reply With Quote
Old 06-09-11, 05:13 PM   #52
MaDDeePee
Registered User
 
Join Date: Aug 2010
Posts: 41
Default Re: NVIDIA, please, fix Adobe Flash 10.2.x and 10.3.x

For some reason i'm unable to active hardware output.
It always shows me software renderer, no matter if 10.1 or the new Flash 11 beta.
Maybe again this is a composite / xinerama problem?

Edit:

Oh, wait! Im using 10,1,102,64 because there is no such overlay bug. This doesn't support vdpau at all, does it?
(yes, i got a mms.cfg and those stings are in there, card is vdpau capable )
MaDDeePee is offline   Reply With Quote
Old 06-10-11, 07:46 AM   #53
artem
Registered User
 
Join Date: Jun 2006
Posts: 704
Default Re: NVIDIA, please, fix Adobe Flash 10.2.x and 10.3.x

Adobe Flash Player 10,1,102,64 is almost a year old - it doesn't support VDPAU at all.
artem is offline   Reply With Quote
Old 06-15-11, 06:10 AM   #54
one_and_only
Registered User
 
Join Date: Mar 2007
Posts: 47
Default Re: NVIDIA, please, fix Adobe Flash 10.2.x and 10.3.x

Using version 10.3.181.26 with latest nvidia-driver, nspluginwrapper and chromium:
I gave hardware acceleration, even right click on youtube video and showing video info says I'm using software video rendering -> cpu usage is below 5% with 1080p video so it must be GPU.
On the other hand, it causes known overlay bug, so the optinos are:
- GPU rendering with overlay bug
- Software rendering without overlay bug (just right click on flash content, settings and disable hardware acceleration)
one_and_only is offline   Reply With Quote
Old 06-15-11, 07:18 AM   #55
artem
Registered User
 
Join Date: Jun 2006
Posts: 704
Default Re: NVIDIA, please, fix Adobe Flash 10.2.x and 10.3.x

I can confirm that GPU acceleration works, but the overlay issue is not fixed.

I'm not sure about the rest of the bugs (which cause freezes and Xid errors).
artem is offline   Reply With Quote
Old 06-29-11, 04:06 PM   #56
Huk
Registered User
 
Join Date: Dec 2006
Posts: 12
Default Re: NVIDIA, please, fix Adobe Flash 10.2.x and 10.3.x

With drivers 275.09.07, player version 10.3.181.34, GF9800GT and /etc/adobe/mms.cfg overrides, VDPAU acceleration is working pretty good, of course the bug is still there... also bug is present when "normal" acceleration is enabled and VDPAU is disabled (EnableLinuxHWVideoDecode=0, I got "accelerated video rendering" AND "software video decoding" then, with VDPAU both are "accelerated"). Well now if it only wasn't for that stupid overlay bug it would work perfectly for me...
Huk is offline   Reply With Quote

Old 07-01-11, 10:54 AM   #57
DBabo
Registered User
 
Join Date: Dec 2010
Posts: 15
Default Re: NVIDIA, please, fix Adobe Flash 10.2.x and 10.3.x

Quote:
Originally Posted by artem View Post
You need to create a /etc/adobe/mms.cfg file and fill it with
Code:
EnableLinuxHWVideoDecode=1
OverrideGPUValidation=true
Then find any HD YouTube video, start playing it, right mouse click it and choose "Show video info".

If VDPAU acceleration is actually used, you'll see "accelerated output", if it's not enabled you'll see "software renderer".
cool. Thank you Artem. indeed my CPU utilization dropped significantly.
Yet when i'm going to hbo.com and , for example, go to "sports -> Boxing" - it basically crashes the firefox ... no logs...
DBabo is offline   Reply With Quote
Old 07-01-11, 01:48 PM   #58
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: NVIDIA, please, fix Adobe Flash 10.2.x and 10.3.x

Quote:
Originally Posted by Huk View Post
With drivers 275.09.07, player version 10.3.181.34, GF9800GT and /etc/adobe/mms.cfg overrides, VDPAU acceleration is working pretty good, of course the bug is still there... also bug is present when "normal" acceleration is enabled and VDPAU is disabled (EnableLinuxHWVideoDecode=0, I got "accelerated video rendering" AND "software video decoding" then, with VDPAU both are "accelerated"). Well now if it only wasn't for that stupid overlay bug it would work perfectly for me...
I dont know about the 9800, but i have a 8200 and after viewing an accelerated flash clip i get tearing in any subsequent vdpau instance with any player (regardless if the browser is closed). This lasts until reboot or the nvidia driver reload.
So its not only the overlay bug is the issue.

Quote:
cool. Thank you Artem. indeed my CPU utilization dropped significantly.
Yet when i'm going to hbo.com and , for example, go to "sports -> Boxing" - it basically crashes the firefox ... no logs...
Not every site supports vdpau. Youtube does, but i did not have any success with others.
gradinaruvasile is offline   Reply With Quote
Old 07-02-11, 04:10 AM   #59
MaDDeePee
Registered User
 
Join Date: Aug 2010
Posts: 41
Default Re: NVIDIA, please, fix Adobe Flash 10.2.x and 10.3.x

Is it just me or is the Vdpau layer problem fixed with 280.04?
I can get a message for "accelerated Video decoding / rendering" on youtube video information AND i don't get this dirty layer problem in "black fonts" / whatever.

If i'm not wrong there:

THANKS FOR FIXING IT!

Edit: Never mind, its still bugged but it doesn't stick to the background anymore. Other windows covering it in a layer above the video make the video visible in black (fonts etc.).
MaDDeePee is offline   Reply With Quote
Old 07-09-11, 04:06 AM   #60
luother
Guest
 
Posts: n/a
Default Re: NVIDIA, please, fix Adobe Flash 10.2.x and 10.3.x

Thought that too, but it worked only with the first youtube video I tried. All videos afterwards were screwed.
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:45 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.