Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-20-11, 02:38 AM   #1
Elmar Krieger
Registered User
 
Join Date: Feb 2008
Posts: 2
Default Viewsonic V3D241wm 3D screen stuck at 60Hz in Linux, but works fine in Windows 7

Dear NVIDIA Support team,

I've got 10 years of experience fiddling with xorg.conf files, but now I'm stuck:

I bought the Viewsonic V3D241wm 3D screen, which shows 3D with 1920x1080 pixels at 100-120 Hz and comes with its own shutter glasses. If I boot the PC to Windows 7, I can select the high refresh rates, and the shutter glasses work fine, so the hardware incl. Dual-Link DVI cable is OK.

In Linux however (CentOS 5.6, latest driver 260.19.44, see below), I'm completely stuck at 60Hz and cannot set any higher refresh rate.

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro FX 1800/PCI/SSE2
OpenGL version string: 3.3.0 NVIDIA 260.19.44
(see also attached nvidia-bug-report.log.gz)

So far, I tried three things:

1) Beginner's approach:

Run nvidia-settings as root, which offers me to select the high refresh rates 100Hz, 101Hz, 110Hz, 120Hz and 121Hz. If I select any of these, the screen turns black, then a dialog asks me if the new setting is OK. Unfortunately the monitor's on-screen-display still shows 60Hz, and also my 3D applications confirm that it's 60Hz. (In Windows 7, the monitor's on-screen-display always showed the 100Hz..120Hz refresh rates correctly, so the bug does not sit in the on screen display).

2) Intermediate approach:

Edit xorg.conf, verify that the HorizSync and VertRefresh settings are OK, add option "ModeValidation" "AllowNon60HzDFPModes" and select mode 1920x1080_100 as the only one:

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "ViewSonic V3D241wm"
HorizSync 24.0 - 186.0
VertRefresh 50.0 - 122.0
Option "DPMS"
Option "ModeValidation" "AllowNon60HzDFPModes"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "Stereo" "3"
SubSection "Display"
Depth 24
Modes "1920x1080_100"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "off"
EndSection

When restarting the X-server and looking at /var/log/Xorg.0.log, the 100Hz mode is properly validated:

(II) Apr 20 10:10:30 NVIDIA(0): NVIDIA GPU Quadro FX 1800 (G94GL) at PCI:1:0:0 (GPU-0)
(--) Apr 20 10:10:30 NVIDIA(0): Memory: 786432 kBytes
(--) Apr 20 10:10:30 NVIDIA(0): VideoBIOS: 62.94.6e.00.24
(II) Apr 20 10:10:30 NVIDIA(0): Detected PCI Express Link width: 16X
(--) Apr 20 10:10:30 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) Apr 20 10:10:30 NVIDIA(0): Connected display device(s) on Quadro FX 1800 at
PCI:1:0:0
(--) Apr 20 10:10:30 NVIDIA(0): ViewSonic V3D241wm (DFP-0)
(--) Apr 20 10:10:30 NVIDIA(0): ViewSonic V3D241wm (DFP-0): 330.0 MHz maximum pi
xel clock
(--) Apr 20 10:10:30 NVIDIA(0): ViewSonic V3D241wm (DFP-0): Internal Dual Link T
MDS
(II) Apr 20 10:10:30 NVIDIA(0): Mode Validation Overrides for ViewSonic V3D241wm
(DFP-0):
(II) Apr 20 10:10:30 NVIDIA(0): AllowNon60HzDFPModes
(II) Apr 20 10:10:30 NVIDIA(0): Assigned Display Device: DFP-0
(II) Apr 20 10:10:30 NVIDIA(0): Validated modes:
(II) Apr 20 10:10:30 NVIDIA(0): "1920x1080_100"
(II) Apr 20 10:10:30 NVIDIA(0): Virtual screen size determined to be 1920 x 1080
(--) Apr 20 10:10:30 NVIDIA(0): DPI set to (93, 94); computed from "UseEdidDpi"

But nastily, the screen still runs at 60Hz, no matter what.


3) Advanced approach:

I found the modelines for the V3D241wm at this site:
http://www.ixbt.com/monitor/viewsoni...oninfo-dvi.txt

So I turned off all EDID stuff I could find in xorg.conf and added the modelines:

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "ViewSonic V3D241wm"
HorizSync 24.0 - 186.0
VertRefresh 50.0 - 122.0
#Detailed timing #1....... 1920x1080p at 121Hz (16:9)
Modeline "1920x1080_121" 287.670 1920 1968 2000 2080 1080 1083 1088 1143 +hsync +vsync
#Detailed timing #2....... 1920x1080p at 110Hz (16:9)
Modeline "1920x1080_110" 260.250 1920 1968 2000 2080 1080 1083 1088 1138 +hsync +vsync
#Detailed timing #3....... 1920x1080p at 101Hz (16:9)
Modeline "1920x1080_101" 237.810 1920 1968 2000 2080 1080 1083 1088 1132 +hsync +vsync
#Detailed timing #4....... 1920x1080p at 120Hz (16:9)
Modeline "1920x1080_120" 329.470 1920 1968 2000 2080 1080 1083 1088 1320 +hsync +vsync
#Detailed timing #5....... 1920x1080p at 100Hz (16:9)
Modeline "1920x1080_100" 328.640 1920 1968 2000 2080 1080 1083 1088 1580 +hsync +vsync
Option "DPMS"
Option "UseEDIDFreqs" "False"
Option "IgnoreEDIDChecksum" "DFP-0"
Option "ModeValidation" "NoEdidModes,AllowNon60HzDFPModes,NoMaxPClkChe ck"

EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "Stereo" "3"
SubSection "Display"
Depth 24
Modes "1920x1080_100" "1920x1080_101" "1920x1080_110" "1920x1080_120" "1920x1080_121"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "off"
EndSection


Unfortunately, my modelines are all rejected according to /var/log/Xorg.0.log:


(II) Apr 19 11:40:29 NVIDIA(0): NVIDIA GPU Quadro FX 1800 (G94GL) at PCI:1:0:0 (GPU-0)
(--) Apr 19 11:40:29 NVIDIA(0): Memory: 786432 kBytes
(--) Apr 19 11:40:29 NVIDIA(0): VideoBIOS: 62.94.6e.00.24
(II) Apr 19 11:40:29 NVIDIA(0): Detected PCI Express Link width: 16X
(--) Apr 19 11:40:29 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) Apr 19 11:40:29 NVIDIA(0): Connected display device(s) on Quadro FX 1800 at PCI:1:0:0
(--) Apr 19 11:40:29 NVIDIA(0): ViewSonic V3D241wm (DFP-0)
(--) Apr 19 11:40:29 NVIDIA(0): ViewSonic V3D241wm (DFP-0): 330.0 MHz maximum pixel clock
(--) Apr 19 11:40:29 NVIDIA(0): ViewSonic V3D241wm (DFP-0): Internal Dual Link TMDS
(II) Apr 19 11:40:29 NVIDIA(0): Mode Validation Overrides for ViewSonic V3D241wm (DFP-0):
(II) Apr 19 11:40:29 NVIDIA(0): AllowNon60HzDFPModes
(II) Apr 19 11:40:29 NVIDIA(0): NoMaxPClkCheck
(II) Apr 19 11:40:29 NVIDIA(0): NoEdidModes
(II) Apr 19 11:40:29 NVIDIA(0): Assigned Display Device: DFP-0
(WW) Apr 19 11:40:29 NVIDIA(0): No valid modes for "1920x1080_100"; removing.
(WW) Apr 19 11:40:29 NVIDIA(0): No valid modes for "1920x1080_101"; removing.
(WW) Apr 19 11:40:29 NVIDIA(0): No valid modes for "1920x1080_110"; removing.
(WW) Apr 19 11:40:29 NVIDIA(0): No valid modes for "1920x1080_120"; removing.
(WW) Apr 19 11:40:29 NVIDIA(0): No valid modes for "1920x1080_121"; removing.
(WW) Apr 19 11:40:29 NVIDIA(0):
(WW) Apr 19 11:40:29 NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) Apr 19 11:40:29 NVIDIA(0): "nvidia-auto-select".


Looks like you are now my only hope!

Thanks,
Elmar
Attached Files
File Type: gz nvidia-bug-report.log.gz (41.2 KB, 79 views)
Elmar Krieger is offline   Reply With Quote
Old 04-20-11, 06:45 AM   #2
poltsy
Registered User
 
Join Date: Jan 2010
Posts: 26
Default Re: Viewsonic V3D241wm 3D screen stuck at 60Hz in Linux, but works fine in Windows 7

Check if GPU scaling is forced enabled in nvidia-settings as it will force default refresh rate and will cause all your settings to have no effect on the actual output even though all the tools will say you're getting what you asked for.

Note that settings you change in nvidia-settings will only be applied once you run it so you have to run it every time X restarts. If you run it as root it will apply settings from /root and if you run it as user it'll get them from the user $home so if you're not always running it as the same user the behaviour might seem a little indeterministic. I'm not really sure if running it as root has any purpose to begin with.

If that doesn't actually change anything you could start the X server with -logverbose 6 to get a better idea what exactly it is about the modeline that makes it fail the validation (and adjust any limits accordingly).
poltsy is offline   Reply With Quote
Old 04-20-11, 09:54 AM   #3
Elmar Krieger
Registered User
 
Join Date: Feb 2008
Posts: 2
Default Re: Viewsonic V3D241wm 3D screen stuck at 60Hz in Linux, but works fine in Windows 7

Dear Poltsy,

many thanks, you saved the day. As soon as I disabled GPU scaling, everything worked. I'll forward this to linux-bugs(a)nvidia.com, so that they can fix this unbelievable pitfall...

Best regards,
Elmar

Quote:
Originally Posted by poltsy View Post
Check if GPU scaling is forced enabled in nvidia-settings as it will force default refresh rate and will cause all your settings to have no effect on the actual output even though all the tools will say you're getting what you asked for.

Note that settings you change in nvidia-settings will only be applied once you run it so you have to run it every time X restarts. If you run it as root it will apply settings from /root and if you run it as user it'll get them from the user $home so if you're not always running it as the same user the behaviour might seem a little indeterministic. I'm not really sure if running it as root has any purpose to begin with.

If that doesn't actually change anything you could start the X server with -logverbose 6 to get a better idea what exactly it is about the modeline that makes it fail the validation (and adjust any limits accordingly).
Elmar Krieger is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:37 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.