Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-27-11, 07:03 AM   #1
Nek
Registered User
 
Join Date: Apr 2011
Posts: 1
Default GT220 & Xorg delay at startup

Using latest drivers 270.41.06 (and previous ones from 270.x) the time it takes to startup Xorg 1.10 (and previous versions back to 1.7) is almost 7 full seconds (with no disk activity). This does not happen with other nvidia cards, as I tested it with my laptop which has a Geforce Go 7400 and Xorg (same driver and xorg versions) starts up in just 1 second.

Xorg.log produces no errors at all and it just shows a delay of 5 seconds in the point where the nvidia driver probes and initializes the GPU. This same point, in my laptop takes atmost 0.5 seconds only. I have tried almost all of the nvidia driver options in X Config and none seem to mitigate the delay.

Steps to reproduce:

1. First remove the nvidia kernel module
Code:
$ rmmod nvidia
2. Then start Xorg
Code:
$ Xorg -pogo
Code:
System details
OS: Arch Linux x64 2.6.38-ARCH, Xorg v1.10, Nvidia drivers v270.41.06
CPU: Core 2 duo E6400
GPU: Nvidia GT220
MB: Asus P5Q
How much time does your system takes to startup xorg (Use Xorg -pogo to do the benchmark)? Is this problem known and is there a solution?
Nek is offline   Reply With Quote
Old 04-30-11, 03:54 AM   #2
steffen_b
Registered User
 
Join Date: Dec 2010
Posts: 10
Default Re: GT220 & Xorg delay at startup

We can confirm this with multiple setups using G210/ION2
OS is amd64 Natty, kernel 2.6.38-8
when looking at bootchart it takes 8-10s from Xorg start until the wm starts

I will try to get the data you are requesting later for these.

For my 32bit natty installation (E7400, G210, 4GB DDR3 mem) its:
real 0m3.057s

I will reinstall this weekend with 64bit and provide the time from there.
steffen_b is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:43 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.