Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-18-03, 04:13 AM   #13
lrj
Registered User
 
Join Date: Aug 2003
Posts: 6
Talking the README gives Via users advice

Hi,

I was reading the nVidia README file (located in /usr/share/doc/NVIDIA_GLX-1.0/README it can also be accessed online too) and under Appendix F - Configuring AGP it mentions that for Via based motherboards that the AGP drive strenth settings in the BIOS affect nVidia boards. I had set mine to the max when I changed to the 5200 which of course I shouldn't have according to the README. I've just reset that to EE - the maximum value - and I'm running with nVidia AGP enabled in X without the "mem=nopentium" and waiting for a lock up, if any. You may want to check if it is set to auto or disabled. As the README warns, be very careful with the BIOS settings. I'm not sure if you've ever change any BIOS settings before but if you haven't and don't feel comfortable then have someone else do it that has experience in that area. Since it is your "work" PC you don't want to render it unusable.

As far as kernel configuration goes, I use a custom built 2.4.21 kernel in Debian and I've set mine to use 4GB High Memory Support because I have 1.5GB of RAM as I stated before and the help for the kernel's configuration settings says that for systems with 1GB - 4GB of RAM that you should select 4GB. I really don't think that's the problem with nVidia & Via. I think it is safe for you to go with the BIGMEM kernel because you do have 1GB of RAM.

Also, I have my AGP aperture set to 128MB the same as the board comes with. I had tried 64MB and it seemed to perform slower. I plan to try 256MB to see if that will give better performance but one thing at a time.

Also, I personally use nVidia's AGP as it seems to give better performance when using AGP. If you choose to do the same, you'd have to go with the "NvAGP" option set to "1" (the default is 3 according to the README). To check if it is enabled just do "cat /proc/drivers/nvidia/agp/status" in an xterm or from a virtual terminal once X is running.

I'll let you know if the new BIOS setting works for me. :-)
lrj is offline   Reply With Quote
Old 08-25-03, 11:22 PM   #14
jerone2
Registered User
 
Join Date: Mar 2003
Posts: 14
Unhappy

Well,
Just grabed 2.4.22 and applied Highmem for 4G support and IT STILL DOESN'T WORK. Same old things happen. So all the Highmem theories are in the garabage. The new via chipset driver doesn't seem to fix anything either. Oh well there is allways Athlon 64, let's hope that the chipsets available for it don't have these types of issues!!!!!
jerone2 is offline   Reply With Quote
Old 08-26-03, 04:40 AM   #15
lrj
Registered User
 
Join Date: Aug 2003
Posts: 6
Default BIOS settings work for the most part

Well,

I've been running with the AGP BIOS settings and it locked up on me twice since then that I can relate to AGP. I'm using the latest nVidia drivers 4496. I'd recommend checking your BIOS settings.

My motherboard is using the Award BIOS. The AGP settings I have in my BIOS for AGP are as follows:

in the Advanced Chipset Features section

AGP Aperture Size = 128M
AGP 4x Mode = Enabled
AGP Driving Control = Manual
AGP Driving Value = EE
Fast Write Support = Supported

The driving value is the one I mentioned in my previous post that was in the driver's README file. I can't say it'll be that easy to find in your BIOS but if it is that's what you should set.

My system is stable with AGP enabled in X and I'm running the 3D screensavers & my games with no problems now. :-)
lrj is offline   Reply With Quote
Old 08-26-03, 07:56 AM   #16
jerone2
Registered User
 
Join Date: Mar 2003
Posts: 14
Default

,
Hey thanks for the advice, but those settings did more harm then good on my system. If it wasn't the initial kernel panic, when the login screen whould come up it would be jumbled and locked. Now one thing I am using that you may not be is DVI, and there have been issues in the past, and it could be that DVI is just adding to the issue (But you couldn't take DVI out of my dead cold hands!).
jerone2 is offline   Reply With Quote
Old 08-28-03, 04:03 PM   #17
lrj
Registered User
 
Join Date: Aug 2003
Posts: 6
Angry Wow! Bummer...

Sorry those settings didn't work, my system is very stable with my current BIOS AGP settings. It really sucks that it didn't help ya.

My next upgrade will be the motherboard / CPU / RAM and for that I'm going with something NOT Via-based. That way there shouldn't be any more of these problems (hopefully). That's the only other solution I can see next to running without AGP.

Unless the 2.6 kernel can overcome it. I'm waiting/hoping to see if/when nVidia will release drivers for that kernel although I am tempted to try the patch that is out there to get the nVidia drivers running on 2.6 before that happens. Maybe I'll play around with it on the weekend.

Good luck!

P.S. I stopped using Red Hat a long time ago. Try Knoppix. It's an unstable Debian that you can run off a CD to try it out and there is an installation script for installing it to your hard drive. www.knopper.net/knoppix It is the easiest Debian install I've seen. I'm very pleased with it as a whole.
lrj is offline   Reply With Quote
Old 08-29-03, 04:20 AM   #18
pii350mmxpc100
Registered User
 
Join Date: Aug 2002
Posts: 34
Lightbulb Re: Nvidia Driver + AGP + 1GIG RAM = HANG!

Quote:
Originally posted by jerone2
Hey,

Here are my specs:
Redhat 9
Geforce 4 4600 (using DVI port)
Samsung 191T
Abit KT7A (VIA Board)
1 Gig Crucial PC 133 (1x512 , 2x256)
Athlon 1.2 @ 133 , no overclocking here
Intel ethernet card
Is all your System RAM Double sided, or is there a single side Stick in there as well?
Or vice-versa ?

You never know, It might mater. http://www.nvnews.net/vbulletin/images/icons/icon3.gif
pii350mmxpc100 is offline   Reply With Quote
Old 08-31-03, 02:06 PM   #19
mesa
Registered User
 
Join Date: Aug 2003
Posts: 1
Default

Quote:
Originally posted by Tommi
I am not totally sure, but if I remember correctly, the BIGMEM architecture is for those who has over 4 gigabytes of RAM. But if I am wrong it may be wise for me to install BIGMEM kernel, but I think that when I tried that many months ago, Linux said, that I didnt have enough memery for BIGMEM kernel. I have also 1 gigabyte of DDR ram in my comp.

The highmem option in the kernel is for machines with more than 960 megabytes of system ram.

If you have 1 Gig system ram you should enable this option in the kernel.

From the kernel itself:

If the machine has between 1 and 4 Gigabytes physical RAM, then answer "4GB" here.

peace,
mesa

-Tommi
mesa is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver quality decrease? legluondunet NVIDIA Linux 17 06-26-12 10:03 AM
NVIDIA Driver Installation flores.facundo NVIDIA Linux 2 06-24-12 08:37 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM

All times are GMT -5. The time now is 03:28 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.