Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-02-11, 04:04 PM   #1
valeriot
Registered User
 
Join Date: May 2011
Posts: 1
Default No HDMI devices by aplay with Nvidia 9500GT with alsa 1.0.23 and linux 2.6.38-r3

Hi, after a long try i post here.
Recently i'm passed to a new motherboard Asus P7H55M Pro, i've insert hda-intel hdmi display port into the kernel, but the hdmi audio output of my geforce 9500gt isn't recognized.

I attach the nvidia-bug-report log.
Attached Files
File Type: gz nvidia-bug-report.log.gz (44.7 KB, 88 views)
valeriot is offline   Reply With Quote
Old 05-02-11, 07:35 PM   #2
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: No HDMI devices by aplay with Nvidia 9500GT with alsa 1.0.23 and linux 2.6.38-r3

The GeForce 9xxx series didn't have HDMI audio controllers on the GPU. That is why you don't see any HDMI audio devices.

In Stephen's GPU HDMI Audio Document, this is what is referred to in section 3.1 as "Pre-Azalia":

Quote:
Some older GPUs included a connector to receive S/PDIF audio from a separate sound card, and route that audio over HDMI. This document does not cover such devices at all.
Look for a 3-pin header on your GPU board near the HDMI port. Usually it's labeled "SPDIF IN". You will need to connect this header to some SPDIF output on some sound controller, since the GPU doesn't have a sound controller of its own. It is this sound controller that you will be driving via ALSA.

Once you have the header connected, audio playing over that SPDIF output will be passed through to the HDMI port.

[1] ftp://download.nvidia.com/XFree86/gp...dmi-audio.html
danix is offline   Reply With Quote
Old 05-03-11, 05:48 AM   #3
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: No HDMI devices by aplay with Nvidia 9500GT with alsa 1.0.23 and linux 2.6.38-r3

Quote:
Originally Posted by danix View Post
The GeForce 9xxx series didn't have HDMI audio controllers on the GPU. That is why you don't see any HDMI audio devices.
In Stephen's GPU HDMI Audio Document, this is what is referred to in section 3.1 as "Pre-Azalia"
Why can't you guys just list the "Pre-Azalia" cards there?
Licaon is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:28 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.