Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-15-11, 06:27 AM   #1
wizardnumbernex
Registered User
 
Join Date: May 2011
Posts: 1
Default TwinView on two CRTs with modelines

TwinView is weirdest stuff I ever encountered.
I eventually got "working" TwinView with displays turned on and used right for X start. I was trying all day to get it to that stage. I won't mind turned of TV (it by DVI->VGA cable), but turning it on in nvidia-setting stilling me compositing and VPDAU (or at least most of accelerations) and its permanent.
Eventually I got it working, but now nvidia doing what it want with my CRT. It suppose to start in 1600x1200@76Hz, now its 1600x1200@75Hz, which is completely wrong. I do not want this mode. I want VESA CVT 1600x1200@76Hz mode back. When I shall switch to it on nvidia-settings all acceleration is gone yet another time.

there are relevant parts of xorg.conf
<code>
Section "Monitor"
Option "CRT-1" "LG_F700P"
Identifier "LGeF700P"
VendorName "LG Electronics"
ModelName "F700P"
HorizSync 30.0 - 96.0
VertRefresh 50.0 - 160.0
DisplaySize 330 250
Option "PreferredMode" "1600x1200"
Option "Primary" "1"
Option "DPMS"
EndSection

Section "Monitor"
Option "CRT-0" "Technika"
Identifier "Technika"
VendorName "CVT"
ModelName "CVT"
HorizSync 31.5 - 80.0
VertRefresh 60.0 - 75.0
Option "PreferredMode" "1680x1050_CVT"
Option "UseDisplayDevice" "CRT-0"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "nVidia GeForce 8800 GTS"
# BusID "PCI:3:0:0"
Option "CursorShadow" "1"
Option "AllowDDCCI" "1"
Option "ModeValidation" "NoMaxPClkCheck, NoEdidMaxPClkCheck"
Option "MultisampleCompatibility" "1"
Option "TripleBuffer" "1"
Option "BackingStore" "1"
Option "AllowSHMPixmaps" "1"
Option "UseEvents" "1"
Option "DamageEvents" "1"
Option "CoolBits" "5"
Option "ConnectedMonitor" "CRT-1, CRT-0"
Screen 0
EndSection


Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "LGeF700P"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "CRT-1, CRT-0"
Option "TwinViewOrientation" "CRT-0 RightOf CRT-1"
Option "HorizSync" "CRT-1: 30.0-96.0; CRT-0: 31.5-80.0"
Option "VertRefresh" "CRT-1: 50.0-160.0; CRT-0: 60.0-75.0"
# Option "MetaModes" "CRT-0: 1680x1050_CVT, CRT-1: 1600x1200; CRT-0: 1680x1050_CVT, CRT-1: 1280x960; CRT-0: 1680x1050_CVT, CRT-1: 1024x768; CRT-0: 1680x1050_CVT, CRT-1: 800x600; CRT-0: 1680x1050_CVT, CRT-1: 640x480; CRT-0: 1680x1050_CVT, CRT-1: 2048x1536; CRT-0: 1680x1050_CVT, CRT-1: 1920x1440; CRT-0: 1680x1050_CVT, CRT-1: 1280x1024"
SubSection "Display"
Depth 24
# Modes "1600x1200" "1536x1152" "1400x1050" "1280x960" "1024x768" "800x600" "768x576" "640x480" "2048x1536" "1920x1440" "1920x1200" "1680x1050" "1680x1050_CVT" "1440x900" "1280x800" "1280x768" "800x480" "1920x1080" "1366x768" "1280x720" "1024x576" "854x480" "2048x1080" "1280x1024"
EndSubSection
EndSection
</code>
I had to comment Modes and MetaModes to get it work. If I shall uncomment any of them, it will stop working.
wizardnumbernex is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:32 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.