Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-14-11, 08:31 AM   #13
NitDawg
Registered User
 
Join Date: Jun 2011
Posts: 4
Default Re: XServer freezes on start using nVidia 270.xx drivers on Geforce 9300 IGP

Quote:
Originally Posted by Evilandi666 View Post
As you see here the same thing happens on Windows 7 x64 .. install newest nvidia drivers -> BSOD.

But it seems to be only on x64 on Windows 7 .. did anyone try a x86 (32bit) linux instead of x64? Maybe it's also only a x64 problem in linux.
FWIW, I'm not running Linux, but I've had BSOD problems with anything > 260.99 on two different rigs that use the 9300, Win7, both x86 and x64. I've stuck with 257.21. I keep trying the latest and greatest, but I get the same result every time.
NitDawg is offline   Reply With Quote
Old 06-14-11, 11:19 AM   #14
Evilandi666
Registered User
 
Join Date: Jun 2011
Posts: 35
Default Re: XServer freezes on start using nVidia 270.xx drivers on Geforce 9300 IGP

Today 275.09.07 came out, I don't think it helps, but did anyone try?
Evilandi666 is offline   Reply With Quote
Old 06-14-11, 11:54 AM   #15
vallor
Packet Pimp
 
Join Date: Feb 2006
Posts: 5
Default Re: XServer freezes on start using nVidia 270.xx drivers on Geforce 9300 IGP

Tried 275.09.07 -- didn't fix the problem.

[pre]
[ 599.833080] BUG: unable to handle kernel NULL pointer dereference at 0000000000000a50
[ 599.833085] IP: [<ffffffffa29f86c6>] _nv008541rm+0xf1/0x115 [nvidia]
[ 599.833318] PGD 60581067 PUD 37a30067 PMD 0
[ 599.833321] Oops: 0000 [#1] SMP
[ 599.833323] last sysfs file: /sys/bus/acpi/drivers/NVIDIA ACPI Video Driver/uevent
[ 599.833326] CPU 1
[ 599.833327] Modules linked in: nvidia(P) sunrpc cpufreq_ondemand acpi_cpufreq freq_table mperf ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_physdev tuner_simple tuner_types ipt_MASQUERADE iptable_nat ip6table_filter ip6_tables nf_nat coretemp snd_hda_codec_hdmi snd_hda_codec_realtek tda9887 tda8290 wm8775 tuner snd_hda_intel snd_hda_codec snd_hwdep snd_seq cx25840 snd_seq_device pvrusb2 snd_pcm dvb_core cx2341x v4l2_common videodev v4l2_compat_ioctl32 tveeprom joydev snd_timer i2c_nforce2 snd i2c_core microcode forcedeth serio_raw pcspkr video soundcore wmi shpchp snd_page_alloc ipv6 [last unloaded: nvidia]
[ 599.833357]
[ 599.833359] Pid: 2630, comm: Xorg Tainted: P 2.6.38.8 #2 NVIDIA MCP7A/MCP7A
[ 599.833362] RIP: 0010:[<ffffffffa29f86c6>] [<ffffffffa29f86c6>] _nv008541rm+0xf1/0x115 [nvidia]
[ 599.833514] RSP: 0018:ffff880069a518c8 EFLAGS: 00010246
[ 599.833515] RAX: 0000000000000000 RBX: 0000000000000000 RCX: 000000000000000f
[ 599.833517] RDX: 0000000000000000 RSI: 0000000000000000 RDI: ffff880069c10000
[ 599.833519] RBP: ffff880060de5d78 R08: 0000000000000007 R09: 0000000000000021
[ 599.833520] R10: 0000000000000021 R11: 0000000000000021 R12: ffff880037b0c000
[ 599.833522] R13: 0000000000000000 R14: ffff880069c10000 R15: ffff880060404000
[ 599.833524] FS: 00007f6b2bdb68a0(0000) GS:ffff88006fc80000(0000) knlGS:0000000000000000
[ 599.833526] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 599.833527] CR2: 0000000000000a50 CR3: 0000000068b99000 CR4: 00000000000406e0
[ 599.833529] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[ 599.833531] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[ 599.833533] Process Xorg (pid: 2630, threadinfo ffff880069a50000, task ffff880069d94530)
[ 599.833534] Stack:
[ 599.833535] 0000000000000000 ffff880037b0c000 ffff880069c10000 ffff880060404000
[ 599.833539] 0000000000000000 ffffffffa29f887c 0000000000000000 0000000000000000
[ 599.833542] ffff880037b0c000 ffff880037b0c000 ffff880060404000 ffffffffa29cb577
[ 599.833545] Call Trace:
[ 599.833696] [<ffffffffa29f887c>] ? _nv008354rm+0x10f/0x121 [nvidia]
[ 599.833841] [<ffffffffa29cb577>] ? _nv022672rm+0x1b6/0x33f [nvidia]
[ 599.833991] [<ffffffffa29ec8f6>] ? _nv022670rm+0xf8/0x121 [nvidia]
[ 599.834001] [<ffffffffa28a4a3f>] ? _nv007733rm+0xde/0x109 [nvidia]
[ 599.834001] [<ffffffffa28a4c0d>] ? _nv007732rm+0x1a3/0x1dc [nvidia]
[ 599.834001] [<ffffffffa28dcf78>] ? _nv008062rm+0x263/0xd47 [nvidia]
[ 599.834001] [<ffffffffa28ba99f>] ? _nv007730rm+0x49/0x4f [nvidia]
[ 599.834001] [<ffffffffa28b9eaf>] ? _nv019304rm+0xaef/0xe79 [nvidia]
[ 599.834001] [<ffffffffa295badf>] ? _nv009952rm+0x1d5/0x336 [nvidia]
[ 599.834001] [<ffffffffa2a0e174>] ? _nv009949rm+0x2e/0x5a [nvidia]
[ 599.834001] [<ffffffffa2b77732>] ? _nv015076rm+0x27b/0x4c3 [nvidia]
[ 599.834001] [<ffffffffa2b761b8>] ? _nv015378rm+0xe9/0x165 [nvidia]
[ 599.834001] [<ffffffffa27653b5>] ? _nv015558rm+0xd/0x12 [nvidia]
[ 599.834001] [<ffffffffa2db07b9>] ? _nv002413rm+0x19d/0x28a [nvidia]
[ 599.834001] [<ffffffffa2db1828>] ? _nv002407rm+0x4a5/0x684 [nvidia]
[ 599.834001] [<ffffffffa2db8724>] ? rm_init_adapter+0x9e/0x1b6 [nvidia]
[ 599.834001] [<ffffffff810aaae2>] ? __setup_irq+0x28a/0x320
[ 599.834001] [<ffffffffa2dd76a6>] ? nv_kern_open+0x542/0x6dc [nvidia]
[ 599.834001] [<ffffffff811215b5>] ? chrdev_open+0x119/0x142
[ 599.834001] [<ffffffff8112149c>] ? chrdev_open+0x0/0x142
[ 599.834001] [<ffffffff8111c720>] ? __dentry_open+0x161/0x283
[ 599.834001] [<ffffffff81470bfe>] ? _raw_spin_lock+0xe/0x10
[ 599.834001] [<ffffffff8111d694>] ? nameidata_to_filp+0x60/0x67
[ 599.834001] [<ffffffff811294ef>] ? finish_open+0xa1/0x17f
[ 599.834001] [<ffffffff81128638>] ? do_path_lookup+0xca/0xf6
[ 599.834001] [<ffffffff81129a32>] ? do_filp_open+0x186/0x60a
[ 599.834001] [<ffffffff811329ab>] ? setattr_copy+0xab/0xf2
[ 599.834001] [<ffffffff810411e2>] ? should_resched+0xe/0x2d
[ 599.834001] [<ffffffff8146f6a8>] ? _cond_resched+0xe/0x22
[ 599.834001] [<ffffffff8122ea61>] ? might_fault+0x21/0x23
[ 599.834001] [<ffffffff811335ad>] ? alloc_fd+0x72/0x11d
[ 599.834001] [<ffffffff8111d6fb>] ? do_sys_open+0x60/0xf2
[ 599.834001] [<ffffffff8111d7ad>] ? sys_open+0x20/0x22
[ 599.834001] [<ffffffff81009b82>] ? system_call_fastpath+0x16/0x1b
[ 599.834001] Code: 00 ff 97 b0 01 00 00 85 c0 49 0f 45 dc be 8f 2c 00 00 4c 89 ff 41 ff 97 90 00 00 00 ba 00 00 00 00 85 c0 75 0e 48 89 de 4c 89 f7 <ff> 93 50 0a 00 00 89 c2 85 d2 0f 94 c0 0f b6 c0 89 83 0c 14 00
[ 599.834001] RIP [<ffffffffa29f86c6>] _nv008541rm+0xf1/0x115 [nvidia]
[ 599.834001] RSP <ffff880069a518c8>
[ 599.834001] CR2: 0000000000000a50
[ 599.836203] ---[ end trace d5b3ccbb4a810000 ]---
[/pre]
vallor is offline   Reply With Quote
Old 06-16-11, 08:56 AM   #16
Evilandi666
Registered User
 
Join Date: Jun 2011
Posts: 35
Default Re: XServer freezes on start using nVidia 270.xx drivers on Geforce 9300 IGP

Any news here? Will it be fixed in next release? Or do I have to sell my Zotac 9300 motherboard because I can never use it with nvidia drivers in future (in linux and windows)?
Evilandi666 is offline   Reply With Quote
Old 06-16-11, 11:42 AM   #17
vallor
Packet Pimp
 
Join Date: Feb 2006
Posts: 5
Default Re: XServer freezes on start using nVidia 270.xx drivers on Geforce 9300 IGP

Quote:
Originally Posted by Evilandi666 View Post
Any news here? Will it be fixed in next release? Or do I have to sell my Zotac 9300 motherboard because I can never use it with nvidia drivers in future (in linux and windows)?
I'm bummed -- I would have thought they would at least tell us they're working on it.

nvidia: are you going to keep ignoring us? If you aren't going to fix it, at least man-up and tell us!

p.s. maybe that's the wrong attitude to take over nvidia's silence. Instead, let me offer: Dear nvidia: since you have the source code, we would prefer that you develop the fix. Thank you.

Last edited by vallor; 06-16-11 at 11:50 AM. Reason: adding a postscript
vallor is offline   Reply With Quote
Old 06-17-11, 12:04 PM   #18
Evilandi666
Registered User
 
Join Date: Jun 2011
Posts: 35
Default Re: XServer freezes on start using nVidia 270.xx drivers on Geforce 9300 IGP

Quote:
Originally Posted by vallor View Post
nvidia: are you going to keep ignoring us? If you aren't going to fix it, at least man-up and tell us!
I want really know if there is something going on about it - or even someone noticed this bug report. :/
Evilandi666 is offline   Reply With Quote
Old 06-20-11, 08:22 AM   #19
hmskrecik
Registered User
 
Join Date: Jun 2011
Posts: 1
Default Re: XServer freezes on start using nVidia 270.xx drivers on Geforce 9300 IGP

I confirm this problem under Debian.

Also I think it is not exactly related to Linux distro or Xorg version (excluding the fact that due to ABI change it is not possible now to downgrade the driver). I have dual boot box and under Windows Vista I got BSOD during boot up after installing 275 driver. Rolling back to 195 solved the issue.
hmskrecik is offline   Reply With Quote
Old 06-22-11, 08:52 AM   #20
Evilandi666
Registered User
 
Join Date: Jun 2011
Posts: 35
Default Re: XServer freezes on start using nVidia 270.xx drivers on Geforce 9300 IGP

I started a thread at nvidia forums: http://forums.nvidia.com/index.php?showtopic=203643

Please post there if you also got this problem.

Don't know if any nvidia dev will ever see it here @nvnews.
Evilandi666 is offline   Reply With Quote

Old 07-01-11, 02:42 AM   #21
Evilandi666
Registered User
 
Join Date: Jun 2011
Posts: 35
Default Re: XServer freezes on start using nVidia 270.xx drivers on Geforce 9300 IGP

bump
Evilandi666 is offline   Reply With Quote
Old 07-02-11, 09:52 AM   #22
Evilandi666
Registered User
 
Join Date: Jun 2011
Posts: 35
Default Re: XServer freezes on start using nVidia 270.xx drivers on Geforce 9300 IGP

Anyone tried 280.04 yet?

Edit: I tried 280.04:

[ 20.133554] BUG: unable to handle kernel NULL pointer dereference at 0000000000000a58
[ 20.133559] IP: [<ffffffffa05bf726>] _nv008499rm+0xf1/0x115 [nvidia]
[...]
[ 20.133744] Pid: 1312, comm: Xorg Tainted: P 2.6.39-ARCH #1 NVIDIA MCP7A/MCP7A
[ 20.133747] RIP: 0010:[<ffffffffa05bf726>] [<ffffffffa05bf726>] _nv008499rm+0xf1/0x115 [nvidia]
[ 20.133853] RSP: 0018:ffff880128351858 EFLAGS: 00010246
[ 20.133854] RAX: 0000000000000000 RBX: 0000000000000000 RCX: 0000000000000010
[ 20.133856] RDX: 0000000000000000 RSI: 0000000000000000 RDI: ffff880127d4e000
[ 20.133857] RBP: ffff88011f095d70 R08: 0000000000000007 R09: 0000000000000021
[ 20.133859] R10: 0000000000000021 R11: 0000000000000021 R12: ffff880127fa0000
[ 20.133860] R13: 0000000000000000 R14: ffff880127d4e000 R15: ffff88011ded4000
[ 20.133862] FS: 00007f0d9dee6880(0000) GS:ffff88012fc80000(0000) knlGS:0000000000000000
[ 20.133864] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 20.133865] CR2: 0000000000000a58 CR3: 000000011ddaf000 CR4: 00000000000006e0
[ 20.133867] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[ 20.133868] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[ 20.133870] Process Xorg (pid: 1312, threadinfo ffff880128350000, task ffff880125960000)
[ 20.133872] Stack:
[ 20.133873] 0000000000000000 ffff880127fa0000 ffff880127d4e000 ffff88011ded4000
[ 20.133877] 0000000000000000 ffffffffa05bf8dc 0000000000000000 0000000000000000
[ 20.133879] ffff880127fa0000 ffff880127fa0000 ffff88011ded4000 ffffffffa0591c67
[ 20.133882] Call Trace:
[ 20.133988] [<ffffffffa05bf8dc>] ? _nv008312rm+0x10f/0x121 [nvidia]
[ 20.134091] [<ffffffffa0591c67>] ? _nv022700rm+0x1b6/0x33f [nvidia]
[ 20.134196] [<ffffffffa05b34a6>] ? _nv022698rm+0xf9/0x122 [nvidia]
[ 20.134280] [<ffffffffa046b56f>] ? _nv007685rm+0xde/0x109 [nvidia]
[ 20.134363] [<ffffffffa046b73d>] ? _nv007684rm+0x1a3/0x1dc [nvidia]
[ 20.134450] [<ffffffffa0499db8>] ? _nv008016rm+0x263/0xd47 [nvidia]
[ 20.134536] [<ffffffffa04814bf>] ? _nv007682rm+0x49/0x4f [nvidia]
[ 20.134622] [<ffffffffa04809cf>] ? _nv019310rm+0xaef/0xe79 [nvidia]
[ 20.134716] [<ffffffffa0521256>] ? _nv009936rm+0x23c/0x39b [nvidia]
[ 20.134822] [<ffffffffa05d55d4>] ? _nv009933rm+0x2e/0x5a [nvidia]
[ 20.134941] [<ffffffffa074113c>] ? _nv015069rm+0x27b/0x4c3 [nvidia]
[ 20.135059] [<ffffffffa073fb92>] ? _nv015362rm+0xe9/0x165 [nvidia]
[ 20.135114] [<ffffffffa032a6d8>] ? _nv015542rm+0xd/0x12 [nvidia]
[ 20.135185] [<ffffffffa097a639>] ? _nv002297rm+0x19d/0x28a [nvidia]
[ 20.135255] [<ffffffffa097b6a8>] ? _nv002291rm+0x4a5/0x684 [nvidia]
[ 20.135324] [<ffffffffa09825b4>] ? rm_init_adapter+0x9e/0x1b6 [nvidia]
[ 20.135328] [<ffffffff810be877>] ? __setup_irq+0x2d7/0x3e0
[ 20.135397] [<ffffffffa09a2064>] ? nv_kern_open+0x414/0x7a0 [nvidia]
[ 20.135400] [<ffffffff811560eb>] ? chrdev_open+0x1bb/0x2d0
[ 20.135403] [<ffffffff8114fcfb>] ? __dentry_open+0x16b/0x390
[ 20.135405] [<ffffffff81155f30>] ? cdev_put+0x30/0x30
[ 20.135407] [<ffffffff811511d1>] ? nameidata_to_filp+0x71/0x80
[ 20.135410] [<ffffffff8116004c>] ? do_last+0x3cc/0xa80
[ 20.135412] [<ffffffff8116150b>] ? path_openat+0xcb/0x3c0
[ 20.135414] [<ffffffff8116d068>] ? setattr_copy+0xa8/0x140
[ 20.135416] [<ffffffff81161842>] ? do_filp_open+0x42/0xa0
[ 20.135419] [<ffffffff8116e04c>] ? alloc_fd+0xec/0x140
[ 20.135421] [<ffffffff811512d7>] ? do_sys_open+0xf7/0x1d0
[ 20.135423] [<ffffffff8115c862>] ? path_put+0x22/0x30
[ 20.135425] [<ffffffff811513d0>] ? sys_open+0x20/0x30
[ 20.135428] [<ffffffff813e8f42>] ? system_call_fastpath+0x16/0x1b
[ 20.135429] Code: 00 ff 97 b8 01 00 00 85 c0 49 0f 45 dc be 90 2c 00 00 4c 89 ff 41 ff 97 98 00 00 00 ba 00 00 00 00 85 c0 75 0e 48 89 de 4c 89 f7 <ff> 93 58 0a 00 00 89 c2 85 d2 0f 94 c0 0f b6 c0 89 83 14 14 00
[ 20.135452] RIP [<ffffffffa05bf726>] _nv008499rm+0xf1/0x115 [nvidia]
[ 20.135557] RSP <ffff880128351858>
[ 20.135558] CR2: 0000000000000a58
[ 20.135560] ---[ end trace 7ccf98218d2ae638 ]---

... will this ever be fixed?

Last edited by Evilandi666; 07-03-11 at 03:49 PM.
Evilandi666 is offline   Reply With Quote
Old 07-06-11, 06:56 PM   #23
Evilandi666
Registered User
 
Join Date: Jun 2011
Posts: 35
Default Re: XServer freezes on start using nVidia 270.xx drivers on Geforce 9300 IGP

There seems to be an Nvidia Bugtracker!!

Everyone should go to http://nvidia.custhelp.com/ and report the problem there.

Maybe they get to know it then...
Evilandi666 is offline   Reply With Quote
Old 07-06-11, 11:35 PM   #24
rmm
Registered User
 
Join Date: May 2011
Posts: 2
Default Re: XServer freezes on start using nVidia 270.xx drivers on Geforce 9300 IGP

Has anybody tried the drivers that zotac advertises on their support page:


http://www.zotac.com/index.php?optio...100059&lang=en
rmm is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:32 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.