Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-02-11, 12:31 PM   #1
Hal_Canary
Registered User
 
Join Date: Jun 2011
Posts: 2
Default NVidia 3D Vision under Linux.

I'm trying to get NVidia 3D Vision working under Linux.

I've got a Red Hat Enterprise Linux (6.1) workstation with two Quadro 5000 cards and the nvidia driver version 270.41.19. The 3D Vision IR emitter is plugged in to both a video card and a USB port,and it glows dull green. I verified that the refresh rate on the monitor is set to 120 Hz. When I launch a stereo application (like glxgears -stereo), the monitor shows a double image, but the emitter doesn't become bright green and the shutter glasses don't respond.

Any ideas on how to troubleshoot this issue?

* * *

Here's what I've done to get this far:

Code:
## from my /etc/X11/xorg.conf file:
[...]
Section "Screen"
        [...]
        Option "Stereo" "10"
EndSection
[...]
Section "Device"
        [...]
        Option "FlatPanelProperties" "Scaling = Native"
EndSection
[...]
Section "Extensions"
        Option "Composite" "off"
EndSection
References:
Hal_Canary is offline   Reply With Quote
Old 06-02-11, 02:33 PM   #2
stvnash
Nvidia Corporation
 
Join Date: Jan 2010
Posts: 3
Default Re: NVidia 3D Vision under Linux.

In the /var/log/Xorg.0.log file, are there any messages related to 3D vision being enbled OK?

What type of monitor are you using?

Can you try disabling the GPU scaling under nvidia-settings to get it running at 120Hz?
stvnash is offline   Reply With Quote
Old 06-03-11, 09:20 AM   #3
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: NVidia 3D Vision under Linux.

can you read http://www.nvnews.net/vbulletin/showthread.php?t=46678 and generate a good report with the debug ( -logverbose 6 ) info as instructed after the issue appears ?
Licaon is offline   Reply With Quote
Old 06-03-11, 02:33 PM   #4
Hal_Canary
Registered User
 
Join Date: Jun 2011
Posts: 2
Default Re: NVidia 3D Vision under Linux.

I have fixed the problem! It turned out that it was a bad wire. one of
the pins in the 3-pin stereo connector was bent. We swapped it out and
it worked perfectly.

Sorry for the bother!
Hal_Canary is offline   Reply With Quote
Old 06-03-11, 03:20 PM   #5
stvnash
Nvidia Corporation
 
Join Date: Jan 2010
Posts: 3
Default Re: NVidia 3D Vision under Linux.

Do you mean a bad cable? Was the cable from Nvidia? I'd be interested to know the part number of the bad cable if you could post it.

Where did the good cable come from?
stvnash is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:13 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.