Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-30-11, 10:02 AM   #1
crizh
Registered User
 
Join Date: Apr 2004
Posts: 6
Default 173.14.30 Fix needed pronto

Sheez, haven't been here in a while, 6 years tomorrow since my last login....

Just goes to show how long it's been since I had any problem with Nvidia on linux.

Anyways....

173.14.30.

It's been released at a very unfortunate point in time and has broken all sorts of stuff in Ubuntu. Looks like dozens of threads on the support forums are all about to coalesce into one big stink-storm.

To quote

Quote:
Our assumptions were correct, it seems like GLSL's been enabled for some reasons on that new driver for these chips. I guess the icons are black because the fragment programs used by the launcher exceed the GPU caps and the driver fallbacks to a set-fragment-color-to-black shader.
From bug 768178.

Seems like that change has royally screwed a whole swathe of legacy cards. The 'solution' is to turn off the fancy new Unity desktop. Any fix is going to have to come from Nvidia and it'll have to come fast.

Looks like if you have AGP hardware, no matter how good it is, your going to have to upgrade to PCIe to see the benefits of 11.04.

Last time I had to buy new hardware 'cos the drivers blew it was 10 years ago and ATI hasn't seen a dime from me since.

173.14.28 works and has worked for a very long time. It's a shame to see a new release that might fall flat on it's face at the first hurdle.

Fix? Please?! Pretty please?!
crizh is offline   Reply With Quote
Old 05-01-11, 12:02 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 173.14.30 Fix needed pronto

Do you know if there's any more detail on what is triggering this Unity behavior? The 173.14 driver series is very stable and so little changed between 173.14.28 and 173.14.30 that it's hard to believe the driver could be at fault, but I'll file a bug anyway.
AaronP is offline   Reply With Quote
Old 05-01-11, 12:33 PM   #3
luk1don
Registered User
 
luk1don's Avatar
 
Join Date: Nov 2008
Posts: 55
Default Re: 173.14.30 Fix needed pronto

I think Unity is very very buggy, sometimes works or sometimes not on identical hardware
__________________
250 MB free extra space on Dropbox! <= Please join by this link!
luk1don is offline   Reply With Quote
Old 05-03-11, 09:58 AM   #4
crizh
Registered User
 
Join Date: Apr 2004
Posts: 6
Default Re: 173.14.30 Fix needed pronto

Sorry, I haven't the faintest idea what a GLSL rendering pathway even is. I imagine the developers posting in the bug report I linked to above could give you a clearer idea of what the driver is doing different now than it did before.

Unfortunately what they consider a 'fix' is to simply disable all hardware acceleration of the desktop. From what I can tell they've closed that bug and moved on and there won't be any actual fix until the driver changes.

I've got some logs but they don't seem to contain anything revealing other than leading one to that and a couple of other similar bug reports.
crizh is offline   Reply With Quote
Old 05-03-11, 11:22 AM   #5
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 173.14.30 Fix needed pronto

There's no evidence in that Launchpad bug that they tried 173.14.28. Given that it doesn't support the X server Ubuntu 11.04 uses, how did you test it to determine that it worked?

A "GLSL rendering pathway" would be a set of code routines in Unity that it uses when it decides the hardware is capable enough. It should make that decision ideally based on the OpenGL version and extension string reported by the driver. The only thing that changed between 173.14.28 and 173.14.30 as far as the OpenGL capabilities go is the version number. It's possible that Unity is looking at that and was confused by the change.
AaronP is offline   Reply With Quote
Old 05-03-11, 11:23 AM   #6
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 173.14.30 Fix needed pronto

Sorry, I should clarify that I meant the driver version number in the OpenGL vendor string, which should not be used for making decisions like whether or not to use GLSL.
AaronP is offline   Reply With Quote
Old 05-04-11, 01:02 PM   #7
crizh
Registered User
 
Join Date: Apr 2004
Posts: 6
Default Re: 173.14.30 Fix needed pronto

I haven't tried to regress the driver myself.

173.14.30 is less than three weeks old, I have to assume that all testing of unity on NV35 and earlier occurred on 173.14.28 prior to that date. That bug is two days after the release of 174.14.30.

As I understand it 173.14.28 is a release to make the driver compatible with Xorg 1.9 and 173.14.30 similarly for Xorg 1.10?

It's only bleeding edge distro's like Ubuntu that use bleeding edge X servers. There's no point releasing an update to make the driver compatible with Natty if the new driver breaks Natty in the process. No?

The largest single group of users using these cards and these drivers are using them to run Ubuntu 11.04. All the effort put into the driver update is wasted if it still doesn't work for those users.

The Ubuntu devs have closed that bug because it's a driver issue and therefore somebody else's problem. If you are certain it is not it would be helpful if you could let them know why not and point them in the right direction.
crizh is offline   Reply With Quote
Old 05-04-11, 01:12 PM   #8
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 173.14.30 Fix needed pronto

Quote:
Originally Posted by crizh View Post
I haven't tried to regress the driver myself.

173.14.30 is less than three weeks old, I have to assume that all testing of unity on NV35 and earlier occurred on 173.14.28 prior to that date. That bug is two days after the release of 174.14.30.

As I understand it 173.14.28 is a release to make the driver compatible with Xorg 1.9 and 173.14.30 similarly for Xorg 1.10?

It's only bleeding edge distro's like Ubuntu that use bleeding edge X servers. There's no point releasing an update to make the driver compatible with Natty if the new driver breaks Natty in the process. No?
No. Ubuntu 11.04 users running Unity are not the only people using X.Org xserver 1.10.

Quote:
Originally Posted by crizh View Post
The Ubuntu devs have closed that bug because it's a driver issue and therefore somebody else's problem. If you are certain it is not it would be helpful if you could let them know why not and point them in the right direction.
So far, I have nothing to go on other than, "Unity doesn't work." There's no indication that anything actually changed in the driver between 173.14.28 and 173.14.30 to cause that behavior, and no explanation of what Unity is trying to do that goes wrong.
AaronP is offline   Reply With Quote

Old 05-04-11, 02:37 PM   #9
crizh
Registered User
 
Join Date: Apr 2004
Posts: 6
Default Re: 173.14.30 Fix needed pronto

Well not the only people obviously.

I never had any trouble on CentOS....

I only converted this machine to Ubuntu about a month ago and 10.10 is running 1.9. So a cutting edge distro that is only six months old isn't running 1.10 and doesn't have any of these problems.

My point was that a huge chunk of people running 174.14.30 for compatibility with 1.10 are running Ubuntu 11.04. If the driver update doesn't give them a working accelerated desktop it was a bit of a waste of effort.

How can I help? As far as I can tell the errors I can find in my log files are of little use to you. All they did was lead me to the relevant bug reports which contained information I didn't have and fear I lack the competence to uncover.

There's one about Xalloc asking for an 'uncomfortable' amount of memory in xorg.log and another somewhere else about Compiz crashing in libnux.

I thought I had Ubuntu One sharing my log files with this laptop but I'm clearly not as smart as I thought I was in that regard so I don't have them to hand to post the exact error messages.
crizh is offline   Reply With Quote
Old 05-05-11, 11:33 AM   #10
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 173.14.30 Fix needed pronto

I installed X.Org xserver 1.9.5 and NVIDIA driver version 173.14.28 on Ubuntu 11.04 and Compiz still crashes. This is not a driver regression.
AaronP is offline   Reply With Quote
Old 05-05-11, 07:25 PM   #11
crizh
Registered User
 
Join Date: Apr 2004
Posts: 6
Default Re: 173.14.30 Fix needed pronto

Thanks.

Any idea what would be best to say in that bug report to get them to re-open it? Or should I just file a new one?
crizh is offline   Reply With Quote
Old 05-05-11, 07:30 PM   #12
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 173.14.30 Fix needed pronto

It sounds like they fixed it by disabling the buggy code path on GeForce FX cards (I didn't try Jay Taoko's fix in natty-proposed). Does that fix work for you?
AaronP is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:05 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.