Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-29-10, 02:47 PM   #1
pete4nv
Registered User
 
Join Date: Jul 2003
Posts: 27
Send a message via ICQ to pete4nv Send a message via AIM to pete4nv Send a message via Yahoo to pete4nv
Default Sony Vaio VPCF1290X blank screen when switching away from X and back: X1.7.7 Nv256.52

Update 2: On looking closely at the X screen on returning from suspend or pressing the Display Off button, the screen backlight is at minimal setting. I can faintly observe the X screen elements, but not enough to find the brightness slider. Still, brightness must be set to maximum for screen brightness to hold. Then, further adjustments can be made lower. I like 75%. Sonys are wickedly bright.

Update: Attached nvidia-bug-report.log for native X nv driver. NV Driver allows for terminal switching with no blank screen. However, resume from Suspend results in blank screen. Also, I was incorrect, sony Brightness keys do not work with NV driver (Fn-F5/F6). Began with NO xorg.conf file and let X decide all defaults.
---------------------------------------------------------------------------------------

XServer Version 1.7.7
NVidia Driver Version 256.52 64 bit no compat

(note, some of the backlight issues mentioned do not occur if brightness is set to maximum at time of screen switch or power suspend)

X starts fine and brightness adjustment via power manager works fine.
Sony native keys for increasing or decreasing brightness (Fn-F5/F6) do not work
Sony native keys for increasing or decreasing audio (Fn-F3/F4) do work
Sony native key for audio mute (Fn-F2) works
Sony Native Display On/Off key does not work. After blanking display, it takes quite a bit of switching to get the display to restore. This feature worked fine with 256.44.
Alt-F1/2/3/4/5/6 switching results in a blank screen but active keyboard. However, backlight is off on returning to X. Takes much switching back and forth to restore backlight. Backlight issue was not a problem when returning to X with 256.44.
Power-suspend to ram works, but backllight is off and it takes much switching on and off of the display to get brightness back to normal otherwise screen blanks after a second.
After exiting X, screen is blank, keyboard works and it is possible to log out.

Using the X-nv drivers, keyboard brightness adjustments worked fine. Terminal switching worked fine. However, power suspend did not work and on resuming, backlight was off.

SO for now, 256.52 works less well than .44. Resuming from suspend means no backlight and it is tricky to tweak it back.

Again, if brightness is set to maximum, backlight is restored on return to X. However, terminal switching is not usable other than keyboard.
Attached Files
File Type: gz nvidia-bug-report.log.gz (57.7 KB, 99 views)
File Type: gz nvidia-bug-report-nvdriver.log.gz (38.7 KB, 94 views)

Last edited by pete4nv; 08-30-10 at 01:59 PM. Reason: Update for NV Driver info/Correct Model Number/ Brightness Update
pete4nv is offline   Reply With Quote
Old 06-21-11, 05:05 AM   #2
pete4nv
Registered User
 
Join Date: Jul 2003
Posts: 27
Send a message via ICQ to pete4nv Send a message via AIM to pete4nv Send a message via Yahoo to pete4nv
Thumbs down Re: Sony Vaio VCPF1290X blank screen when switching to VT 275.09.07

It's 10 months and I thought I would post another message. The issue with the blank VT screens continue. Apparently, switching away from X causes the problem. The Backlight turns off and nothing, not even the Sony Display button restores it. Once returning to X, pressing Display plus Fn-F6 to up the brightness restores the screen.

nvidia-bug-report.log file attached. X parameters included in report duplicated here.

Code:
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "RegistryDwords" "EnableBrightnessControl=1" 
    Option "NoLogo" "1"
    Option "OnDemandVBlankInterrupts" "true"
    Option "EnableACPIHotkeys" "1"
    Option "EnableACPIBrightnessHotkeys" "1"
EndSection
Attached Files
File Type: gz nvidia-bug-report.log.gz (29.1 KB, 61 views)
pete4nv is offline   Reply With Quote
Old 06-21-11, 06:35 AM   #3
XjCook
Registered User
 
Join Date: Oct 2010
Posts: 28
Default Re: Sony Vaio VCPF1290X blank screen when switching away from X and back: X1.7.7 Nv25

I had similar problem (GF330M), then I discovered Uvesafb framebuffer. With uvesafb switching is working fine.
XjCook is offline   Reply With Quote
Old 06-22-11, 05:25 AM   #4
pete4nv
Registered User
 
Join Date: Jul 2003
Posts: 27
Send a message via ICQ to pete4nv Send a message via AIM to pete4nv Send a message via Yahoo to pete4nv
Default Re: Sony Vaio VCPF1290X blank screen when switching away from X and back: X1.7.7 Nv25

Quote:
Originally Posted by XjCook View Post
I had similar problem (GF330M), then I discovered Uvesafb framebuffer. With uvesafb switching is working fine.
Odd, because I also tried uvesafb and it did not change the problem. Please mention any other settings you used.
pete4nv is offline   Reply With Quote
Old 06-24-11, 12:57 PM   #5
pete4nv
Registered User
 
Join Date: Jul 2003
Posts: 27
Send a message via ICQ to pete4nv Send a message via AIM to pete4nv Send a message via Yahoo to pete4nv
Default Re: Sony Vaio VCPF1290X blank screen when switching away from X and back: X1.7.7 Nv25

Quote:
Originally Posted by XjCook View Post
I had similar problem (GF330M), then I discovered Uvesafb framebuffer. With uvesafb switching is working fine.
Disabled VESA in kernel, loaded uvesafb. Same problem. What steps?
pete4nv is offline   Reply With Quote
Old 06-24-11, 05:02 PM   #6
pete4nv
Registered User
 
Join Date: Jul 2003
Posts: 27
Send a message via ICQ to pete4nv Send a message via AIM to pete4nv Send a message via Yahoo to pete4nv
Smile Re: Sony Vaio VCPF1290X blank screen when switching away from X and back: X1.7.7 Nv25

Quote:
Originally Posted by XjCook View Post
I had similar problem (GF330M), then I discovered Uvesafb framebuffer. With uvesafb switching is working fine.
Slap me. Once compiling the v86d package the switching works fine. I also disabled VESA in kernel config. Thank you. One year!
pete4nv is offline   Reply With Quote
Old 06-25-11, 02:33 AM   #7
XjCook
Registered User
 
Join Date: Oct 2010
Posts: 28
Default Re: Sony Vaio VCPF1290X blank screen when switching away from X and back: X1.7.7 Nv25

Great, sorry for my late answer, all information about graphics settings and other things I have from http://code.google.com/p/vaio-f11-linux. Maybe this site will be helpful for you
XjCook is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:11 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.