Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Thread Tools
Old 06-18-11, 08:43 PM   #1
Registered User
Join Date: Jun 2011
Posts: 3
Default Ubuntu Quadro FX 880M Powermizer Stuck


That's a quote from my post on ubuntuforums from some time ago:

I'm not completely sure but I think this is a problem for me too. I have a laptop HP 8540W with NVIDIA Quadro FX880M, core i7-720qm.

Output of nvidia-settings -q GPUPerfModes -t:
perf=0, nvclock=135, memclock=135, processorclock=270 ; perf=1, nvclock=405,
memclock=324, processorclock=810 ; perf=2, nvclock=550, memclock=790,

Switching between perf0 and perf1 is ok, compiz runs smooth, but as much as the nvidia-applet shows it never goes to perf2 mode.
I have done benchmarks with Unigine Heaven and Sanctuary getting 13 and 33 fps in Linux while with the same settings in Win7 I get respectively 24 and 52 fps (both with opengl rendering exact same settings) which was the first thing that made me think something is not working fine.

I have tried all the perflevelsrc hacks and with trial and error managed to lock it in perf0 and perf1 modes and other different combinations for ac and battery power but never to maximum performance although I ran glxgears for each setup and got around 5-6 different results ranging from 650 to 4000 fps.

I also tested WoW in wine with opengl rendering and it gets solid 30fps on max settings and 1600x900 resolution which is quite good but in Win7 I get around 40-45fps for the same settings (although this may be completely due to the game).

Most of all while running the Unigine Benchmarks my graphics card runs much hotter on Win7 than on Ubuntu which I'm quite sure means that I'm not running on max performance on Ubuntu.

Using Ubuntu 10.10 x64, 2.6.35-28-generic
nvidia drivers downloaded - tried with both development driver 260.19.26 and normal driver 270.41.06
In general, powermizer stops my gpu from going to it's normal frequencies for no apparent reason, or at least nvidia panel shows that.

I still have the same problems - everything reproduced also on Ubuntu 11.04 x64 2.6.38-8-generic, and partially reproduced on Fedora 15 ( I just ran a live cd and installed nvidia drivers for a couple of apps).
Problem persists with the latest drivers 275.09.07. Since my previous post I have also done benchmarks with specviewperf, nexuiz and a couple of opencl and cuda apps from the nvidia sdk and about 90% of them show that in Linux I get roughly 60% of the performance I get on Win7 Home Premium. Including really simple OpenCL apps which I don't think could be platform dependent in any way - example oclBandwidthTest from the SDK gives 8GB/s device to device bandwith in linux and 16GB/s in Windows, which is really straightforward since the memory clock is shown to work on 325MHz in linux where it's max frequency would be 790MHz.

Nothing unusual can be seen in my log files. Tell me if it would be of any help to post exact results of some benchmarks.

I would really appreciate any help, I usually prefer searching forums than posting when I have a problem but this really seems a dead end.
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (48.2 KB, 95 views)
tkod is offline   Reply With Quote
Old 06-19-11, 03:47 PM   #2
Registered User
Join Date: Jan 2008
Posts: 330
Default Re: Ubuntu Quadro FX 880M Powermizer Stuck

Perhaps check the bios power managment settings. Does it happen with battery or plugged in or both? Is your power supply rated for that machine (>>100W)?
ledoc is offline   Reply With Quote
Old 06-20-11, 05:01 AM   #3
Registered User
Join Date: Jun 2011
Posts: 3
Default Re: Ubuntu Quadro FX 880M Powermizer Stuck

It's a laptop workstation - power settings in general are not present in the bios. Power supply is ok for the machine. As I have said in my post GPU frequency scales just fine in Windows 7 on this machine with the same bios settings and everything.

I have done some more tests using PerfLevelSrc tweaks as explained here:

I observed 4 different distinguishable performance levels - 2 on battery and 2 on ac.
I used nbody and bandwidthTest from cuda sdk to measure relative performance. Some numbers I got:

Battery power, locked in lowest performance: 200 | 1300 | 5
Battery power, locked in medium performance: 600 | 3900 | 16
AC power, locked in lowest performance: 1400 | 3300 | 19
AC power, locked in medium performance: 2800 | 8500 | 55

Some explanation - locked in lowest performance means that nvidia panel shows perf=0 mode. Locked in medium performance - perf=1 mode reported. When I try to lock it in perf=2 I get perf=1 reported and same results as perf=1(including 405,324MHz reported frequencies). For the numbers - first column is device-host/host-device bandwidth, second is device-device bandwidth, third is FPS in nbody. I ran each app a few times on each mode - deviations were no more than 5%.
tkod is offline   Reply With Quote
Old 06-23-11, 04:49 PM   #4
Registered User
Join Date: Jun 2011
Posts: 3
Default Re: Ubuntu Quadro FX 880M Powermizer Stuck

Hello everyone. Although I didn't manage to get any feedback here, after 3-4 days of extensive searching on the internet I put a lot of stuff I found together and fixed my problem. I'm posting this because my problem seems similar to


which It seems hasn't been resolved yet. And it probably won't be, because at least in my case it wasn't nvidia related, but due to crappy HP laptop bios, and since windows handles this buggy bios it's considered linux issue.

I used mostly things from here


on how to fix dsdt file (I'm not gonna go into detail because well I just can't), and most importantly this topic was a total lifesaver -


A lot of thanks to zander for pointing the exact problem and to Brendan Visser for posting how he fixed it.

Here are the exact steps it took me to fix it up:
1.install iasl from repos:

sudo apt-get install iasl

2.copy current dsdt file, change it's permissions, and disassemble it

sudo cp /sys/firmware/acpi/tables/DSDT ./dsdt
sudo chmod 777 dsdt
iasl -d dsdt

This will give you a file dsdt.dsl

3.Open it in text editor. If there are any lines before the first commented line (line that starts with /* ) delete them (if there are they shouldn't be more than 2-3, if you're not sure ask). Now here's what fixed things for me (note that it might not work for you,especially if you're not using HP)

Put the section:

Device (PEG3)

before the section(cut and paste it):

Device (PEGP)

4.Save and close the file and compile the new dsdt:

iasl -tc dsdt.dsl

Don't worry if this gives you some errors, although if you are skilled enough to fix them in the source code probably another things will start working in linux on your computer(like brightness controls, hibernation and suspend etc. if they aren't working already). You should have a dsdt.aml file now. Put it in your /boot folder.(sudo cp dsdt.aml /boot)

5.Download the attached 01_acpi.txt, rename it to 01_acpi make it executable and put it /etc/grub.d/

It's important to make it executable. This works for grub2 only, if you use another bootloader google how to load custom dsdt table.

6.update your grub entries

sudo update-grub


This may or may not work, based on your hardware, your bios and your exact problem. It's only known to help on HP 8540W with quadro fx 880m or 1800m .
This guide may render your system unbootable.
I don't think it could do any harm to your hardware but I'm not taking responsibility for that either.

I really hope this guide helps someone, I've been trying to solve the problem for over 2 months now and I'm quite happy I finally did.
Attached Files
File Type: txt 01_acpi.txt (627 Bytes, 111 views)
tkod is offline   Reply With Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -5. The time now is 12:10 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.