Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-12-11, 11:26 AM   #1
awn
Registered User
 
Join Date: Jul 2011
Posts: 1
Default X craches when loading GLX

Hi

I am trying to get Nvidia drivers with GLX up and running but I am having quite some troubles...

I could really use some hints on how on how to debug this, here is what I got when running X in gdb.

------- SNIPPET -----------
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
(II) NVIDIA GLX Module 275.09.07 Wed Jun 8 14:34:43 PDT 2011
------- SNIPPET -----------
(II) NVIDIA(0): [DRI2] Setup complete
(II) NVIDIA(0): Screen initialization complete
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX

Program received signal SIGSEGV, Segmentation fault.
0x00007f26f7570f72 in backtrace () from /lib/libc.so.6
(gdb) bt
#0 0x00007f26f7570f72 in backtrace () from /lib/libc.so.6
#1 0x00007f26f74f62fe in ?? () from /lib/libc.so.6
#2 0x00007f26f74ffab5 in ?? () from /lib/libc.so.6
#3 0x00007f26f7502f45 in ?? () from /lib/libc.so.6
#4 0x00007f26f75049e0 in malloc () from /lib/libc.so.6
#5 0x000000000042f1ac in AddCallback ()
#6 0x00007f26f6aac895 in ?? () from /usr/lib/xorg/modules/extensions/libglx.so
#7 0x00007f26f6aa88a4 in ?? () from /usr/lib/xorg/modules/extensions/libglx.so
#8 0x000000000046e6fa in InitExtensions ()
#9 0x0000000000421f99 in _start ()
(gdb)

At this point I have a nvidia logo on my screen.

If I disable GLX everything works.

--
Best regards
Allan W. Nielsen
awn is offline   Reply With Quote
Old 07-14-11, 04:29 PM   #2
gabomdq
Registered User
 
Join Date: Jul 2011
Posts: 1
Default Re: X craches when loading GLX

I'm seeing the exact same thing, I'm running Ubuntu Natty on a Zotac ID40 (Nvidia ION 2 GTX 218). The only way to get X started is to disable GLX, I wasn't able to get anything meaningful from strace/gdb, and I get a segfault registered in dmesg whose location changes every time I start X.
gabomdq is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:25 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.