Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-15-11, 08:08 AM   #1
pbc2520
Registered User
 
Join Date: Jul 2011
Location: UK
Posts: 25
Default How do I get Performance Mode = "Desktop" in X Server Settings dialog?

In the X Server Settings dialog on the page GPU 0/PowerMizer - see attached screen capture - how can I get the Performance Mode (labelled 1) to show "Desktop" instead of "Maximum Performance"? I don't believe I am using any of the things listed in the Help (OpenGL, VDPAU, or CUDA) that would cause "Maximum Performance". Is there any way to determine what is causing it?

Setting Preferred Mode to "Adaptive" (labelled 2) does not seem to make any difference. From what I have read, that is to be expected because this related to Performance Levels, not the Performance Mode.

I ask because my Quadro 2000M is running between 52 and 59 celsuis when totally idle and I'm getting a lot of fan usage. I suspect this is causing my terrible battery life.
Attached Thumbnails
Click image for larger version

Name:	NVIDIAXServerSettings_PM.jpg
Views:	207
Size:	57.0 KB
ID:	43141  
pbc2520 is offline   Reply With Quote
Old 08-23-11, 04:29 AM   #2
pbc2520
Registered User
 
Join Date: Jul 2011
Location: UK
Posts: 25
Default Re: How do I get Performance Mode = "Desktop" in X Server Settings dialog?

I have tried various values for Option "RegistryDwords" in xorg.conf but none had any effect on the Performance Mode - it only affected the Performance Levels. Also, I note that
Code:
nvidia-settings -t -q GPUCurrentPerfMode
returns 1 irrespective of whether glxgears is running. (My understanding is that Performance Mode would change depending on whether e.g. 3D was in use.) Curiously, unofficial websites have indicate 1 means "Desktop" but the nvidia-settings dialog shows "Maximum Performance".

Without knowing any way to determine what is causing the driver to select "Maximum Performance", I have to assume this is an issue, so bug report is attached.
Attached Files
File Type: gz nvidia-bug-report.log.gz (90.9 KB, 56 views)
pbc2520 is offline   Reply With Quote
Old 08-23-11, 05:11 AM   #3
pbc2520
Registered User
 
Join Date: Jul 2011
Location: UK
Posts: 25
Default Re: How do I get Performance Mode = "Desktop" in X Server Settings dialog?

This time nvidia-bug-report with -logverbose 6...
Attached Files
File Type: gz nvidia-bug-report.log.gz (108.6 KB, 63 views)
pbc2520 is offline   Reply With Quote
Old 08-31-11, 07:56 PM   #4
pbc2520
Registered User
 
Join Date: Jul 2011
Location: UK
Posts: 25
Default [SOLVED] Re: How do I get Performance Mode = "Desktop" in X Server Settings dialog?

ARRRRGGGGHH.. GNOME 3.

Put it into fallback mode (System Settings -> System Info -> Graphics -> Forced Fallback Mode -> ON) and the Performance Mode will behave as expected.

BTW This also solved a problem I was having with corrupted refresh/redraw of OpenMotif text widgets. (Most of my work involves using a Motif application... not through choice!) If fallback mode doesn't scrub up, I'll be consigning Gnome 3 to the history books...
pbc2520 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.