Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-26-11, 03:44 PM   #1
Fackamato
User
 
Join Date: Mar 2005
Posts: 366
Default X hangs on GTX 580 285.03 (flash related?)

So I was playing a Youtube clip, it was finished, I attempted to close the tab (Firefox 6), then X hung (including the mouse pointer). Perhaps I could've SSH:ed in and killed the X server, but I didn't try it at the time. Ctrl+alt+f1 didn't work. Here's the last lines of the Xorg log:

Code:
[ 18320.626] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration threshold: 4
[ 18605.926] [mi] EQ overflowing. The server is probably stuck in an infinite loop.
[ 18605.926] 
Backtrace:
[ 18605.926] 0: /usr/bin/X (xorg_backtrace+0x26) [0x45d496]
[ 18605.927] 1: /usr/bin/X (mieqEnqueue+0x201) [0x457af1]
[ 18605.927] 2: /usr/bin/X (xf86PostMotionEventM+0xa3) [0x47ce13]
[ 18605.927] 3: /usr/bin/X (xf86PostMotionEventP+0x37) [0x47cf07]
[ 18605.927] 4: /usr/lib/xorg/modules/input/evdev_drv.so (0x7fbbb2b59000+0x44ea) [0x7fbbb2b5d4ea]
[ 18605.927] 5: /usr/bin/X (0x400000+0x6a577) [0x46a577]
[ 18605.927] 6: /usr/bin/X (0x400000+0x1197ce) [0x5197ce]
[ 18605.927] 7: /lib/libpthread.so.0 (0x7fbbb952b000+0xf7c0) [0x7fbbb953a7c0]
[ 18605.927] 8: /lib/libc.so.6 (nanosleep+0x10) [0x7fbbb852e970]
[ 18605.927] 9: /lib/libc.so.6 (usleep+0x34) [0x7fbbb85577f4]
[ 18605.927] 10: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7fbbb3619000+0x42d039) [0x7fbbb3a46039]
[ 18605.927] 11: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7fbbb3619000+0x42d306) [0x7fbbb3a46306]
[ 18605.927] 12: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7fbbb3619000+0x42d37b) [0x7fbbb3a4637b]
[ 18605.927] 13: /usr/bin/X (_CallCallbacks+0x34) [0x433144]
[ 18605.927] 14: /usr/bin/X (0x400000+0x29bcb) [0x429bcb]
[ 18605.927] 15: /usr/bin/X (0x400000+0x2ea89) [0x42ea89]
[ 18605.927] 16: /usr/bin/X (0x400000+0x22b9e) [0x422b9e]
[ 18605.927] 17: /lib/libc.so.6 (__libc_start_main+0xed) [0x7fbbb84ab13d]
[ 18605.927] 18: /usr/bin/X (0x400000+0x22e8d) [0x422e8d]
[ 18641.507] (EE) NVIDIA(0): GpFifo object allocation failed: 0x2c
[ 18641.508] (EE) NVIDIA(0): Failed to allocate DMA push buffer
[ 18641.508] (EE) NVIDIA(0):  *** Aborting ***
[ 18641.508] (EE) NVIDIA(0): Error recovery failed.
[ 18641.508] (EE) NVIDIA(0):  *** Aborting ***
[ 18641.508] (EE) NVIDIA(0): Failed to restore the NVIDIA error handler!
This was using 2.6.39-ck, NVIDIA 285.03, Flashplugin 11.0.1.98 (default config), Xorg server 1.10.3.901 .

Any ideas?

edit: It happened again with 3.0-ck, same NV and flash plugin etc. Xids:

Code:
ug 25 23:24:23 localhost kernel: [18591.435078] NVRM: Xid (0000:01:00): 31, Ch 00000005, engmask 00000120, intr 10000000
Aug 25 23:24:46 localhost kernel: [18614.919731] NVRM: Xid (0000:01:00): 8, Channel 00000001
Aug 26 22:21:35 localhost kernel: [ 4338.775167] NVRM: Xid (0000:01:00): 31, Ch 00000005, engmask 00000120, intr 10000000
Attached Files
File Type: gz nvidia-bug-report.log.gz (39.9 KB, 68 views)
Fackamato is offline   Reply With Quote
Old 08-27-11, 07:41 AM   #2
Tares
Registered User
 
Tares's Avatar
 
Join Date: May 2010
Posts: 4
Default Re: X hangs on GTX 580 285.03 (flash related?)

I think I have a similar issue. Youtube in full screen mode is unwatchable. X freeze will occur in few seconds and flash feels very choppy. I had to revert to 280.13. Here everything works fine.
Tares is offline   Reply With Quote
Old 08-27-11, 03:16 PM   #3
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: X hangs on GTX 580 285.03 (flash related?)

Do you guys have enabled accelerated video via /etc/adobe/mms.conf?
kriko is offline   Reply With Quote
Old 08-28-11, 04:29 AM   #4
MadCatX
Registered User
 
Join Date: Sep 2010
Posts: 29
Default Re: X hangs on GTX 580 285.03 (flash related?)

I guess I had a similar problem (reported here). Setting EnableLinuxHWVideoDecode=0 in /etc/adobe/mms.cfg seems to have fixed the issue for me.
MadCatX is offline   Reply With Quote
Old 08-31-11, 05:01 AM   #5
Fackamato
User
 
Join Date: Mar 2005
Posts: 366
Default Re: X hangs on GTX 580 285.03 (flash related?)

Quote:
Originally Posted by MadCatX View Post
I guess I had a similar problem (reported here). Setting EnableLinuxHWVideoDecode=0 in /etc/adobe/mms.cfg seems to have fixed the issue for me.
I'll try that, thanks. I reverted to 280.13 (stable) and the issue is the same.
Fackamato is offline   Reply With Quote
Old 09-20-11, 11:41 AM   #6
darkraven
Registered User
 
Join Date: Nov 2010
Posts: 19
Default Re: X hangs on GTX 580 285.03 (flash related?)

similar problem.
only happens when trying to close the tab containing flash videos.
darkraven is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:44 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.