Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-12-11, 01:14 AM   #1
feldmaus
Registered User
 
Join Date: May 2008
Posts: 17
Default VT's are blank

Good morning,

i have a Nvidia 8600 GT Card (Nvidia version 285.05.09) on my Debian Squeeze PC. My problem is, that my virtual terminals (VT's) turn blank mostly. The first top line (login prompt) on my VT's can be viewed, but only really blurred. This occurs only when my system starts gdm, so not from the boot time till gdm starts.

Further on i have sometimes a blurred X Desktop, depending on my running applications.

Any ideas? Maybe wrong resolution?
Should i remove the HorizSync and VertRefresh Statements in my Monitor Section? I have a TFT-Monitor.

regards Markus
Attached Files
File Type: gz nvidia-bug-report.log.gz (63.2 KB, 34 views)
feldmaus is offline   Reply With Quote
Old 10-12-11, 03:21 AM   #2
towo|
Registered User
 
Join Date: Feb 2007
Posts: 113
Default Re: VT's are blank

Does lsmod | grep fb show anything?
towo| is offline   Reply With Quote
Old 10-12-11, 04:43 AM   #3
feldmaus
Registered User
 
Join Date: May 2008
Posts: 17
Default Re: VT's are blank

I have a self compiled kernel 3.0.4. Some static included modules are:

Code:
--- Support for frame buffer devices[*]   Enable firmware EDID
[ ]   Framebuffer foreign endianness support  --->
-*-   Enable Video Mode Handling Helpers[*]   Enable Tile Blitting Support 
*** Frame buffer hardware drivers ***
< >   Cirrus Logic support
< >   Permedia2 support 
< >   CyberPro 2000/2010/5000 support
< >   Arc Monochrome LCD board support
[ ]   Asiliant (Chips) 69000 display support
[ ]   IMS Twin Turbo display support 
<*>   VGA 16-color graphics support
<M>   Userspace VESA VGA graphics support
[*]   VESA VGA graphics support
[*]   EFI-based Framebuffer Support
Code:
-*- VGA text console                               
[*]   Enable Scrollback Buffer in System RAM
(64)    Scrollback Buffer Size (in KB)
< > MDA text console (dual-headed) (EXPERIMENTAL)
{*} Framebuffer Console support 
-*-   Map the console to the primary display device
[*]   Framebuffer Console Rotation
[ ] Select compiled-in fonts
And here a list of dynamically included modules:
Code:
cpufreq_conservative     4133  0 
cpufreq_powersave        666  0 
powernow_k8            10880  2 
mperf                    975  1 powernow_k8
ppdev                   4561  0 
fuse                   50943  3 
firewire_sbp2           9827  0 
nvidia              10566094  30 
snd_hda_codec_realtek   242081  1 
snd_hda_intel          19613  1 
snd_hda_codec          58711  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               4368  1 snd_hda_codec
snd_pcm                59755  2 snd_hda_intel,snd_hda_codec
snd_seq                39446  0 
snd_timer              14147  2 snd_pcm,snd_seq
snd_seq_device          4675  1 snd_seq
rtl8187                26335  0 
eeprom_93cx6            1195  1 rtl8187
snd                    43707  10 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_timer,snd_seq_device
soundcore               4583  1 snd
snd_page_alloc          5689  2 snd_hda_intel,snd_pcm
evdev                   6519  4 
psmouse                31333  0 
processor              22841  1 powernow_k8
button                  3955  0 
wmi                     6956  0 
k8temp                  2727  0 
serio_raw               3174  0 
pcspkr                  1318  0 
sg                     18284  0 
firewire_ohci          21851  0 
atiixp                  2097  0 
ide_core               63693  1 atiixp
ata_generic             2627  0 
firewire_core          39238  2 firewire_sbp2,firewire_ohci
sr_mod                 10674  0 
sd_mod                 21210  5 
pata_atiixp             2900  0
Is this ok or should i remove something?

regards Markus
feldmaus is offline   Reply With Quote
Old 10-12-11, 05:49 AM   #4
artem
Registered User
 
Join Date: Jun 2006
Posts: 705
Default Re: VT's are blank

Code:
[    0.427377] efifb: probing for efifb
[    0.427676] efifb: framebuffer at 0xfb300000, mapped to 0xf8080000, using 3072k, total 3072k
[    0.427679] efifb: mode is 1024x768x32, linelength=4096, pages=1
[    0.427681] efifb: scrolling: redraw
[    0.427684] efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[    0.432691] Console: switching to colour frame buffer device 128x48
[    0.437498] fb0: EFI VGA frame buffer device
[    0.437669] vga16fb: initializing
[    0.437671] vga16fb: mapped to 0xc00a0000
[    0.437676] checking generic (fb300000 300000) vs hw (a0000 10000)
[    0.437752] fb1: VGA16 VGA frame buffer device
Try running without efifb.
artem is offline   Reply With Quote
Old 10-12-11, 06:54 AM   #5
feldmaus
Registered User
 
Join Date: May 2008
Posts: 17
Default Re: VT's are blank

Quote:
Originally Posted by artem View Post
Try running without efifb.
This freezes my system total. Other ideas? Do i need some of the framebuffer devices?
feldmaus is offline   Reply With Quote
Old 10-12-11, 08:17 AM   #6
Gusar
Registered User
 
Join Date: Apr 2006
Posts: 277
Default Re: VT's are blank

I'd say remove anything fb that is not efifb. Especially vga16, which I think is the cause of your problem.
Gusar is offline   Reply With Quote
Old 10-12-11, 10:41 AM   #7
artem
Registered User
 
Join Date: Jun 2006
Posts: 705
Default Re: VT's are blank

Quote:
Originally Posted by feldmaus View Post
This freezes my system total. Other ideas? Do i need some of the framebuffer devices?
Never in my whole life I've seen a system which required an EFI framebuffer. I smell something is borked with your kernel configuration.
artem is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:11 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.