Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-28-11, 02:07 AM   #1
iro
Registered User
 
Join Date: Mar 2007
Posts: 58
Default 280.11: 100% CPU and hung gnome-session

Symptoms:
1. type username and password at gdm login window
2. gdm login window disappears but nothing happens
3. CPU Fan starts going at max speed

Switching to VT, and using top shows gnome-session is eating 100% CPU.
However perf top shows that all the time is spent in nvidia-driver:

Code:
   PerfTop:    1001 irqs/sec  kernel: 2.5%  exact:  0.0% [1000Hz cycles],  (all, 1 CPU)
-------------------------------------------------------------------------------

             samples  pcnt         RIP        function               DSO
             _______ _____ ________________ ______________________ _______________________

             3674.00 98.3% 0000000000000be0 _nv012tls              libnvidia-tls.so.280.11
               28.00  0.7% 00000000c101a630 read_hpet              [kernel]               
                5.00  0.1% 000000000003ee10 dso__load_sym.clone.10 perf                   
                5.00  0.1% 000000000001caa0 symbol_filter          perf

I'm using GNOME3, and it happens logging in as either "gnome-shell mode" or "fallback mode".

EDIT: I forgot to mention that 280.04 works fine.
Attached Files
File Type: gz nvidia-bug-report.log.gz (54.9 KB, 92 views)

Last edited by iro; 07-28-11 at 03:19 AM. Reason: noted that 280.04 works fine
iro is offline   Reply With Quote
Old 07-28-11, 04:58 AM   #2
Аноним
Registered User
 
Join Date: Jul 2011
Location: Ukraine
Posts: 3
Default Re: 280.11: 100% CPU and hung gnome-session

[bug report] 275.19 makes Gtk apps go into infinite loop when quitting, breaks Gnome
http://www.nvnews.net/vbulletin/showthread.php?t=164619
Аноним is offline   Reply With Quote
Old 07-31-11, 05:10 PM   #3
jmak
Registered User
 
Join Date: Jul 2011
Posts: 1
Default Re: 280.11: 100% CPU and hung gnome-session

The (apparently) same bug is triggered by Clementine. Latest nVidia driver hits an infinite loop:

http://code.google.com/p/clementine-...detail?id=2113

Thread 1 (Thread 0x7fc4a51a88a0 (LWP 8135)):
#0 0x00007fc49b07aba4 in _nv012tls () from /usr/lib/tls/libnvidia-tls.so.280.11
#1 0x00007fc49e21eded in ?? () from /usr/lib/libGL.so.1
#2 0x00007fc49e1fe4a9 in ?? () from /usr/lib/libGL.so.1
#3 0x00007fc4a4fe321c in ?? () from /lib64/ld-linux-x86-64.so.2
#4 0x00007fc49e97dd82 in __run_exit_handlers (status=0, listp=0x7fc49ecc54c8, run_list_atexit=true) at exit.c:78
#5 0x00007fc49e97ddd5 in exit (status=-1630763112) at exit.c:100
#6 0x00007fc49e965eb4 in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>,
fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff07ee40f8) at libc-start.c:260
#7 0x0000000000519c11 in _start ()
(gdb) disassemble 0x00007fc49b07aba4
Dump of assembler code for function _nv012tls:
0x00007fc49b07ab80 <+0>: sub $0x8,%rsp
0x00007fc49b07ab84 <+4>: callq 0x7fc49b07a990 <_nv009tls>
0x00007fc49b07ab89 <+9>: test %rax,%rax
0x00007fc49b07ab8c <+12>: je 0x7fc49b07ab9f <_nv012tls+31>
0x00007fc49b07ab8e <+14>: xchg %ax,%ax
0x00007fc49b07ab90 <+16>: mov 0x8(%rax),%edx
0x00007fc49b07ab93 <+19>: test %edx,%edx
0x00007fc49b07ab95 <+21>: jne 0x7fc49b07aba4 <_nv012tls+36>
0x00007fc49b07ab97 <+23>: mov (%rax),%rax
0x00007fc49b07ab9a <+26>: test %rax,%rax
0x00007fc49b07ab9d <+29>: jne 0x7fc49b07ab90 <_nv012tls+16>
0x00007fc49b07ab9f <+31>: add $0x8,%rsp
0x00007fc49b07aba3 <+35>: retq
=> 0x00007fc49b07aba4 <+36>: jmp 0x7fc49b07aba4 <_nv012tls+36>
jmak is offline   Reply With Quote
Old 08-01-11, 02:06 PM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 280.11: 100% CPU and hung gnome-session

Thanks for reporting this. I filed bug 858349.
AaronP is offline   Reply With Quote
Old 09-13-11, 01:44 PM   #5
iro
Registered User
 
Join Date: Mar 2007
Posts: 58
Default Re: 280.11: 100% CPU and hung gnome-session

From this gentoo bug I've found that compiling the cairo library without opengl support fixes the problem
iro is offline   Reply With Quote
Old 09-16-11, 05:37 PM   #6
naib
Registered User
 
Join Date: Nov 2004
Posts: 8
Default Re: 280.11: 100% CPU and hung gnome-session

I can confirm this as well (can't even login via gdm... I enter username & passwd and the screen just goes to the gdm background while xserver eats an entire core...)

275.09.07 work well for me.

280.13 & 285.03 have this issue.

What is more worrying is with this new "long-lived" driver program (ie 275.28) which is just suppose to have bugfixes has this EXACT same issue.

Thus one of these so call bugfixes has the regression
naib is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:07 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.