Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-20-02, 04:55 AM   #1
alex31
Registered User
 
Join Date: Dec 2002
Posts: 47
Default highmem ( >= 1 Go) compatibility ?

In order to use more than 920 Mo, the linux kernel have to be compiled with CONFIG_HIGHMEM4G. But when i compile the kernel with this option, i am unable to use nvidia driver, due to memory mapping problem at the driver level :

NVRM: failed to map registers, aborting!!
Dec 15 11:03:50 ifar kernel: 0: NVRM: rm_init_adapter failed

I have tried with mandrake 9 flavors of 2.4.19 and 2.4.20 kernel

thanks for any help

Alexandre
alex31 is offline   Reply With Quote
Old 12-20-02, 07:33 AM   #2
Klaus-P
Registered User
 
Join Date: Aug 2002
Location: Germany
Posts: 134
Default

You might try to change the highmemory kernel mapping option

under "USER ADDRESS SPACE SIZE" , try "2 G" , "1 G is default setting"
Klaus-P is offline   Reply With Quote
Old 12-23-02, 03:28 AM   #3
alex31
Registered User
 
Join Date: Dec 2002
Posts: 47
Default

Quote:
Originally posted by Klaus-P
You might try to change the highmemory kernel mapping option

under "USER ADDRESS SPACE SIZE" , try "2 G" , "1 G is default setting"

thanks for th reply, but i don't see anything
like "USER ADDRESS SPACE SIZE" in the
.config file ... ?

perhaps this option has been dropped in
recent release of kernel ?

amfou> grep -i user /usr/src/linux/.config
# CONFIG_APM_IGNORE_USER_SUSPEND is not set
# User Modules And Translation Layers
CONFIG_EXT3_FS_XATTR_USER=y
CONFIG_EXT2_FS_XATTR_USER=y

amfou> egrep -i '[0-9]G' /usr/src/linux/.config
#CONFIG_NOHIGHMEM is not set
CONFIG_HIGHMEM4G=y
# CONFIG_HIGHMEM64G is not set


Alexandre
alex31 is offline   Reply With Quote
Old 12-23-02, 05:30 AM   #4
Klaus-P
Registered User
 
Join Date: Aug 2002
Location: Germany
Posts: 134
Default

If you edit the " .config "-file manually
......

CONFIG_MICROCODE=m
CONFIG_X86_MSR=m
CONFIG_X86_CPUID=m
# CONFIG_NOHIGHMEM is not set
CONFIG_HIGHMEM4G=y
# CONFIG_HIGHMEM64G is not set
CONFIG_HIGHMEM=y

!!! here is the passage... !!!

# CONFIG_1GB is not set
CONFIG_2GB=y
# CONFIG_3GB is not set
# CONFIG_05GB is not set
CONFIG_HIGHIO=y

I guess you have

" CONFIG_1GB=y " in your .config file

Now try to edit as shown above. But it is recommanded to use either "make config" or
"make menuconfig" and there is this or should be this "address space size option"

Klaus
Klaus-P is offline   Reply With Quote
Old 12-23-02, 08:00 AM   #5
alex31
Registered User
 
Join Date: Dec 2002
Posts: 47
Default

thanks, but i dont see this CONFIG_?GB
in my .config, and with make xconfig i don't see anything like that.

what is your kernel version ?

Alexandre




!!! here is the passage... !!!

# CONFIG_1GB is not set
CONFIG_2GB=y
# CONFIG_3GB is not set
# CONFIG_05GB is not set
CONFIG_HIGHIO=y

I guess you have

" CONFIG_1GB=y " in your .config file

Now try to edit as shown above. But it is recommanded to use either "make config" or
"make menuconfig" and there is this or should be this "address space size option"

Klaus [/b][/quote]
alex31 is offline   Reply With Quote
Old 12-23-02, 08:28 AM   #6
Klaus-P
Registered User
 
Join Date: Aug 2002
Location: Germany
Posts: 134
Default

I'm running linux kernel 2.4.18.

Maybe in your kernel Documentation of version 2.4.19 you get a hint about any changes in the configuration options.

Last edited by Klaus-P; 12-23-02 at 08:33 AM.
Klaus-P is offline   Reply With Quote
Old 12-25-02, 12:48 AM   #7
crimsun
Registered User
 
Join Date: Aug 2002
Posts: 43
Default

As far as I know, the option for 2GB is only in -aa -based kernels (SuSE, etc.). You'll need to patch your kernel source with Andrea's patches and recompile the kernel if you wish to use this option.
crimsun is offline   Reply With Quote
Old 12-25-02, 01:41 AM   #8
Noth
Registered User
 
Join Date: Nov 2002
Posts: 44
Default

I'm using CONFIG_HIGHMEM4G with the nVidia drivers and have no problems, something else has to be wrong.

And the user/kernel space split ratio wouldn't have anything to do with a kernel mode only driver.
Noth is offline   Reply With Quote

Old 12-26-02, 03:31 AM   #9
kamy
Registered User
 
Join Date: Dec 2002
Posts: 1
Default

Here's what i got when trying to compile the kernel module, i have 1.25G of ram and highmem=4G in my kernel
Attached Files
File Type: txt error.txt (1.7 KB, 139 views)
kamy is offline   Reply With Quote
Old 12-30-02, 04:36 PM   #10
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

kamy: You have unresolved symbols. This usually means your kernel source tree's configuration doesn't match your running kernel. Please make sure you're running the kernel that matches your source's configuration; you cannot use a kernel module compiled for one kernel with a different kernel.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 12-31-02, 03:52 AM   #11
alex31
Registered User
 
Join Date: Dec 2002
Posts: 47
Default

In my case, i have no problem compiling the driver with a CONFIG_HIGHMEM4G kernel,
just some warning about arithmetic on pointer.

I can insmod the driver, but i have error message about memory mapping whan i launch the X server.

Test have been made with kernel suuplied with mandrake 9.0 (2.4.19)

Alexandre
alex31 is offline   Reply With Quote
Old 08-20-03, 09:10 AM   #12
TheOuch
Registered User
 
Join Date: Jul 2003
Posts: 32
Default Is this a SUSE problem?

Are you running a SUSE kernel? I have the same issues under Suse 8.2
TheOuch is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows 8: Clarifying Codecs, Compiling, And Compatibility News Archived News Items 0 11-04-12 06:40 AM
PS Vita Firmware Update v1.8 Live Now, Check Out the PS1 Compatibility List News Archived News Items 0 08-28-12 04:50 AM
GameGrade3D S3D Compatibility Database Recognized by AMD News Archived News Items 0 06-29-12 10:10 AM
[NVIDIA REMINDER] Missing Linux kernel => 3.4.x compatibility artem NVIDIA Linux 0 05-02-12 06:09 PM
Windows 2000 Compatibility util, post-sp3 PCarr78 Microsoft Windows XP And Vista 3 09-03-02 11:41 PM

All times are GMT -5. The time now is 05:21 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.