Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-21-11, 05:28 AM   #1
atsibulnik
Registered User
 
Join Date: Sep 2011
Posts: 2
Default GT 555M with PCI ID 0x0DEB

Hello,
I've been looking for a powerful notebook with NVidia card and almost decided to obtain Lenovo Y570 with GT555M.
But unfortunately I've found out that the card is not supported by Linux NVidia driver. It has Device PCI ID: 0x0DEB,
and supported ones are 0x0DCD and 0x0DCE. So, the only way to run graphical interface in linux is to switch
to Intel HD 3000 or to use low performance "nouveau" driver, which isn't a good solution.
I like this notebook, and I can suffer poor performance for a certain amount of time, but I have to be sure that
sometimes in bright shiny future I'll get fast and fully-featured Linux desktop powered by GT 555M NVidia card.

Q: Are there any plans to implement support for GT 555M/0x0DEB in the near future?

Thanks,
Alex
atsibulnik is offline   Reply With Quote
Old 09-21-11, 10:54 AM   #2
LLStarks
Registered User
 
Join Date: Dec 2010
Posts: 66
Default Re: GT 555M with PCI ID 0x0DEB

The next Nvidia Linux driver may support it since 285.26 does on Windows, but you'll still need Bumblebee to access it.
LLStarks is offline   Reply With Quote
Old 10-07-11, 04:06 PM   #3
Divided
Registered User
 
Join Date: Oct 2011
Posts: 6
Default Re: GT 555M with PCI ID 0x0DEB

Just tried the latest binary (10/05/2011). The module doesn't recognize the chipset, so it's still not supported.



Please support this in the next driver release, Nvidia. It will make me very happy.
Divided is offline   Reply With Quote
Old 10-08-11, 08:05 AM   #4
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: GT 555M with PCI ID 0x0DEB

the chipset is supported, but:

what laptop?

does it have Optimus?

can the Intel video card be disabled in BIOS or the nVidia card be selected?

is the model number a secret or something?

If it has Optimus and you can't select the nVidia card you can't use the GPU with the nVidia drivers because at this time nVidia does not support Optimus under Linux, see the big thread: http://www.nvnews.net/vbulletin/showthread.php?t=144750
Licaon is offline   Reply With Quote
Old 10-08-11, 03:36 PM   #5
Divided
Registered User
 
Join Date: Oct 2011
Posts: 6
Default Re: GT 555M with PCI ID 0x0DEB

Yeah, I don't know. There is Bumblebee now, but for that too work I think the modules have to first be loaded. My problem is that the Nvidia module doesn't load, but the intel one does.

I'm on a Y570. Unfortunately, the 555M that is in this notebook, as has already been said is not the standard reference design for the 555M, hence the different PCI ID. It also seems the Nvidia chip displays to the screen through the Intel chip (they work together in some way so there is no on/off mux). So I haven't been able to find out if this PCI ID is part of the linux driver; is there some way to extract the contents of the nvidia driver so that I can read the PCI ID list? I would assume that if it was included, it would work through the intel chip if it needs to.

Anyone know?

Here's an excerpt from my xorg log file.
Quote:
[ 162.333] (II) LoadModule: "fb"
[ 162.333] (II) Reloading /usr/lib64/xorg/modules/libfb.so
[ 162.333] (II) Loading sub module "dri2"
[ 162.333] (II) LoadModule: "dri2"
[ 162.333] (II) Reloading /usr/lib64/xorg/modules/extensions/libdri2.so
[ 162.333] (==) NVIDIA(1): Depth 24, (==) framebuffer bpp 32
[ 162.333] (==) NVIDIA(1): RGB weight 888
[ 162.333] (==) NVIDIA(1): Default visual is TrueColor
[ 162.333] (==) NVIDIA(1): Using gamma correction (1.0, 1.0, 1.0)
[ 162.343] (EE) NVIDIA(1): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please
[ 162.343] (EE) NVIDIA(1): check your system's kernel log for additional error
[ 162.343] (EE) NVIDIA(1): messages and refer to Chapter 8: Common Problems in the
[ 162.343] (EE) NVIDIA(1): README for additional information.
[ 162.343] (EE) NVIDIA(1): Failed to initialize the NVIDIA graphics device!
[ 162.343] (II) UnloadModule: "nvidia"
[ 162.343] (II) UnloadModule: "wfb"
[ 162.343] (II) UnloadModule: "fb"
[ 162.343] (==) Depth 24 pixmap format is 32 bpp
[ 162.343] (II) intel(0): [DRI2] Setup complete
[ 162.343] (II) intel(0): [DRI2] DRI driver: i965
[ 162.343] (II) intel(0): Allocated new frame buffer 1408x768 stride 5632, tiled
[ 162.383] (II) UXA(0): Driver registered support for the following operations:
[ 162.383] (II) solid
[ 162.383] (II) copy
[ 162.383] (II) composite (RENDER acceleration)
[ 162.383] (II) put_image
[ 162.383] (II) get_image
[ 162.383] (==) intel(0): Backing store disabled
[ 162.383] (==) intel(0): Silken mouse enabled
[ 162.386] (II) intel(0): Initializing HW Cursor
[ 162.392] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[ 162.394] (==) intel(0): DPMS enabled
[ 162.394] (==) intel(0): Intel XvMC decoder enabled
[ 162.394] (II) intel(0): Set up textured video
[ 162.394] (II) intel(0): [XvMC] xvmc_vld driver initialized.
[ 162.395] (II) intel(0): direct rendering: DRI2 Enabled
[ 162.395] (==) intel(0): hotplug detection: "enabled"
Here's two from syslog

Quote:
Sep 27 18:40:36 Blake kernel: [ 10.776641] [drm:intel_dsm_platform_mux_info] *ERROR* MUX INFO call failed
Quote:
Oct 8 14:45:55 Blake kernel: [ 44.362822] NVRM: failed to copy vbios to system memory.
Oct 8 14:45:55 Blake kernel: [ 44.372774] NVRM: RmInitAdapter failed! (0x30:0xffffffff:864)
Oct 8 14:45:55 Blake kernel: [ 44.372793] NVRM: rm_init_adapter(0) failed
Here's two from messages

Quote:
Oct 8 14:45:31 Blake kernel: [ 11.177070] [drm] nouveau 0000:01:00.0: Detected an NVc0 generation card (0x0c1580a1)
Oct 8 14:45:31 Blake kernel: [ 11.184932] [drm] nouveau 0000:01:00.0: Attempting to load BIOS image from PRAMIN
Oct 8 14:45:31 Blake kernel: [ 11.194760] [drm] nouveau 0000:01:00.0: ... BIOS signature not found
Oct 8 14:45:31 Blake kernel: [ 11.194841] [drm] nouveau 0000:01:00.0: Attempting to load BIOS image from PROM
Oct 8 14:45:31 Blake kernel: [ 11.194957] [drm] nouveau 0000:01:00.0: ... BIOS signature not found
Oct 8 14:45:31 Blake kernel: [ 11.195036] [drm] nouveau 0000:01:00.0: Attempting to load BIOS image from PCIROM
Oct 8 14:45:31 Blake kernel: [ 11.205156] [drm] nouveau 0000:01:00.0: ... BIOS signature not found
Oct 8 14:45:31 Blake kernel: [ 11.205236] [drm] nouveau 0000:01:00.0: Attempting to load BIOS image from ACPI
Oct 8 14:45:31 Blake kernel: [ 11.205350] [drm] nouveau 0000:01:00.0: ... BIOS signature not found
Oct 8 14:45:31 Blake kernel: [ 11.210432] nouveau 0000:01:00.0: PCI INT A disabled
Quote:
Oct 8 14:45:31 Blake kernel: [ 11.380888] i915 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Oct 8 14:45:31 Blake kernel: [ 11.448788] mtrr: no more MTRRs available
Oct 8 14:45:31 Blake kernel: [ 11.448908] [drm] MTRR allocation failed. Graphics performance may suffer.
Oct 8 14:45:31 Blake kernel: [ 11.450020] vga_switcheroo: enabled
Oct 8 14:45:31 Blake kernel: [ 11.521466] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=nonew ns=io+mem
Oct 8 14:45:31 Blake kernel: [ 11.521582] vgaarb: transferring owner from PCI:0000:00:02.0 to PCI:0000:01:00.0
Oct 8 14:45:31 Blake kernel: [ 11.632444] fb0: inteldrmfb frame buffer device
Oct 8 14:45:31 Blake kernel: [ 11.632467] drm: registered panic notifier
Oct 8 14:45:31 Blake kernel: [ 11.635123] acpi device:31: registered as cooling_device10
Oct 8 14:45:31 Blake kernel: [ 11.635528] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/device:2f/LNXVIDEO:00/input/input13
Oct 8 14:45:31 Blake kernel: [ 11.635717] ACPI: Video Device [PEGP] (multi-head: no rom: yes post: no)
Oct 8 14:45:31 Blake kernel: [ 11.638905] acpi device:3d: registered as cooling_device11
Oct 8 14:45:31 Blake kernel: [ 11.639267] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:01/input/input14
Oct 8 14:45:31 Blake kernel: [ 11.639421] ACPI: Video Device [GFX0] (multi-head: yes rom: no post: no)
Oct 8 14:45:31 Blake kernel: [ 11.639719] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
Oct 8 14:45:31 Blake kernel: [ 12.166334] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
Oct 8 14:45:31 Blake kernel: [ 12.166398] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Oct 8 14:45:31 Blake kernel: [ 12.166463] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=nonew ns=none
I'll have to figure out how to disable the attempt to initialize nouvea, but does anyone know if this is enough for Bumblebee to work with? I must admit, I don't really understand most of what these logs are saying, but the gist seems to be that the kernel is forced to use the intel chipset over the nvidia.
Divided is offline   Reply With Quote
Old 10-09-11, 06:00 PM   #6
Divided
Registered User
 
Join Date: Oct 2011
Posts: 6
Default Re: GT 555M with PCI ID 0x0DEB

Yeah, it's not supported. I looked over the README for the latest driver (10/05/2011). The Lenovo 555M is PCI ID 0x0DEB and the supported 555M chips are:
GeForce GT 555M 0x0DCD
GeForce GT 555M 0x0DCE

I don't really know if that's related to Optimus (if the GPUs supported don't use it). If this isn't an Optimus issue (assuming it isn't since Bumblebee exists), would it matter to anyone important if I make this request that it get included in the next driver release?
Divided is offline   Reply With Quote
Old 12-19-11, 02:15 AM   #7
presianbg
Registered User
 
Join Date: Dec 2011
Posts: 25
Default Re: GT 555M with PCI ID 0x0DEB

Dear All,

I have the exact same problem here .... Lenovo Y570 with gt555m on Ubuntu 11.10 x64 (and the the graphic card is not supported) ! So ... from who depends to get supported in the next driver realise ? Is there a work around the get work or we just f*cked up ?


Best Regards,

Presian
presianbg is offline   Reply With Quote
Old 12-19-11, 03:35 PM   #8
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: GT 555M with PCI ID 0x0DEB

Have any of you guys tried to modify your video BIOS with a different PCI ID? If not, it would be worth a shot. It is not straight forward to do on laptops (usually embedded in the motherboard BIOS) so if you do not know what you are doing I would not recommend it.
mooninite is offline   Reply With Quote

Old 12-19-11, 06:55 PM   #9
Plagman
NVIDIA Corporation
 
Plagman's Avatar
 
Join Date: Sep 2007
Posts: 254
Default Re: GT 555M with PCI ID 0x0DEB

The 0x0DEB-based 555M product is going to be correctly marked as supported in the README of the next driver release series, please see this thread:

http://www.nvnews.net/vbulletin/showthread.php?t=170057

However in this case the VBIOS initialization problem is a different issue that we're actively attempting to reproduce and investigate. I'll update this thread when I have more information.
Plagman is offline   Reply With Quote
Old 12-20-11, 10:25 AM   #10
UVV
Registered User
 
Join Date: Dec 2011
Location: Dusseldorf, Germany
Posts: 10
Default Re: GT 555M with PCI ID 0x0DEB

Quote:
Originally Posted by Plagman View Post
The 0x0DEB-based 555M product is going to be correctly marked as supported in the README of the next driver release series, please see this thread:

http://www.nvnews.net/vbulletin/showthread.php?t=170057

However in this case the VBIOS initialization problem is a different issue that we're actively attempting to reproduce and investigate. I'll update this thread when I have more information.
Doesn't sound good now. In my post I was referring to this particular issue. I thought that both issues are related.
UVV is offline   Reply With Quote
Old 12-27-11, 04:30 PM   #11
Lekensteyn
Registered User
 
Join Date: Dec 2011
Posts: 14
Default Re: GT 555M with PCI ID 0x0DEB

nouveau users, please test the patch at https://github.com/Bumblebee-Project...omment-3285349 and report back. If the ROM is still not detected via ACPI, please mention your laptop model and post your DSDT and SSDT tables as described on http://linux-hybrid-graphics.blogspot.com/
Lekensteyn is offline   Reply With Quote
Old 12-31-11, 09:56 AM   #12
UVV
Registered User
 
Join Date: Dec 2011
Location: Dusseldorf, Germany
Posts: 10
Default Re: GT 555M with PCI ID 0x0DEB

Quote:
Originally Posted by Plagman View Post
The 0x0DEB-based 555M product is going to be correctly marked as supported in the README of the next driver release series, please see this thread:

http://www.nvnews.net/vbulletin/showthread.php?t=170057

However in this case the VBIOS initialization problem is a different issue that we're actively attempting to reproduce and investigate. I'll update this thread when I have more information.
Do you have any news on that?
I tried the latest version 295.09 and VBIOS issue is still present.
Perhaps you need any logs or something else? Please let me know I can try to help.
UVV is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:30 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.