Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-25-11, 12:07 PM   #1
Soulsuke
Registered User
 
Join Date: Sep 2011
Posts: 11
Default High CPU issues on xorg-server-core 1.11.1-1 on Debian

Hi,
the recent bug fix in X (at least the one in Debian Sid) makes it work pretty well with NVIDIA drivers, but I'm experiencing high cpu spikes whenever pop-ups (such as those generated by notify-send and pressing gnome volume hotkeys) appear on screen, and it lasts as long as the pop-up does (in the case of the volume hotkeys ones, it's a pretty long period), causing some noticeable lag in X applications.
Attached Files
File Type: gz nvidia-bug-report.log.gz (85.4 KB, 113 views)
Soulsuke is offline   Reply With Quote
Old 09-25-11, 02:29 PM   #2
hybris
Registered User
 
Join Date: Sep 2011
Posts: 2
Default Re: High CPU issues on xorg-server-core 1.11.1-1 on Debian

i confirm extreme slowliness in many common cases in a KDE environment too.

debian unstable with the very last x server that solves the graphics corruption and crashes of this thread:
http://www.nvnews.net/vbulletin/show...06#post2479906

application menu takes several seconds to show
any animation of the gui is extremely slow too
popups in firefox

and many other things

bug report and perf report are here

http://www.flatworld.eu/nvidia-bug-report.log.gz

http://www.flatworld.eu/perf.data.bz2
hybris is offline   Reply With Quote
Old 09-27-11, 05:33 AM   #3
Poldo Sbaffini
Registered User
 
Join Date: Sep 2011
Posts: 3
Default Re: High CPU issues on xorg-server-core 1.11.1-1 on Debian

Quote:
Originally Posted by Soulsuke View Post
Hi,
the recent bug fix in X (at least the one in Debian Sid) makes it work pretty well with NVIDIA drivers, but I'm experiencing high cpu spikes whenever pop-ups (such as those generated by notify-send and pressing gnome volume hotkeys) appear on screen, and it lasts as long as the pop-up does (in the case of the volume hotkeys ones, it's a pretty long period), causing some noticeable lag in X applications.
i just want to confirm this behavior on debian sid
after i i updated xserver-xorg to 2:1.11.1-1 (fixing the fb->wfb renaming issues) everything is unreally slow... moving a window puts one core to 99% cpu etc
driver is 275.28, board is GeForce 9400 GT

the debian changelog for 2:1.11.0-1 to 2:1.11.1-1 is


xorg-server (2:1.11.1-1) unstable; urgency=high
[ Cyril Brulebois ]
  • Bump glproto dependency for xserver-xorg-dev (Closes: #639651).
  • Set urgency to high since there were no issues other than the libwfb one (see below) in the last 4 weeks.

[ Julien Cristau ]
  • New upstream bugfix release
    • belatedly bump extension ABI major
    • add missing fbFoo wfbFoo renames for libwfb.so, fixing issues with the nvidia driver (closes: #641344)
Attached Files
File Type: gz nvidia-bug-report.log.gz (60.9 KB, 91 views)
Poldo Sbaffini is offline   Reply With Quote
Old 09-27-11, 05:55 AM   #4
Poldo Sbaffini
Registered User
 
Join Date: Sep 2011
Posts: 3
Default Re: High CPU issues on xorg-server-core 1.11.1-1 on Debian

just another data point: the problems i reported in my previous post were encountered while i was using compiz; now i'm using another (non compositing) window manager and afaict everything is ok

regards,
gb

Addendum 2011-09-30

i ihave installed the latest driver in the variuos driver series( 175, 180, 185), and i've verified that ALL the drivers give severely under par performance if used with compiz, while under twm the performance of ALL the drivers is OK

Last edited by Poldo Sbaffini; 09-30-11 at 11:37 AM. Reason: additional info
Poldo Sbaffini is offline   Reply With Quote
Old 09-28-11, 08:23 AM   #5
ant
A GeForced Ant
 
ant's Avatar
 
Join Date: Sep 2002
Location: An Ant Farm
Posts: 348
Default Re: High CPU issues on xorg-server-core 1.11.1-1 on Debian

Interesting. I have not seen this problem with KDE v3.5.10 and Compiz in my old Debian box with an GeForce 8800 GT video card. I did have to use a workaround because X.org v1.11 did not like my NVIDIA driver as shown in http://www.nvnews.net/vbulletin/showthread.php?t=165665 (latest post).
__________________
Ant @ The Ant Farm (http://antfarm.ma.cx) and Ant's Quality Foraged Links (http://aqfl.net).
ant is offline   Reply With Quote
Old 10-03-11, 04:02 PM   #6
dae
Registered User
 
Join Date: Jul 2004
Location: Sweden
Posts: 40
Default Re: High CPU issues on xorg-server-core 1.11.1-1 on Debian

Still seeing extreme cpu spikes and an unusable desktop in general, with xorg-server-1.11.1 and nvidia-285.05.09. Had to go back to 1.10.4.

I'm running kde-4.7.1, with desktop effects enabled. Disabling it made no noticable difference.
Attached Files
File Type: gz nvidia-bug-report.log.gz (43.5 KB, 78 views)
dae is offline   Reply With Quote
Old 10-03-11, 04:06 PM   #7
ant
A GeForced Ant
 
ant's Avatar
 
Join Date: Sep 2002
Location: An Ant Farm
Posts: 348
Default Re: High CPU issues on xorg-server-core 1.11.1-1 on Debian

OK, I think I am starting to see weird/odd problems like slowness and pauses over the weekend of usage (didn't use it much last week). I even black animated loading cursor. However, I don't see my top showing CPU going up much? I never had this problem before I upgraded xorg so I assume this is related to the upgrade and the older NVIDIA driver and without its workaround. I saw nothing odd in dmesg. I might go to the newest driver and use the workaround since I didn't see that problem (didn't use it much).
__________________
Ant @ The Ant Farm (http://antfarm.ma.cx) and Ant's Quality Foraged Links (http://aqfl.net).
ant is offline   Reply With Quote
Old 10-04-11, 04:46 PM   #8
one_and_only
Registered User
 
Join Date: Mar 2007
Posts: 47
Default Re: High CPU issues on xorg-server-core 1.11.1-1 on Debian

For oxygen-gtk seems to be the issue of high cpu usage. Are you using this gtk theme?
one_and_only is offline   Reply With Quote

Old 10-04-11, 05:55 PM   #9
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: High CPU issues on xorg-server-core 1.11.1-1 on Debian

I tracked this down to this commit to the X server:
http://cgit.freedesktop.org/xorg/xse...11eec3338fb969

It removed our ability to accelerate part of the trapezoid rendering process and forces the whole thing (even the part we can accelerate) to fall back to software on GPUs that do not support full trapezoid acceleration. I've started a discussion on the xorg-devel@lists.x.org mailing list to see how the X community wants to solve this problem:

http://lists.x.org/archives/xorg-dev...er/026050.html
AaronP is offline   Reply With Quote
Old 10-04-11, 10:26 PM   #10
mdriftmeyer
Registered User
 
Join Date: Feb 2009
Posts: 40
Default Re: High CPU issues on xorg-server-core 1.11.1-1 on Debian

Switching Chrome's theme out from GTK+ to it's ``native'' them cuts out the drag on Xorg for that specific application.

Whether it's typing lag in the uri textfield or in forms or opening a new tab, the GTK+ theme working with Xorg seems to crap the server.

Of course, Iceweasel/Firefox doesn't have anything but a GTK+ theme.

Does GTK+ leverage XUL+Mozilla's Javascript engine to draw the them?

If so, the sooner GNOME completes its switch over to WebKit for it's Help System, GNOME-SHELL and more the better.

They've targeted Gnome 3.4 for April 2012, so I cannot imagine waiting that long for GTK+ and XOrg + Aaron's suggestion about trapezoidal rendering in the GPU versus Software being part of the problem taking that long to find a best solution that will allow GTK+ apps/GNOME 3.x apps and Xorg + Nvidia to work smoothly together.

The Nvidia 8600GTS has more than enough power to manage all that today's Linux/Xorg system can throw at it.

Hell, they have just barely started touching OpenGL ES 2.0 acceleration with KDE 4.7.x, so don't tell me it's due to an incapable GPU.
mdriftmeyer is offline   Reply With Quote
Old 10-04-11, 10:40 PM   #11
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: High CPU issues on xorg-server-core 1.11.1-1 on Debian

Quote:
Originally Posted by mdriftmeyer View Post
The Nvidia 8600GTS has more than enough power to manage all that today's Linux/Xorg system can throw at it.
Actually, the 8600 GTS is missing some of the shader support needed to make trapezoids work the way Xorg expects them. X trapezoids are surprisingly computationally intensive. You can tell if your GPU supports trapezoid acceleration if "nvidia-settings -q AccelerateTrapezoids" prints something.

This X server regression only affects GPUs that don't support trapezoid rendering.
AaronP is offline   Reply With Quote
Old 10-05-11, 06:08 AM   #12
thefirstm
Registered User
 
Join Date: Feb 2009
Posts: 226
Default Re: High CPU issues on xorg-server-core 1.11.1-1 on Debian

Could this also be causing the slow, jerky scrolling problem that I have with xorg-server 1.11.1 and 285.05.09 on an 8600m GT?
thefirstm is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:01 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.