Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-10-11, 05:30 PM   #1
MaDDeePee
Registered User
 
Join Date: Aug 2010
Posts: 41
Default 270.41.xx breaks java with xinerama?

Two boards in one PC:

GTX 560ti, GT 520.

For that reason i need at least 270.41.xx to make X able to recognize my cards.

Problem with that:

The current available 270.41.03 and 270.41.06 are breaking java with xinerama.

Reproduce:

Install Sweethome3d 3d home model java program. ( http://www.sweethome3d.com )
Use either 270.41.03 or 270.41.06
Use at least 2 Screens (i am using 4) with Xinerama ENABLED (not twinview !)
start Sweethome3d:

Code:
maddeepee@MaDWorkStatioN /opt/SweetHome3D-3.2 $ ./SweetHome3D 
An irrecoverable stack overflow has occurred.
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x6d7a33c0, pid=4340, tid=1821096816
#
# JRE version: 6.0_24-b07
# Java VM: Java HotSpot(TM) Server VM (19.1-b02 mixed mode linux-x86 )
# Problematic frame:
# C  [libnvidia-glcore.so.270.41.03+0xc8d3c0]
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid4340.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Now, either disable Xinerama or "force" a 260.19.44 driver over your running X (you wont get a screen with that driver and that cards from boot, but its working with a running system).

Sweethome3d is working with 260.19.44 libraries on GT520/GTX560ti @ Xinerama.

For that reason i think there is something wrong with 270.41.03 && 270.41.06.

Help MUCH appreciated!

Yours
MaDDeePee is offline   Reply With Quote
Old 05-11-11, 05:54 AM   #2
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: 270.41.xx breaks java with xinerama?

can you read http://www.nvnews.net/vbulletin/showthread.php?t=46678 and generate a good report with the debug ( -logverbose 6 ) info as instructed after the issue appears ?
Licaon is offline   Reply With Quote
Old 05-11-11, 01:19 PM   #3
MaDDeePee
Registered User
 
Join Date: Aug 2010
Posts: 41
Default Re: 270.41.xx breaks java with xinerama?

Yes, of course - sry!

Attached Files
File Type: gz nvidia-bug-report.log.gz (140.1 KB, 69 views)
MaDDeePee is offline   Reply With Quote
Old 05-18-11, 11:35 PM   #4
MaDDeePee
Registered User
 
Join Date: Aug 2010
Posts: 41
Default Re: 270.41.xx breaks java with xinerama?

hmm...nothing on this?


So...isn't it a driver problem?
MaDDeePee is offline   Reply With Quote
Old 05-20-11, 09:50 AM   #5
MaDDeePee
Registered User
 
Join Date: Aug 2010
Posts: 41
Default Re: 270.41.xx breaks java with xinerama?

Also happens with 275.09 and other Java Apps....Here now: Wakfu.
is it only me? Is it a java bug?

Quote:
maddeepee@MaDWorkStatioN ~/ankama/Wakfu $ ./Wakfu
An irrecoverable stack overflow has occurred.
#
# An unexpected error has been detected by Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x96e6c5c0, pid=19106, tid=2569202544
#
# Java VM: Java HotSpot(TM) Server VM (10.0-b23 mixed mode linux-x86)
# Problematic frame:
# C [libnvidia-glcore.so.275.09+0xd0c5c0]
#
# An error report file with more information is saved as:
# /home/maddeepee/ankama/Wakfu/hs_err_pid19106.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
./Wakfu: Zeile 378: 19106 Abgebrochen "$app_java_home/bin/java" -server "-splash:$app_home/.install4j/Splash.png" -Dinstall4j.jvmDir="$app_java_home" -Dexe4j.moduleName="$prg_dir/$progname" "-server" "-Xmx320M" "-Dsun.java2d.noddraw=true" "-XX:MaxDirectMemorySize=92m" "-XX:+ForceTimeHighResolution" "-Dsun.awt.noerasebackground=true" "-XX:+UseConcMarkSweepGC" "-XX:+CMSIncrementalMode" "-XX:CMSIncrementalSafetyFactor=3" "$vmov_1" "$vmov_2" "$vmov_3" "$vmov_4" "$vmov_5" $INSTALL4J_ADD_VM_PARAMS -classpath "$local_classpath" com.install4j.runtime.Launcher launch com.ankamagames.wakfu.client.WakfuClient true false "$prg_dir/error.log" "$prg_dir/output.log" true true false "Splash.png" true true 350 200 "" 20 20 "Arial" "0,0,0" 8 500 "version 2" 20 40 "Arial" "0,0,0" 8 500 -1 "$@"
MaDDeePee is offline   Reply With Quote
Old 05-20-11, 12:39 PM   #6
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: 270.41.xx breaks java with xinerama?

There does seem to be a regression in the 270 and later drivers with respect to JOGL and Xinerama. We have reproduced the problem internally but we don't know yet whether it's a new bug in the driver, or an old bug in JOGL exposed by a change in the driver.

NVIDIA bug number for this issue is 826235.

Last edited by danix; 05-20-11 at 12:40 PM. Reason: Clarified that the regression is specific to Xinerama configurations.
danix is offline   Reply With Quote
Old 05-29-11, 03:32 PM   #7
MaDDeePee
Registered User
 
Join Date: Aug 2010
Posts: 41
Default Re: 270.41.xx breaks java with xinerama?

Well, ok?

And now? does i have to note a bug at some Java forum...or is Nvidia looking after this in some time?
MaDDeePee is offline   Reply With Quote
Old 05-30-11, 04:02 PM   #8
sgothel
Registered User
 
Join Date: May 2011
Posts: 1
Default Re: 270.41.xx breaks java with xinerama?

Hi there, I am the maintainer of JOGL @ jogamp.org,
not supporting for the 'old' JOGL 1.* variants.

If I can help w/ this issue, please email me / reply with details etc.

I can say that the Xinerama handling is almost identical between JOGL1 and JOGL2
and so far complies w/ the specs.

Since I am not aware about the named application,
I would love to see a small 'n simple [unit] test case.

Bumping up our drivers to NVIDIA-Linux-x86_64-275.09.run (beta) in the meantime,
allowing to catch some bugs in our jenkins test suite ..
sgothel is offline   Reply With Quote

Old 06-17-11, 03:11 AM   #9
MaDDeePee
Registered User
 
Join Date: Aug 2010
Posts: 41
Default Re: 270.41.xx breaks java with xinerama?

This problem isn't fixed yet with 275.09.07
Unable to run any Java program that uses OpenGL...


(a quick reminder, :-) )
MaDDeePee is offline   Reply With Quote
Old 07-02-11, 04:12 AM   #10
MaDDeePee
Registered User
 
Join Date: Aug 2010
Posts: 41
Default Re: 270.41.xx breaks java with xinerama?

Still @ 280.4
MaDDeePee is offline   Reply With Quote
Old 09-29-11, 05:03 PM   #11
MaDDeePee
Registered User
 
Join Date: Aug 2010
Posts: 41
Default Re: 270.41.xx breaks java with xinerama?

Any news about this?
MaDDeePee is offline   Reply With Quote
Old 09-29-11, 05:08 PM   #12
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: 270.41.xx breaks java with xinerama?

Looking at the notes for bug 826235, it seems that this should be fixed in the 285.xx drivers. Are you still seeing problems with 285?
danix is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:30 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.