Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-24-11, 04:34 AM   #1
thecapsaicinkid
Registered User
 
Join Date: Aug 2010
Posts: 47
Default 285.05.09 + latest mplayer, problems with VDPAU DI

Ubuntu 10.04 LTS
gpu G210 + driver 285.05.09
mplayer from daily snapshot ppa
powermizer to max perf
compositing disabled



Playing back a BBC HD recording, if I set deint to 2 or 3 something odd happens (deint=4 causes framedropping straight away as expected) The video will play back smoothly

Code:
[h264_vdpau @ 0x89322a0]illegal short term buffer state detected
A:38769.3 V:38769.3 A-V: -0.000 ct: -1.005   0/  0  1% 39%  2.3% 1 0 50%
until it reaches a specific point in the video where the frames dropped counter (3rd number from the end?) will suddenly start increasing rapidly (~20/s) and the video starts to slow slightly and audio will start to drift out of sync (even though A-V still says ~0)

Code:
AO: [pulse] 48000Hz 6ch floatle (4 bytes per sample) <- Adverts stop, program starts and switches 2ch>5.1
A:38986.9 V:38986.9 A-V:  0.000 ct: -0.941   0/  0  0% 93%  1.9% 1621 0 50%
The thing is, if I seek (say 30s forward and then back again to just after the point of the problem) sync is restored and the frame drop counter stays at zero and everything carries on as normal until maybe say 10mins time it happens again. I can seek back, sync will restore and it will play the same section without dropping frames. It does this 3-4 times over a 45min program. If the gpu can't handle deint=2/3 then I wouldn't expect seeking to fix the issue. Basically as soon as 1 frame is dropped, things spiral out of control, like some sort of memory leak.


mplayer config

Code:
[default]
# Write your default config options here!

fs=yes
demuxer=lavf
vo=vdpau:deint=3
vc=ffmpeg12vdpau,ffh264vdpau,ffvc1vdpau,ffwmv3vdpau,
vfm=ffmpeg,

ao=pulse
ac=fftruehd,ffdca,ffeac3,ffac3,fflpcm,
afm=ffmpeg,
alang=English,eng,en
slang=English,eng,en
forcedsubsonly=yes
channels=6
af=surround=25,pan=6:1:0:0:0:0:0:0:1:0:0:0:0:0:0:1:0:0:0:0:0:0:1:0:0:0.62:0.62:0:0:0:0:0:0:0:0:0:1,delay=0:0:5.5:5.5:0:0
a52drc=1
autosync=1   

cache=8000
cache-min=20.0
cache-seek-min=50
nolirc=yes
nojoystick=yes
Benchmark
Code:
Intel(R) Core(TM)2 Duo CPU     E7300  @ 2.66GHz
NVIDIA GPU GeForce 210 (GT218) at PCI:2:0:0 (GPU-0)

VDPAU API version : 1
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  285.05.09  Fri Sep 23 19:17:37 PDT 2011

SURFACE GET BITS: 1143.35 M/s
SURFACE PUT BITS: 905.532 M/s

MPEG DECODING (1920x1080): 67 frames/s
MPEG DECODING (1280x720): 162 frames/s
H264 DECODING (1920x1080): 64 frames/s
H264 DECODING (1280x720): 116 frames/s
VC1 DECODING (1440x1080): 83 frames/s
MPEG4 DECODING (1920x1080): 67 frames/s

MIXER WEAVE (1920x1080): 298 frames/s
MIXER BOB (1920x1080): 494 fields/s
MIXER TEMPORAL (1920x1080): 139 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 91 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 185 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 60 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 48 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 68 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 214 fields/s
MIXER TEMPORAL_SPATIAL + HQSCALING (720x576 video to 1920x1080 display): 128 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 62 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 94 fields/s
Complete mplayer output
http://pastebin.com/78kTDyuY
Attached Files
File Type: gz nvidia-bug-report.log.gz (41.3 KB, 25 views)
thecapsaicinkid is offline   Reply With Quote
Old 10-24-11, 03:03 PM   #2
thecapsaicinkid
Registered User
 
Join Date: Aug 2010
Posts: 47
Default Re: 285.05.09 + latest mplayer, problems with VDPAU DI

Just found out this issue isn't limited to HD content, this is the result of letting an SD recording run through. It plays for quite a while before the dropped frame count starts to go up and eventually it crashes mplayer.

I'm starting to think this is an audio driver bug.

http://pastebin.com/pw9ciXdA
thecapsaicinkid is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:19 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.