Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-09-10, 02:51 PM   #1
luother
Guest
 
Posts: n/a
Default Lock PowerMizer in LOWEST mode on-the-fly?

Hi,

this question has been asked many times the other way around, but is it possible to lock PowerMizer in the lowest mode for power saving reasons?

In my tries my NVIDIA 8400M GS takes about 2W more while running in highest state ( I know you hate that card ), and it stays for 15 seconds in this state after whatever triggered transition. That could happen even from some KDE App or whatever.

I know I can SOMEHOW lock my card with RESTARTING X, but thats IMO no solution.

BTW underclocking does not work with the newest 260.19.12 driver, it simply jumps back to original frequencies.

Thanks for hints,

robert
  Reply With Quote
Old 11-15-10, 05:17 AM   #2
quantumphaze
Registered User
 
Join Date: Nov 2010
Posts: 1
Default Re: Lock PowerMizer in LOWEST mode on-the-fly?

There is not much I can help you with, but you can have it forced to be on the lowest clock when on battery and dynamic when on AC.

In your Device section of xorg.conf
Code:
Option         "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2233; PowerMizerLevel=0x3"
I really want to be able to force it to be on low when on AC on the fly like I can force it to be maximum with the nvidia-settings GUI. As it stands it will rocket up to maximum if I do as much as move a window.
quantumphaze is offline   Reply With Quote
Old 11-15-10, 12:37 PM   #3
luother
Guest
 
Posts: n/a
Default Re: Lock PowerMizer in LOWEST mode on-the-fly?

Ack, I don't understand why its possible to lock the highest mode while its not possible to lock the lowest mode, as the mechanism should be the same???
  Reply With Quote
Old 12-15-10, 02:38 PM   #4
XjCook
Registered User
 
Join Date: Oct 2010
Posts: 28
Default Re: Lock PowerMizer in LOWEST mode on-the-fly?

Hi,
in xorg.conf I have this line:
Code:
Option         "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2233; PowerMizerLevel=0x3"
But from 260.19.xx drivers lock frequency to the lowest is not possible. With 256.53 low mode was working without problems.
XjCook is offline   Reply With Quote
Old 12-19-10, 03:19 AM   #5
zzpulp
Registered User
 
Join Date: Dec 2010
Posts: 1
Default Re: Lock PowerMizer in LOWEST mode on-the-fly?

If you are having problems underclocking then attach a copy of your videocard bios here (rom file).
zzpulp is offline   Reply With Quote
Old 04-30-11, 10:07 AM   #6
XjCook
Registered User
 
Join Date: Oct 2010
Posts: 28
Default Re: Lock PowerMizer in LOWEST mode on-the-fly?

It is possible lock powermizer to lowest mode? Because this is very important on laptop without Optimus (fortunately). I can do lot of power saver settings but without underclock discrete graphics everything is worthless. Dynamic change clock frequency is working right but this is not sufficient. For example when I scroll webpage powermizer goes to highest mode for a while
XjCook is offline   Reply With Quote
Old 05-08-11, 01:54 PM   #7
luother
Guest
 
Posts: n/a
Default Re: Lock PowerMizer in LOWEST mode on-the-fly?

I'm still on driver 256.53, as that seemed to be the best. Unfortunately its not working with the latest Xorg 1.10
  Reply With Quote
Old 05-09-11, 06:07 PM   #8
ledoc
Registered User
 
Join Date: Jan 2008
Posts: 330
Default Re: Lock PowerMizer in LOWEST mode on-the-fly?

I used to have some success with:
nvidia-settings -> Clock Frequencies -> Enable Overclocking -> set GPU and memory to the maximum you like (say the frequencies of the lowest or middle performance level).
Then, even in the highest performance level it would not exceed those frequencies. Not sure that still works with modern drivers and GPUs though.
ledoc is offline   Reply With Quote

Old 10-30-11, 07:23 PM   #9
XjCook
Registered User
 
Join Date: Oct 2010
Posts: 28
Default Re: Lock PowerMizer in LOWEST mode on-the-fly?

now it's working like a charm

In device section of xorg.conf I have:

Code:
Option "RegistryDwords" "PowerMizerEnable=0x1;PerfLevelSrc=0x2233;PowerMizerDefault=0x3"
If I run on battery it forces the lowest mode and on power it sets adaptive strategy of powermizer.
XjCook is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:32 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.