Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-24-03, 03:48 PM   #1
t-v
Registered User
 
Join Date: Jul 2003
Posts: 2
Question Epox 8RDA+ & Matrox G550: X freezes after start of glxgears

Hello,

I'm having problems using 3D acceleration with a Matrox G550 on an Epox 8RDA+-mainboard (nForce2 chipset). The system is running on SuSE 8.2 with kernel 2.4.21 and is not overclocked. Without 3D acceleration, everything works fine.

When DRI/GLX is enabled for hardware acceleration, the machine just hangs up after starting glxgears. I get a window with black content. A 'sleep 120; reboot' in a second xterm still lets the box reboot.

The following messages can be found in /var/log/messages:

[...]
Jul 24 20:51:56 luke kernel: Linux agpgart interface v0.99 (c) Jeff Hartmann
Jul 24 20:51:56 luke kernel: agpgart: Maximum main memory to use for agp memory: 941M
Jul 24 20:51:56 luke kernel: agpgart: Detected Nvidia Nforce2 chipset
Jul 24 20:51:56 luke kernel: agpgart: AGP aperture is 32M @ 0xe0000000
Jul 24 20:51:56 luke kernel: [drm] AGP 0.99 on Unknown @ 0xe0000000 32MB
Jul 24 20:51:56 luke kernel: [drm] Initialized mga 3.0.2 20010321 on minor 0
Jul 24 20:51:56 luke kernel: mtrr: base(0xe2000000) is not aligned on a size(0x1800000) boundary
[...]

and in /var/log/XFree86.0.log:

[...]
GetModeLine - scrn: 0 clock: 84990
GetModeLine - hdsp: 1024 hbeg: 1072 hend: 1248 httl: 1416
vdsp: 768 vbeg: 768 vend: 778 vttl: 802 flags: 0
(EE) MGA(0): [dri] Idle timed out, resetting engine...
(EE) MGA(0): [dri] Idle timed out, resetting engine...
(EE) MGA(0): [dri] Idle timed out, resetting engine...
(EE) MGA(0): [dri] Idle timed out, resetting engine...
(EE) MGA(0): [dri] Idle timed out, resetting engine...
(EE) MGA(0): [dri] Idle timed out, resetting engine...
(EE) MGA(0): [dri] Idle timed out, resetting engine...
[etc.]

Any ideas?

Thank you, t-v

PS. More details can be found at http://forum.matrox.com/mgaforum/For...ML/002332.html
t-v is offline   Reply With Quote
Old 09-01-03, 01:23 PM   #2
t-v
Registered User
 
Join Date: Jul 2003
Posts: 2
Default

Recently upgraded to Kernel 2.4.22-bk4 and glxgears, tuxracer etc. are working. FYI: I get around 750fps in glxgears.

:-)
t-v is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:40 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.