Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-27-03, 08:49 PM   #13
Mallec
Registered User
 
Join Date: Aug 2003
Posts: 19
Default Output from commands

Well

dmesg|grep agp generated no output

and for:
cat /proc/driver/nvidia/version
cat /proc/driver/nvidia/agp/*

doesn't exist the directory /proc/driver/nvidia
Mallec is offline   Reply With Quote
Old 08-28-03, 02:36 AM   #14
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default Good...

Good news, now your xfree log file says it loads the nvidia_drv.o. That means we are one step further in the right direction.
You xfree log file is incomplete. We need the end of it. Please post it.
Before you anything else, I want you to check a setting in your BIOS(You know what I'm talking about or not?). I want you to make the standard "assigne IRQ to VGA"=true, enable, on(don't forget to save your settings when exiting the BIOS).

if /proc/driver/nvidia does not, that means we have a pb with the nvidia kernel gateway module.

Before starting X, you must type in this order:
modprobe agpart
modprobe nvidia

Those command lines will load the modules. Please tell us what are their output. Indeed, loading the nvidia module is not quiet.
In order to check they are properly loaded, use the following command:
lsmod
In the output of this command you must see something like agpart and nvidia.
If you don't have nvidia in this output, it is useless to start X. It won't work.

So:
1 - Enable "assign IRQ to VGA" in you BIOS
2 - load agpart (modprobe agpart)
3 - load nvidia (modprobe nvidia)
4 - check that nvidia is properly loaded (lsmod)
5 - Check that /proc/driver/nvidia exists
6 - if everything is ok, start X

If something goes wrong don't forget to post us your complet xfree log file.
XoD is offline   Reply With Quote
Old 08-28-03, 09:06 AM   #15
Mallec
Registered User
 
Join Date: Aug 2003
Posts: 19
Exclamation somethis is wrong

Well...

The IRQ is assigned to VGA in my BIOS
the modprobe agpart command said that can't locate the module agpart
the modprobe nvidia command generates no output
lsmod show a line that contains nvidia
/proc/driver/nvidia exists
but... didn't work.

Because some error is occouring when you open my attachments I pasted the text of my log file here:


XFree86 Version 4.3.0
Release Date: 27 February 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.20-26373clenterprise i686 [ELF]
Build Date: 23 March 2003
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Thu Aug 28 09:56:34 2003
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "Layout0"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Card0"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbModel" "abnt2"
(**) XKB: model: "abnt2"
(**) Option "XkbLayout" "br"
(**) XKB: layout: "br"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Mouse0"
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc:unscaled,/usr/X11R6/lib/X11/fonts/75dpi:unscaled,/usr/X11R6/lib/X11/fonts/100dpi:unscaled,/usr/X11R6/lib/X11/fonts/Type1,/usr/share/fonts/default/ghostscript"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.2
XFree86 Video Driver: 0.6
XFree86 XInput driver : 0.4
XFree86 Server Extension : 0.2
XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1039,0735 card 0000,0000 rev 01 class 06,00,00 hdr 80
(II) PCI: 00:01:0: chip 1039,0001 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:02:0: chip 1039,0008 card 0000,0000 rev 00 class 06,01,00 hdr 80
(II) PCI: 00:02:2: chip 1039,7001 card 1019,0a14 rev 07 class 0c,03,10 hdr 00
(II) PCI: 00:02:3: chip 1039,7001 card 1019,0a14 rev 07 class 0c,03,10 hdr 00
(II) PCI: 00:02:5: chip 1039,5513 card 1039,5513 rev d0 class 01,01,80 hdr 80
(II) PCI: 00:09:0: chip e159,0001 card 00a7,0001 rev 00 class 02,80,00 hdr 00
(II) PCI: 00:0f:0: chip 1813,4000 card 0000,0000 rev 02 class 07,80,00 hdr 00
(II) PCI: 00:11:0: chip 1102,0002 card 1102,8064 rev 08 class 04,01,00 hdr 80
(II) PCI: 00:11:1: chip 1102,7002 card 1102,0020 rev 08 class 09,80,00 hdr 80
(II) PCI: 01:00:0: chip 10de,0110 card 0000,0000 rev b2 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x000a (VGA_EN is set)
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xcde00000 - 0xcfefffff (0x2100000) MX[b]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0xbdc00000 - 0xcdcfffff (0x10100000) MX[b]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:2:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) nVidia Corporation NV11 [GeForce2 MX/MX 400] rev 178, Mem @ 0xce000000/24, 0xc0000000/27, BIOS @ 0xcfef0000/16
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) OS-reported resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
(II) PCI Memory resource overlap reduced 0xd0000000 from 0xd3ffffff to 0xcfffffff
(II) Active PCI resource ranges:
[0] -1 0 0xcfffb000 - 0xcfffbfff (0x1000) MX[b]
[1] -1 0 0xcfffc000 - 0xcfffcfff (0x1000) MX[b]
[2] -1 0 0xcffff000 - 0xcfffffff (0x1000) MX[b]
[3] -1 0 0xcfffe000 - 0xcfffefff (0x1000) MX[b]
[4] -1 0 0xd0000000 - 0xcfffffff (0x0) MX[b]O
[5] -1 0 0xcfef0000 - 0xcfefffff (0x10000) MX[b](B)
[6] -1 0 0xc0000000 - 0xc7ffffff (0x8000000) MX[b](B)
[7] -1 0 0xce000000 - 0xceffffff (0x1000000) MX[b](B)
[8] -1 0 0x0000dc00 - 0x0000dc07 (0x8) IX[b]
[9] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[b]
[10] -1 0 0x0000d400 - 0x0000d4ff (0x100) IX[b]
[11] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[b]
[12] -1 0 0x0000ff00 - 0x0000ff0f (0x10) IX[b]
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0xcfffb000 - 0xcfffbfff (0x1000) MX[b]
[1] -1 0 0xcfffc000 - 0xcfffcfff (0x1000) MX[b]
[2] -1 0 0xcffff000 - 0xcfffffff (0x1000) MX[b]
[3] -1 0 0xcfffe000 - 0xcfffefff (0x1000) MX[b]
[4] -1 0 0xd0000000 - 0xcfffffff (0x0) MX[b]O
[5] -1 0 0xcfef0000 - 0xcfefffff (0x10000) MX[b](B)
[6] -1 0 0xc0000000 - 0xc7ffffff (0x8000000) MX[b](B)
[7] -1 0 0xce000000 - 0xceffffff (0x1000000) MX[b](B)
[8] -1 0 0x0000dc00 - 0x0000dc07 (0x8) IX[b]
[9] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[b]
[10] -1 0 0x0000d400 - 0x0000d4ff (0x100) IX[b]
[11] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[b]
[12] -1 0 0x0000ff00 - 0x0000ff0f (0x10) IX[b]
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
(II) All system resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0xcfffb000 - 0xcfffbfff (0x1000) MX[b]
[6] -1 0 0xcfffc000 - 0xcfffcfff (0x1000) MX[b]
[7] -1 0 0xcffff000 - 0xcfffffff (0x1000) MX[b]
[8] -1 0 0xcfffe000 - 0xcfffefff (0x1000) MX[b]
[9] -1 0 0xd0000000 - 0xcfffffff (0x0) MX[b]O
[10] -1 0 0xcfef0000 - 0xcfefffff (0x10000) MX[b](B)
[11] -1 0 0xc0000000 - 0xc7ffffff (0x8000000) MX[b](B)
[12] -1 0 0xce000000 - 0xceffffff (0x1000000) MX[b](B)
[13] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[14] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[15] -1 0 0x0000dc00 - 0x0000dc07 (0x8) IX[b]
[16] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[b]
[17] -1 0 0x0000d400 - 0x0000d4ff (0x100) IX[b]
[18] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[b]
[19] -1 0 0x0000ff00 - 0x0000ff0f (0x10) IX[b]
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4496
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.13.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension RECORD
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 2.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4496
Module class: XFree86 Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
(II) NVIDIA XFree86 Driver 1.0-4496 Wed Jul 16 19:06:03 PDT 2003
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0xcfffb000 - 0xcfffbfff (0x1000) MX[b]
[6] -1 0 0xcfffc000 - 0xcfffcfff (0x1000) MX[b]
[7] -1 0 0xcffff000 - 0xcfffffff (0x1000) MX[b]
[8] -1 0 0xcfffe000 - 0xcfffefff (0x1000) MX[b]
[9] -1 0 0xd0000000 - 0xcfffffff (0x0) MX[b]O
[10] -1 0 0xcfef0000 - 0xcfefffff (0x10000) MX[b](B)
[11] -1 0 0xc0000000 - 0xc7ffffff (0x8000000) MX[b](B)
[12] -1 0 0xce000000 - 0xceffffff (0x1000000) MX[b](B)
[13] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[14] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[15] -1 0 0x0000dc00 - 0x0000dc07 (0x8) IX[b]
[16] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[b]
[17] -1 0 0x0000d400 - 0x0000d4ff (0x100) IX[b]
[18] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[b]
[19] -1 0 0x0000ff00 - 0x0000ff0f (0x10) IX[b]
(II) resource ranges after probing:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0xcfffb000 - 0xcfffbfff (0x1000) MX[b]
[6] -1 0 0xcfffc000 - 0xcfffcfff (0x1000) MX[b]
[7] -1 0 0xcffff000 - 0xcfffffff (0x1000) MX[b]
[8] -1 0 0xcfffe000 - 0xcfffefff (0x1000) MX[b]
[9] -1 0 0xd0000000 - 0xcfffffff (0x0) MX[b]O
[10] -1 0 0xcfef0000 - 0xcfefffff (0x10000) MX[b](B)
[11] -1 0 0xc0000000 - 0xc7ffffff (0x8000000) MX[b](B)
[12] -1 0 0xce000000 - 0xceffffff (0x1000000) MX[b](B)
[13] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b]
[14] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b]
[15] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b]
[16] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[17] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[18] -1 0 0x0000dc00 - 0x0000dc07 (0x8) IX[b]
[19] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[b]
[20] -1 0 0x0000d400 - 0x0000d4ff (0x100) IX[b]
[21] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[b]
[22] -1 0 0x0000ff00 - 0x0000ff0f (0x10) IX[b]
[23] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b]
[24] 0 0 0x000003c0 - 0x000003df (0x20) IS[b]
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xC0000000
(--) NVIDIA(0): MMIO registers at 0xCE000000
(II) NVIDIA(0): NVIDIA GPU detected as: GeForce2 MX/MX 400
(--) NVIDIA(0): VideoBIOS: 03.11.01.30.00
(EE) NVIDIA(0): Failed to allocate config DMA context
(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@distro.conectiva.com.br.
Mallec is offline   Reply With Quote
Old 08-28-03, 10:00 AM   #16
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default agpart?

Well, you don't have the agpart module?? that is bad... in theory the nvidia kernel module should use its agp support, but it does not work with all chipsets...
What is the chipset of your motherboard? Or if you don't know it, give us the name of your motherboard?
And to be really sure that you don't have linux AGP support, post here the output of the two following commands:
#find / -iname '*agp*'
and
#dmesg

(To save the output of command into a file, use the following command syntax:
#command &>outputfilename, namely in our case you would type:
#find / -iname '*agp*' &>findoutput
#dmesg &>dmesgoutput
and you post here findoutput and dmesgoutput)
XoD is offline   Reply With Quote
Old 08-28-03, 11:08 AM   #17
Mallec
Registered User
 
Join Date: Aug 2003
Posts: 19
Default output files

I have an EliteGroup K7S5A motherboard that uses a SIS 735 chipset

Here is the output of the find command:

/dev/agpgart
/etc/rc.d/init.d/agpgart
/etc/rc.d/rcS.d/S185agpgart
/mnt/Fat32/agp.txt
/lib/modules/2.4.21-28872cl/kernel/drivers/char/agp
/lib/modules/2.4.21-28872cl/kernel/drivers/char/agp/agpgart.o
/usr/share/timidity/instruments/bagpipes.pat
/usr/include/linux/agp_backend.h
/usr/include/linux/agpgart.h
/usr/src/linux-2.4.21-28872cl/drivers/char/agp
/usr/src/linux-2.4.21-28872cl/drivers/char/agp/agpgart_be.c
/usr/src/linux-2.4.21-28872cl/drivers/char/agp/agp.h
/usr/src/linux-2.4.21-28872cl/drivers/char/agp/agpgart_fe.c
/usr/src/linux-2.4.21-28872cl/drivers/char/drm/drm_agpsupport.h
/usr/src/linux-2.4.21-28872cl/drivers/char/drm-4.0/agpsupport.c
/usr/src/linux-2.4.21-28872cl/include/linux/agp_backend.h
/usr/src/linux-2.4.21-28872cl/include/linux/agpgart.h
/usr/src/linux-2.4.21-28872cl/include/linux/modules/agpgart_be.stamp
/usr/src/linux-2.4.21-28872cl/include/linux/modules/agpgart_be.ver


And here, the content of the dmesg command:

Linux version 2.4.21-28872cl (roov@mapi8.distro.conectiva) (gcc version 3.2.2) #1 Sex Mar 21 22:55:39 BRT 2003
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000000fff0000 (usable)
BIOS-e820: 000000000fff0000 - 000000000fff8000 (ACPI data)
BIOS-e820: 000000000fff8000 - 0000000010000000 (ACPI NVS)
BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
BIOS-e820: 00000000ffee0000 - 00000000fff00000 (reserved)
BIOS-e820: 00000000fffc0000 - 0000000100000000 (reserved)
255MB LOWMEM available.
On node 0 totalpages: 65520
zone(0): 4096 pages.
zone(1): 61424 pages.
zone(2): 0 pages.
Kernel command line: root=/dev/hda3 3
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
Initializing CPU#0
Detected 1394.099 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 2785.28 BogoMIPS
Memory: 253608k/262080k available (948k kernel code, 6040k reserved, 916k data, 100k init, 0k highmem, BadRAM enabled)
Dentry cache hash table entries: 32768 (order: 6, 262144 bytes)
Inode cache hash table entries: 16384 (order: 5, 131072 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer-cache hash table entries: 16384 (order: 4, 65536 bytes)
Page-cache hash table entries: 65536 (order: 6, 262144 bytes)
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After generic, caps: 0383fbff c1cbfbff 00000000 00000000
CPU: Common caps: 0383fbff c1cbfbff 00000000 00000000
CPU: AMD Athlon(tm) XP 1600+ stepping 02
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
enabled ExtINT on CPU#0
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 1394.0844 MHz.
..... host bus clock speed is 265.5398 MHz.
cpu: 0, clocks: 2655398, slice: 1327699
CPU0<T0:2655392,T1:1327680,D:13,S:1327699,C:265539 8>
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.10 entry at 0xfdb01, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Using IRQ router SiS [1039/0008] at 00:02.0
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
Starting kswapd
kinoded started
VFS: Diskquotas version dquot_6.5.1 initialized
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with ManY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI ISAPNP enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Cronyx Ltdn Synchronous PPP and CISCO HDLC (c) 1994
Linux port (c) 1998 Building Number Three Ltd & Jan "Yenya" Kasprzak.
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IgMP
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP: Hash tables configured (established 16384 bind 32768)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 448k freed
VFS: Mounted root (minix filesystem).
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz syste} bus speed for PIO mofes; override with idebus=xx
SIS5513: IDE controller on PCI bus 00 dev 15
SIS5513: chipset revision 208
SIS5513: not 100% native mde: will probe irqs later
SiS735
ide0: BM-DMA at 0xff00-0xff07, BIOS settings: hdaMA, hdbMA
ide1: BM-DMA at 0xff08-0xff0f, BIOS settings: hdcMA, hddMA
hda: MAXTOR 4K040H2, ATA DISK drive
hdb: SAMSUNG SV0644A, ATA DISK drive
hdc: CD-R/RW RW7120A, ATAPI CD/DVD-ROM drive
hdd: HL-DT-STDVD-ROM GDR8161B, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
blk: queue d0835e64, I/O limit 4095mb (mask 0xffffffff)
hda: 78198750 sectors (40038 MB) w/2000KiB Cache, CHS=77578/16/63, UDMA(100)
blk: queue d0835fa4, I/O limit 4095Mb (mask 0xffffffff)
hdb: 12504240 sectors (6402 MB) w/478KiB Cache, CHS=13232/15/63, UDMA(33)
Partition check:
hda: [PTBL] [4867/255/63] hda1 hda2 hda3
hdb: [PTBL] [778/255/63] hdb1
Journalled Block Device driver loaded
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Freeing unused kernel memory: 100k freed
Real Time Clock Driver v1.10e
Adding Swap: 1052248k swap-space (priority -1)
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
SiS router pirq escape (99)
SiS router pirq escape (99)
usb-ohci.c: USB OHCI at membase 0xd08fc000, IRQ 11
usb-ohci.c: usb-00:02.3, Silicon Integrated Systems [SiS] 7001 (#2)
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 3 ports detected
PCI: Found IRQ 11 for device 00:02.2
PCI: Sharing IRQ 11 with 00:0f.0
usb-ohci.c: USB OHCI at membase 0xd08fe000, IRQ 11
usb-ohci.c: usb-00:02.2, Silicon Integrated Systems [SiS] 7001
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 3 ports detected
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,3), internal journal
Linux video capture interface: v1.00
usb.c: registered new driver 'W996[87]CF USB driver'
LVM version 1.0.5+(22/07/2002) module loaded
loop: loaded (max 8 devices)
Creative EMU10K1 PCI Audio Driver, version 0.20, 23:03:19 Mar 21 2003
PCI: Found IRQ 11 for device 00:11.0
emu10k1: EMU10K1 rev 8 model 0x8064 found, IO at 0xd000-0xd01f, IRQ 11
ac97_codec: AC97 Audio codec, id: v8(SigmaTel STAC9708)
emu10k1: SBLive! 5.1 card detected
hamcore module init
ham: loading HaM Release 4.51 INT (kern:2.4.21-28872cl) - Aug 28 2003
PCI: Found IRQ 11 for device 00:0f.0
PCI: Sharing IRQ 11 with 00:02.2
ham: IRQ: 11, DSP-Base: 0xcfffb000 (phys) 0xd09ec000 (virt) (range: 4k), DSP-Port: 0xd400 (range: 256b)
Mallec is offline   Reply With Quote
Old 08-28-03, 11:30 AM   #18
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

An error message of interest is (EE) NVIDIA(0): Failed to allocate config DMA context, which typically indicates that the kernel and the NVIDIA kernel module were built with conflicting versions of the GNU C compiler. Did you get a warning about a CC mismatch when you built the kernel module?
zander is offline   Reply With Quote
Old 08-28-03, 11:58 AM   #19
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default My mistake...

Oups! I mispelled the agp kernel module... it is agpgart...
So you have the agp module, you have the nvidia module... then try this:
#modprobe agpgart
#modprobe nvidia
#startx

As usual, if it does not work, post your xfree log file here and also, yes it may be a gcc version mismatch issue. Your chipset is supported by the nvidia agp driver... that would mean that even if you don't load agpgart, it should work... anyway...
XoD is offline   Reply With Quote
Old 08-28-03, 12:04 PM   #20
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

The log file reports a fatal error before AGP initialization would normally occur, Mallec will need to concentrate on solving this problem before attempting to change the AGP configuration.
zander is offline   Reply With Quote

Old 08-28-03, 01:01 PM   #21
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default Ok...

You seems far more experienced than me on the subject. I let him to your care.
XoD is offline   Reply With Quote
Old 08-28-03, 04:02 PM   #22
Mallec
Registered User
 
Join Date: Aug 2003
Posts: 19
Default cc mismatch

If you're questioning if I received any warning when installing the nvidia driver the answer is no. So, what I must do now? Have it any solution or is better I search another distribution (I'm starting on thinking in this possibility)?
Mallec is offline   Reply With Quote
Old 08-29-03, 06:58 AM   #23
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default Install again.

Try to install again the driver on your distro... but this time post here the log file of the installer.
XoD is offline   Reply With Quote
Old 08-29-03, 08:40 AM   #24
Mallec
Registered User
 
Join Date: Aug 2003
Posts: 19
Default Nvidia log

Here's the content of the installer log file:

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Aug 28 09:51:04 2003

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel include path : /usr/src/linux/include
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /root/tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Using the kernel include path '/usr/src/linux/include' as specified by the
'--kernel-include-dir' commandline option.
-> Kernel include path: '/usr/src/linux/include'
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f nv.o os-agp.o os-interface.o os-registry.o nv-linux.o nv_compiler.h *
.d NVdriver nvidia.o
-> Building kernel module:
executing: 'cd ./usr/src/nv; make nvidia.o SYSINCLUDE=/usr/src/linux/include
'...
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > nv_compiler.h
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wp
arentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -
DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D_
_KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVE
L=4496 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -DREMAP_PA
GE_RANGE_4 -I. -I/usr/src/linux/include -Wno-cast-qual nv.c
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wp
arentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -
DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D_
_KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVE
L=4496 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -DREMAP_PA
GE_RANGE_4 -I. -I/usr/src/linux/include -Wno-cast-qual os-agp.c
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wp
arentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -
DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D_
_KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVE
L=4496 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -DREMAP_PA
GE_RANGE_4 -I. -I/usr/src/linux/include -Wno-cast-qual os-interface.c
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wp
arentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -
DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D_
_KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVE
L=4496 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -DREMAP_PA
GE_RANGE_4 -I. -I/usr/src/linux/include -Wno-cast-qual os-registry.c
ld -r -o nv-linux.o nv.o os-agp.o os-interface.o os-registry.o
ld -r -o nvidia.o nv-linux.o nv-kernel.o
-> done.
-> Kernel module compilation complete.
-> Installing classic TLS OpenGL libraries.
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86' (1.0-4496):
executing: './usr/src/nv/makedevices.sh'...
executing: '/sbin/ldconfig'...
executing: '/sbin/depmod -aq'...
-> done.
-> Driver file installation is complete.
-> Running post-install sanity check:
-> done.
-> Sanity check passed.
-> Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86
(version: 1.0-4496) is now complete. Please update your XF86Config file as
appropriate; see the file /usr/share/doc/NVIDIA_GLX-1.0/README for details.
Mallec is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 11:13 PM
Mandrake 9.0 driver installation Andy Mecham NVIDIA Linux 3 10-02-02 05:12 PM
Modules not found Sir Henry NVIDIA Linux 1 10-02-02 12:39 PM
no screens found + BusID ?? orion NVIDIA Linux 2 08-24-02 09:34 AM
Worked fine before, now getting "no screens found" HansBoldt NVIDIA Linux 3 08-22-02 07:20 AM

All times are GMT -5. The time now is 08:33 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.