Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-26-03, 11:08 AM   #1
rberry88
Registered User
 
Join Date: Aug 2003
Location: Arlington Heights, IL USA
Posts: 4
Default What haven't I tried? driver + Suse 8.2 help

Okay, I've read all the posts, searched here and at www.linuxquestions.org forums for the answer but cannot find it. I am following the instructions in the FAQ's in that forum (Newbie forum)and
the README (here) about installing the NVIDIA drivers. I get to the part where the nvidia installer runs and says something like it couldn't find the correct compiled headers and it would try to download
them from ftp.nvidia.com. Then another error message comes up saying it couldn't connect to ftp.nvidia.com because of DNS errors and to try again later. This has happened since yesterday. After this
it kicks me back out to text-mode.

Is there a step I'm missing?? I printed the instructions from the FAQ and all seems to go fine until this happens.

Next Try:

Okay it seems that if I follow what the FAQ but in runlevel 3 I no longer get the ftp error, however, whether I choose yes or no to dowload from ftp//download.nvidia.com it still gives me an error that
says it cannot compile a new header for the kernal that is currently running. I've gone into 'install new programs' and made sure I had

GCC
kernal source
Xfree86-devel
Xfree86-headers

all are loaded (check marks in the boxes).

Do I maybe need to make sure that the kernal that is listed in YAST2 for my graphic card is a certain one before I do this. And if so which one would I choose for a Nvidia Geforce FX 5600?? I see a selection for 5800 and possibly a generic for DDR and 256. The one that currently shows up is 0x312.

The exact error, if it helps, that I get from the nvidia installer is as follows:

--
Error: Unable to find the kernel header files for the currently running kernel. Please make sure you have installed the kerner header files for your kernel; on Red Hat Linux Systems, for example, be sure you have the 'kernal-source' rpm installed. If you know the correct kernel header files are installed, you may specify the kernel include path with '--kernel-include-path' command line option.
---

I have everything in the 'install software' section installed except for two items that say they are more multi-processor machines. Is there a way to find out if the correct kernel is in my system??

I took a different approach and attempted to install the driver using the run command instead of the nvidia installer (posted in the README of the driver) and this is the output:

-----

You Appear to be compiling the Nvidia kernel module with a compiler different from the one that was used to compile the running kernel. This may be perfectly fine, but there are cases where this can lead to unexpected behaviour & system crashes.

If you know what you are doing and want to override this check, you can do so by setting IGNORE__CC__MISMATCH.

In any other case set the CC environment variable to the name of the compiler that was used to compile the kernel.

-----

How would I go about doing the last item mentioned, setting the CC environment variable??

Should I give up or anyone have any ideas??

rberry88
rberry88 is offline   Reply With Quote
Old 08-26-03, 11:31 AM   #2
Thorsten Lange
Registered User
 
Join Date: Aug 2003
Location: Cologne, Germany
Posts: 6
Default

As for the last part of your post: this error message is completely "normal" for a SuSE 8.2. The Makefile gets a bit confused when it sees the version number SuSE's prerelease gcc reports.

Try "make IGNORE_CC_MISMATCH=1 install"
Thorsten Lange is offline   Reply With Quote
Old 08-26-03, 12:00 PM   #3
rberry88
Registered User
 
Join Date: Aug 2003
Location: Arlington Heights, IL USA
Posts: 4
Default

Sorry for the newbie banter but, do I type that in before I run the driver file or after I run it and I get the error about the CC mismatch??

rberry88
rberry88 is offline   Reply With Quote
Old 08-26-03, 12:09 PM   #4
Thorsten Lange
Registered User
 
Join Date: Aug 2003
Location: Cologne, Germany
Posts: 6
Default

Sorry for being a bit terse. I assumed that you were doing a completely manual installation (i.e. go to the module's source directory and type "make install").

If you use a different method, you might be better off setting an environment variable in your shell. If you use bash (most probably), type "export IGNORE_CC_MISMATCH; IGNORE_CC_MISMATCH=1"

Other shells may require different syntax (e.g. tcsh: "setenv IGNORE_CC_MISMATCH 1")

HTH
Thorsten Lange is offline   Reply With Quote
Old 08-26-03, 12:40 PM   #5
rberry88
Registered User
 
Join Date: Aug 2003
Location: Arlington Heights, IL USA
Posts: 4
Default

sh ./NVIDIA-Linux-x86-1.0-4496-pkg1.run --extract-only
cd NVIDIA-Linux-x86-1.0-4496-pkg1
make install


The above is what I do when I try to install and get the 'CC__Mismatch' error.

Do I type the Ignore__CC__mismatch command before I run the above??

rberry88
rberry88 is offline   Reply With Quote
Old 08-27-03, 05:25 AM   #6
Thorsten Lange
Registered User
 
Join Date: Aug 2003
Location: Cologne, Germany
Posts: 6
Default

Use the command "make IGNORE_CC_MISMATCH=1 install" instead of "make install"
Thorsten Lange is offline   Reply With Quote
Old 08-27-03, 11:12 AM   #7
rberry88
Registered User
 
Join Date: Aug 2003
Location: Arlington Heights, IL USA
Posts: 4
Default

I finally got it, after pulling my hair out for a while I figured out I had to change the make IGNORE_CC_MISMATCH=1 to read make IGNORE_CC_MISMATCH= yes . Thanks for the help and I'm on to my next project: getting my onboard nforce2 sound to work.

rberry88
rberry88 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 07:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
NVIDIA 3123 driver on SuSE 8.0 Ok , but slow to start X Gabolander NVIDIA Linux 3 09-27-02 08:41 AM
failing to initialize NV driver PsyShook NVIDIA Linux 10 09-19-02 01:41 PM
Trouble with SuSE 8 & NVIDIA latest driver bughill NVIDIA Linux 3 08-20-02 01:31 PM

All times are GMT -5. The time now is 08:30 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.