Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-26-03, 12:10 PM   #1
maineult
Registered User
 
Join Date: Aug 2003
Location: FRANCE
Posts: 9
Thumbs up XConfiguration of GeForce2 MX400 !!!

I've installed succesfully the fabulous '...4496.pkg2.run' file, but I "startx", I obtains following errors:

(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

If you know that, could you see attach file containing my "/var/log/XFree86.0.log","/etc/X11/XF86Config" files and my bios version.
Thanks to explain me what I must or can do to see at least one gui on my mkd9.1 !!!
Attached Files
File Type: txt bordel.txt (24.7 KB, 125 views)

Last edited by maineult; 08-27-03 at 02:01 PM.
maineult is offline   Reply With Quote
Old 08-27-03, 03:22 AM   #2
eliu
Registered User
 
eliu's Avatar
 
Join Date: Jul 2003
Posts: 34
Default

$ lsmod | grep nvidia
nvidia 1545984 10



Make sure your nvidia kernel module is loaded
eliu is offline   Reply With Quote
Old 08-27-03, 10:38 AM   #3
maineult
Registered User
 
Join Date: Aug 2003
Location: FRANCE
Posts: 9
Thumbs up and then ...

Thanks for your help eliu, but here I obtains when I typed "lsmod":

Module Size Used by Tainted: P
...
NVdriver 1667200 0
...

and when I typed "insmod nvidia":

Using /lib/modules/2.4.21-0.13mdk/kernel/drivers/video/nvidia.o
Warning: loading /lib/modules/2.4.21-0.13mdk/kernel/drivers/video/nvidia.o will taint the kernel: non-GPL license - NVIDIA
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.

How could I load successfully nvidia'driver ?
maineult is offline   Reply With Quote
Old 08-27-03, 10:55 AM   #4
Moled
cheese
 
Join Date: Aug 2003
Posts: 137
Default

that means it loaded ok, but just doesnt have a gpl license, just ignore that warning




and isnt nvdriver a very old version of the nvidia driver? :/
Moled is offline   Reply With Quote
Old 08-27-03, 01:47 PM   #5
maineult
Registered User
 
Join Date: Aug 2003
Location: FRANCE
Posts: 9
Default always any gui

But my principal problem isn't resolved: I don't have any gui when I start mdk9.1 or type "startx" despite '4496.pkg2.run' was correctly installed.

What differences exist between geForce2 DDR (generic) and geForce2 MX400 ?
maineult is offline   Reply With Quote
Old 08-27-03, 08:07 PM   #6
eliu
Registered User
 
eliu's Avatar
 
Join Date: Jul 2003
Posts: 34
Default

Do your nvidia device files exist ?

# ls -l /dev/nvidia*
crw------- 1 eliu root 195, 0 Jan 1 1970 /dev/nvidia0
crw------- 1 eliu root 195, 255 Jan 1 1970 /dev/nvidiac

I also have a GF2 MX400.
eliu is offline   Reply With Quote
Old 08-28-03, 02:26 AM   #7
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default agpart

Try this:
# modprobe agpart
# modprobe nvidia

Check that you have both module loaded with the following command:
#lsmod
You should see something agpart and nvidia
Check that the /proc/driver/nvidia files and directories ok.
Then:
# startx

Don't forget to enable the "assign IRQ to VGA" option in your BIOS.

If it still does not work, post here the log file of the nvidia driver installer and the one from xfree.
XoD is offline   Reply With Quote
Old 08-28-03, 11:18 AM   #8
maineult
Registered User
 
Join Date: Aug 2003
Location: FRANCE
Posts: 9
Thumbs up ... advancing ...

Thanks for your help Eliu and XoD, I'm here:

# ls /dev/nv*:
crw-rw-rw- 1 root root 195, 0 jan 1 1970 /dev/nvidia0
crw-rw-rw- 1 root root 195, 255 jan 1 1970 /dev/nvidiactl

# modprobe agpart:
modprobe: Can't locate module 2
Warning: loading /lib/modules/2.4.21-0.13mdk/kernel/drivers/video/nvidia.o will taint the kernel: non-GPL license - NVIDIA
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
/lib/modules/2.4.21-0.13mdk/kernel/drivers/video/nvidia.o: init_module: Device or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
modprobe: insmod /lib/modules/2.4.21-0.13mdk/kernel/drivers/video/nvidia.o failed

# modprobe nvidia:
modprobe: Can't locate module 2

# lsmod | grep NV*
...
NVdriver 1667200 0
...

# more /proc/driver/nvidia/version:
version
NVRM version: NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4321 Wed Mar 5 19:13:04 PST 2003
GCC version: gcc version 3.2.2 (Mandrake Linux 9.1 3.2.2-3mdk)

# more /proc/driver/nvidia/*
::::::::::::::
/proc/driver/nvidia/agp/card
::::::::::::::
Fast Writes: Supported
SBA: Not Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000017:0x00000000
::::::::::::::
/proc/driver/nvidia/agp/host-bridge
::::::::::::::
Host Bridge: Via Apollo Pro KT133
Fast Writes: Not Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000207:0x00000004
::::::::::::::
/proc/driver/nvidia/agp/status
::::::::::::::
Status: Disabled

# more /var/log/syslog | grep nvidia | grep Aug | grep 28:
...
Aug 28 17:51:11 localhost kernel: 0: nvidia: Can't find an IRQ for your NVIDIA card!
Aug 28 17:51:11 localhost kernel: 0: nvidia: Please check your BIOS settings.
Aug 28 17:51:11 localhost kernel: 0: nvidia: [Plug & Play OS ] should be set to NO
Aug 28 17:51:11 localhost kernel: 0: nvidia: [Assign IRQ to VGA] should be set to YES
Aug 28 17:51:11 localhost kernel: 0: nvidia: loading NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4496 Wed Jul 16 19:03:09 PDT 2003

...

But my bios don't have these options !!!!!

What version's bios are correct to configure these ?
maineult is offline   Reply With Quote

Old 08-28-03, 12:24 PM   #9
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default Come on...

Look better... your BIOS should have those options: PCI OS to NO and IRQ to VGA to YES...
XoD is offline   Reply With Quote
Old 08-28-03, 01:20 PM   #10
maineult
Registered User
 
Join Date: Aug 2003
Location: FRANCE
Posts: 9
Thumbs down ... bios is not my friend ...

-> syslog is really explicit, but my bios version is 4.0.6 with revision 2.00 09/19/00 and I don't have any options with PnP or IRQ...
If you know this bios, what can I do, else what are bios version with these options "Plug and Play [YES/NO]" and "IRQ [VGA]" ?
... see you
maineult is offline   Reply With Quote
Old 08-29-03, 05:44 AM   #11
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default Your motherboard

What is the mother board you have? I wonder who is the constructor not making those options available in its bioses!

And try these:
#depmod -a
#rmmod -r NVdriver
#modprobe agpgart
#modprobe nvidia
#startx
XoD is offline   Reply With Quote
Old 09-01-03, 11:12 AM   #12
maineult
Registered User
 
Join Date: Aug 2003
Location: FRANCE
Posts: 9
Default ...

Hello XoD, all your command line was successfully executed, except "startx" !!!
See my syslog, XFree86.0.log file in attach file !
See you ...
Attached Files
File Type: txt bordel_.txt (28.3 KB, 105 views)
maineult is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:29 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.