Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-17-11, 07:44 AM   #1
Necromant
Registered User
 
Join Date: Dec 2011
Posts: 5
Default GT555M/2GB (10de:1247) question

There have been quite a lot of threads regarding this chip, but none of them show if we're are going to see support for these pci id in the official driver package or not any time soon. I found no commets from nvidia staff regarding the issue. And I haven't found an option to override the id check (well, I haven't tried disassembly, yet, but I will).
I understand that this is a custom modification thrown up by some laptop vendors (asus in my case), that got greedy to pop proper 3 GiBs, but as far as only the memory size is changed and the ids, adding support should be trivial for nvidia developers. (I'm not asking for full optimus crap support, just a way to start X & glx).
In my case, to make the long story short, is there any use of waiting for the features to be added, or better to get the laptop back where I got it and get myseft an amd/ati instead?

Thanks in advance.

Last edited by Necromant; 12-17-11 at 07:45 AM. Reason: fixed typo
Necromant is offline   Reply With Quote
Old 12-18-11, 01:03 AM   #2
Plagman
NVIDIA Corporation
 
Plagman's Avatar
 
Join Date: Sep 2007
Posts: 254
Default Re: GT555M/2GB (10de:1247) question

Can you provide an nvidia-bug-report.log and the model number of the notebook computer you're using?
Plagman is offline   Reply With Quote
Old 12-18-11, 05:14 AM   #3
Necromant
Registered User
 
Join Date: Dec 2011
Posts: 5
Default Re: GT555M/2GB (10de:1247) question

Thanks for the quick reply. bug report attached.
Nouveau is blacklisted and not loaded at the time of running nvidia-bug-report.sh
Laptop is ASUS N75SF, with NVIDIA GT555M, 2GiB. Core i7 variant.
If you need I can povide whatever testing you need on the hardware.
P.S. An option for the linux kernel module to override detected PCI ids would be awesome. I looked at the sources of the kernel module, but it only filters based on vendor and it looks like further checking is done in the blob.
Attached Files
File Type: gz nvidia-bug-report.log.gz (25.0 KB, 52 views)
Necromant is offline   Reply With Quote
Old 12-19-11, 05:49 PM   #4
Plagman
NVIDIA Corporation
 
Plagman's Avatar
 
Join Date: Sep 2007
Posts: 254
Default Re: GT555M/2GB (10de:1247) question

This particular 555M is going to be marked as supported in the README of the next release series.
Plagman is offline   Reply With Quote
Old 12-20-11, 06:21 AM   #5
Necromant
Registered User
 
Join Date: Dec 2011
Posts: 5
Default Re: GT555M/2GB (10de:1247) question

Quote:
Originally Posted by Plagman View Post
This particular 555M is going to be marked as supported in the README of the next release series.
Thanks a lot, looking forward to the next release.
Necromant is offline   Reply With Quote
Old 12-20-11, 05:50 PM   #6
Plagman
NVIDIA Corporation
 
Plagman's Avatar
 
Join Date: Sep 2007
Posts: 254
Default Re: GT555M/2GB (10de:1247) question

By the way, having the PCI ID not marked as supported in the README won't prevent you from using the driver. I took a closer look at your logs and it doesn't look like you specified a BusID for the NVIDIA device in your xorg.conf. If you don't specify one, the X Server will try to drive the first VGA device by default, which here is the Intel GPU in your notebook. In the Device section of the /etc/X11/xorg.conf.d/20-nvidia.conf file, please try adding a BusID line pointing at your NVIDIA VGA device (as reported by lspci), eg.:

BusID "PCI:1:0:0"

That should allow you to start X correctly with the NVIDIA driver with 290.10, so you don't have to wait for a release. Make sure the NVIDIA device is selected in the system BIOS, or it might not be able to drive your display.
Plagman is offline   Reply With Quote
Old 12-21-11, 01:13 AM   #7
Necromant
Registered User
 
Join Date: Dec 2011
Posts: 5
Default Re: GT555M/2GB (10de:1247) question

Thanks a lot for your help. I got it fully running with bumblebee. The BusId did the trick. ( I tried to put it BusId before, but forgot to put the PCI: prefix - just the raw output from lspci )
Necromant is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:41 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.