Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-06-12, 02:11 AM   #1
Pie-rate
Registered User
 
Join Date: Mar 2007
Posts: 14
Default VDPAU and KDE 4.8 compositing = slow

Here's the setup:
GTX 560M
KDE 4.8
nvidia drivers 280 and 290, 295 not tested.

Playing a video in smplayer in a window with kwin compositing on causes the *entire desktop* to become sluggish to the point of unusability. That include the mouse pointer. Pretty big regression from just juddering and tearing video.
Pie-rate is offline   Reply With Quote
Old 02-06-12, 02:13 AM   #2
Pie-rate
Registered User
 
Join Date: Mar 2007
Posts: 14
Default Re: VDPAU and KDE 4.8 compositing = slow

.
Attached Files
File Type: gz nvidia-bug-report.log.gz (49.7 KB, 81 views)
Pie-rate is offline   Reply With Quote
Old 02-06-12, 02:43 AM   #3
leigh123linux
Registered User
 
leigh123linux's Avatar
 
Join Date: Feb 2008
Posts: 163
Default Re: VDPAU and KDE 4.8 compositing = slow

Quote:
Originally Posted by Pie-rate View Post
Here's the setup:
GTX 560M
KDE 4.8
nvidia drivers 280 and 290, 295 not tested.

Playing a video in smplayer in a window with kwin compositing on causes the *entire desktop* to become sluggish to the point of unusability. That include the mouse pointer. Pretty big regression from just juddering and tearing video.
Have you reported a bug against kde 4.8?
leigh123linux is offline   Reply With Quote
Old 02-06-12, 11:59 AM   #4
MadCatX
Registered User
 
Join Date: Sep 2010
Posts: 29
Default Re: VDPAU and KDE 4.8 compositing = slow

Do you experience somthing like this? 295.17 fixed the problem for me.
MadCatX is offline   Reply With Quote
Old 02-10-12, 12:22 PM   #5
RealNC
Registered User
 
Join Date: Feb 2012
Posts: 32
Default Re: VDPAU and KDE 4.8 compositing = slow

I have the exact same problem! The whole GUI stutters (like it's running with 30FPS), including the mouse. It only happens when playing a video while having the KDE desktop effects enabled. If I play a video and disable desktop effects while the video is still playing, then the problem disappears. It reappears again if I bring back desktop effects while the video is still playing.

The problem is not affected at all by PowerMizer. No matter if I force maximum clocks or not, the problem keeps occurring.

I have a GTX 560 Ti. It happens with both 290.10 as well as 295.17. I'm using Xv instead of VDPAU now because of this bug.
Attached Files
File Type: gz nvidia-bug-report.log.gz (59.2 KB, 84 views)
RealNC is offline   Reply With Quote
Old 02-13-12, 09:07 AM   #6
RealNC
Registered User
 
Join Date: Feb 2012
Posts: 32
Default Re: VDPAU and KDE 4.8 compositing = slow

I installed the 295.20 driver and it has the same problem; VDPAU with desktop compositing active makes everything stutter like crazy.
RealNC is offline   Reply With Quote
Old 02-13-12, 11:56 AM   #7
CME
Registered User
 
Join Date: Dec 2007
Posts: 20
Default Re: VDPAU and KDE 4.8 compositing = slow

Quote:
Originally Posted by man mplayer
Using the VDPAU frame queueing functionality controlled by the queuetime options makes MPlayer's frame flip timing less sensitive to system CPU load and allows MPlayer to start de‐
coding the next frame(s) slightly earlier which can reduce jitter caused by individual slow-to-decode frames. However the NVIDIA graphics drivers can make other window behavior
such as window moves choppy if VDPAU is using the blit queue (mainly happens if you have the composite extension enabled) and this feature is active. If this happens on your system
and it bothers you then you can set the queuetime value to 0 to disable this feature. The settings to use in windowed and fullscreen mode are separate because there should be less
reason to disable this for fullscreen mode (as the driver issue shouldn't affect the video itself).
so, can you try mplayer2 -vo vdpau:queuetime_windowed=0:queuetime_fs=0:fps=-1?
CME is offline   Reply With Quote
Old 02-13-12, 12:13 PM   #8
RealNC
Registered User
 
Join Date: Feb 2012
Posts: 32
Default Re: VDPAU and KDE 4.8 compositing = slow

That helps. Well, with mplayer at least. When you switch to fullscreen though and then back, the whole screen goes green and you have to blindly kill applications.

How do I use different settings for fullscreen vs windowed mode?

Furthermore, mplayer might be configurable, but Adobe Flash is not. When using VDPAU with Flash, the same problem appears. In this day and age, compositing is the default with the majority of Linux desktops. VDPAU should be able to work with it.
RealNC is offline   Reply With Quote

Old 02-13-12, 12:43 PM   #9
MadCatX
Registered User
 
Join Date: Sep 2010
Posts: 29
Default Re: VDPAU and KDE 4.8 compositing = slow

You might be experiencing a different issue (IIRC mine wasn't affected by compositing), but have you tried these?

- Use VDPAU in mplayer, but use "-vc ffh264" instead of "-vc ffh246vdpau"?
- Start the playback and while a video is playing, open the nvidia-settings and toggle the PowerMizer to full steam and back. Changing the power mode before didn't work for me either.

EDIT: As for the mplayer2 queuetime issue, I believe it's a problem isolated to KWin + mplayer2 + VDPAU combo as the mplayer2 author said he couldn't reproduce this problem with Compiz.
MadCatX is offline   Reply With Quote
Old 02-14-12, 01:11 AM   #10
Pie-rate
Registered User
 
Join Date: Mar 2007
Posts: 14
Default Re: VDPAU and KDE 4.8 compositing = slow

Quote:
Originally Posted by CME View Post
so, can you try mplayer2 -vo vdpau:queuetime_windowed=0:queuetime_fs=0:fps=-1?
So much better.
Pie-rate is offline   Reply With Quote
Old 02-14-12, 04:06 AM   #11
RealNC
Registered User
 
Join Date: Feb 2012
Posts: 32
Default Re: VDPAU and KDE 4.8 compositing = slow

Quote:
Originally Posted by Pie-rate View Post
So much better.
Fullscreen and back works? Not here. Everything turns green and/or the desktop freezes.
RealNC is offline   Reply With Quote
Old 02-14-12, 04:35 AM   #12
Pie-rate
Registered User
 
Join Date: Mar 2007
Posts: 14
Default Re: VDPAU and KDE 4.8 compositing = slow

Quote:
Originally Posted by RealNC View Post
Fullscreen and back works? Not here. Everything turns green and/or the desktop freezes.
Yes, using smplayer with "user defined" selected in preferences->general->video->output driver, and "vdpau:queuetime_windowed=0:queuetime_fs=0:fps =-1" typed in the box.
Kubuntu 11.10, kde 4.8, nvidia 295.17, mplayer2 installed.
Pie-rate is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:18 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.