Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-19-12, 03:24 PM   #1
Gigadoc 2
Registered User
 
Join Date: Sep 2011
Posts: 8
Default 2D-Performance on KDE with GTX550

Hi,

it's me again. I solved the vsync-problem by getting rid of my dualhead setup, and replacing it with one big screen. But the performance problem is still there. At the moment, the workaround to keep my desktop running smoothly, is to set maximum performance in powermizer, and periodically clear the pixmap cache with
Code:
nvidia-settings -a PixmapCache=0
nvidia-settings -a PixmapCache=1
I also looked into some posts here, and got the impression that 2D-Performance is very bad with Nvidia-Drivers. Therefore I tried out the three different rendering modes of QT: XRender, Raster and OpenGL.

OpenGL did not work at all, it was very slow, with missing elements of the rendered window. Trying to render the whole desktop (plasma) with openGL did not work.

Raster is purely CPU-based, and since I got a decent CPU, it has the best allround performance for me without forcing the Graphics Card to maximum performance, since it is not affected by the powermizer setting. But Raster on a big screen with lots of open windows uses a lot of RAM; and when resizing Windows, or rolling out a yakuake terminal, its very choppy.

XRender (the default rendering mechanism for Qt) is very fast after starting X11. But after some time using it, it starts to get choppy, desktop effects enabled or not. Clearing the PixmapCache did help a bit, but it doesnt take long for the choppiness to reappear. If I turn off maximum performance in powermizer, and the level drops to 1 (about 400Mhz on the GT550), it only takes a few minutes using XRender, and the performance is worse than Raster.

Now to my questions: Is this normal? How is your performance with XRender, and do you know any tricks to get 2D-Performance working a bit better?

The strange thing about this is, that with my previous graphics card (GT220), the desktop seemed to be rendered much smoother and faster, although I was also running KDE4 at that time. Also, shouldnt power level 1 be enough to render a desktop?
Gigadoc 2 is offline   Reply With Quote
Old 01-19-12, 06:52 PM   #2
Plagman
NVIDIA Corporation
 
Plagman's Avatar
 
Join Date: Sep 2007
Posts: 254
Default Re: 2D-Performance on KDE with GTX550

Does VT-switching back and forth clear all the choppiness symptoms you get after a while with XRender?
Plagman is offline   Reply With Quote
Old 01-20-12, 05:45 AM   #3
Gigadoc 2
Registered User
 
Join Date: Sep 2011
Posts: 8
Default Re: 2D-Performance on KDE with GTX550

Not fully, but it seems to have a similar effect like turning the pixmap cache on and off, it helps a bit.
Might be wishful thinking, but I'm pretty sure it actually has an effect.
Gigadoc 2 is offline   Reply With Quote
Old 01-22-12, 08:35 AM   #4
zeroo
Registered User
 
Join Date: Jul 2010
Posts: 7
Default Re: 2D-Performance on KDE with GTX550

I have the same problem with gtx460. As far as I remember it started in KDE 4.6.0 and it is still present in 4.7.4. In earlier versions it was ok.

If I have more than one opened window and using OpenGL, the dragging, minimizing, maximizing any of these windows gets choppy. On top of that the XRender adds tearing, and if I disable the desktop effects, the tearing and the choppiness is still present, but there are also glitches on windows.

I'm forcing the performance level 1 (405/324/810Mhz) because there is no difference between level 1 and 3. And the level 0 (50/135/101MHz) make the things even worse.
zeroo is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:20 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.