Go Back   nV News Forums > Graphics Card Forums > Other Desktop Graphics Cards

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-31-12, 01:27 PM   #1
Capt. Picard
Registered User
 
Capt. Picard's Avatar
 
Join Date: Oct 2005
Location: South Africa
Posts: 6,386
Default ATI driver problem - please help.

Before anyone states the obvious that this is an Nividia forum, let me just say that I value the intelligence, know-how and experience enough to lay this slightly inapplicable problem to you fine people.

A colleague has a Fujitsu Siemens Amilo Li 1718 laptop that came out with Vista. The integrated graphics card is an Ati Radeon Xpress 200M.

I installed windows 7 on it and as is with most hardware, Windows 7 is not supported.

I've installed the latest legacy drivers - doesn't work.
Fujitsu mentions on their site that you can try and install the normal Vista catalyst drivers for legacy devices but only version 9.3 and earlier.

I have up till now installed version 9.2 Vista; 9.3 Vista; and the latest 12.1 Vista/Win7 as well as the 10.2 Vista Legacy driver. Nothing works. In the Device manager just Windows' generic driver is used.

What the hell am I doing wrong?
__________________
If beer is not the answer, you're asking the wrong question.
Capt. Picard is offline   Reply With Quote
Old 01-31-12, 01:37 PM   #2
Roadhog
Resident Alien
 
Join Date: Jan 2005
Posts: 6,776
Default Re: ATI driver problem - please help.

you try this?

http://support.amd.com/us/gpudownloa...v=10.2&ostype=
Roadhog is offline   Reply With Quote
Old 01-31-12, 01:39 PM   #3
Capt. Picard
Registered User
 
Capt. Picard's Avatar
 
Join Date: Oct 2005
Location: South Africa
Posts: 6,386
Default Re: ATI driver problem - please help.

Quote:
Originally Posted by Roadhog View Post
It was the first thing i downloaded and installed on a freshly formatted and installed win7 system.
__________________
If beer is not the answer, you're asking the wrong question.
Capt. Picard is offline   Reply With Quote
Old 01-31-12, 01:47 PM   #4
Roadhog
Resident Alien
 
Join Date: Jan 2005
Posts: 6,776
Default Re: ATI driver problem - please help.

you might just be SOL. The card isn't support by windows 7 drivers.
Roadhog is offline   Reply With Quote
Old 01-31-12, 01:50 PM   #5
Capt. Picard
Registered User
 
Capt. Picard's Avatar
 
Join Date: Oct 2005
Location: South Africa
Posts: 6,386
Default Re: ATI driver problem - please help.

Quote:
Originally Posted by Roadhog View Post
you might just be SOL. The card isn't support by windows 7 drivers.
Damn.
__________________
If beer is not the answer, you're asking the wrong question.
Capt. Picard is offline   Reply With Quote
Old 01-31-12, 01:51 PM   #6
Roadhog
Resident Alien
 
Join Date: Jan 2005
Posts: 6,776
Default Re: ATI driver problem - please help.

Quote:
Originally Posted by Capt. Picard View Post
Damn.
Use the google machine. Maybe you can come up with something.
Roadhog is offline   Reply With Quote
Old 01-31-12, 01:55 PM   #7
Capt. Picard
Registered User
 
Capt. Picard's Avatar
 
Join Date: Oct 2005
Location: South Africa
Posts: 6,386
Default Re: ATI driver problem - please help.

Quote:
Originally Posted by Roadhog View Post
Use the google machine. Maybe you can come up with something.
I have been at it for hours today. But the most I find is google ads in forums, ****ty incomplete answers, driver updaters and detectives that require a $30 registration fee and suggestions that I should try the hardware vendor
__________________
If beer is not the answer, you're asking the wrong question.
Capt. Picard is offline   Reply With Quote
Old 02-01-12, 10:11 AM   #8
dukenukemz
duKe_+
 
Join Date: Sep 2010
Location: Alberta, Canada
Posts: 38
Send a message via MSN to dukenukemz
Default Re: ATI driver problem - please help.

Did you try using custom laptopvideo2go drivers?

http://forums.laptopvideo2go.com/top...catalyst-1112/

That topic might work to download that driver there. other than that id say continue googling or re install XP on that machine.
__________________
CPU - I7 2600K 4.5 GHZ
RAM - 8 GB DDR3 1600mhz
GPU - GTX 570 Classified
dukenukemz is offline   Reply With Quote

Old 02-01-12, 11:27 AM   #9
ViN86
 
Join Date: Mar 2004
Posts: 15,486
Default Re: ATI driver problem - please help.

Moved to correct forum.
ViN86 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:53 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.