Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-18-12, 02:14 PM   #25
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3

Quote:
Originally Posted by uau View Post
Start the program first, then attach gdb to the running process. Looks like the the crash happens when the process forks, probably in a pthread_atfork() handler registered by the nvidia driver.
Yeah that's what I did ... maybe it is some kind of race that just didn't trigger due to gdb slowing it down.

Anyway a crash at fork looks like it is the same bug as reported in http://www.nvnews.net/vbulletin/showthread.php?t=174244
Dragoran is offline   Reply With Quote
Old 02-20-12, 07:03 AM   #26
enigmatichus
Registered User
 
Join Date: Feb 2012
Posts: 4
Default Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3

Clearing recently-used.xbel helps until the file is populated with the first recent voice. After that, problem returns for me.
enigmatichus is offline   Reply With Quote
Old 02-20-12, 09:07 AM   #27
Kaurin
Registered User
 
Join Date: Feb 2012
Posts: 2
Default Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3

+1
Kaurin is offline   Reply With Quote
Old 02-20-12, 05:10 PM   #28
tetromino
Registered User
 
Join Date: Jul 2011
Posts: 6
Default Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3

Same here on Gentoo (see Gentoo bug #405087).

Full backtrace attached. The crash occurs when gnome-shell forks to execute evince-thumbnailer in order to generate a thumbnail of a recently opened .pdf file.

It appears that this is yet another instance of buggy forking/threading detection in the nvidia driver.
Attached Files
File Type: txt backtrace.txt (62.7 KB, 95 views)
File Type: gz nvidia-bug-report.log.gz (140.5 KB, 43 views)
tetromino is offline   Reply With Quote
Old 02-22-12, 01:21 AM   #29
dront78
Registered User
 
dront78's Avatar
 
Join Date: Nov 2007
Location: Moscow
Posts: 11
Default Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3

same for me
NVIDIA Corporation GT216 [GeForce GT 330M] (rev a2)
ArchLinux x86_64 with latest updates
dront78 is offline   Reply With Quote
Old 02-22-12, 03:12 AM   #30
bengershon
Registered User
 
Join Date: Nov 2004
Posts: 15
Default Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3

Same problem here. I have now reverted to my previous version (290.10). Much more stable!
bengershon is offline   Reply With Quote
Old 02-25-12, 09:11 AM   #31
enigmatichus
Registered User
 
Join Date: Feb 2012
Posts: 4
Default Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3

Maybe it does not help anyone, but on Archlinux forum a user suggested to use the immutable bit on recently-used.xbel after clearing it up with
Code:
# chattr +i ~/.local/share/recently-used.xbel
It did the job for me while I wait for a permanent bug fix.
enigmatichus is offline   Reply With Quote
Old 02-27-12, 06:15 PM   #32
Tsu Jan
Registered User
 
Join Date: Oct 2010
Posts: 27
Default Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3

For me, with Debian wheezy/sid with the latest wheezy updates, the shell crashed only when I searched for a word srarting with "r" or "re". Additionally, Evolution crashed on receiving mails. Downgrading to nVidia v290.10-1 fixed both issues.
Tsu Jan is offline   Reply With Quote

Old 02-27-12, 06:48 PM   #33
Tsu Jan
Registered User
 
Join Date: Oct 2010
Posts: 27
Default Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3

BTW, making '~/.local/share/recently-used.xbel' empty and immutable just fixed the search issue: Evolution still crashed on receiving mails until I downgraded nvidia.
Tsu Jan is offline   Reply With Quote
Old 03-05-12, 01:15 PM   #34
Christian_Frank
Registered User
 
Join Date: Dec 2005
Posts: 85
Default Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3

+1
Christian_Frank is offline   Reply With Quote
Old 03-06-12, 07:19 AM   #35
Tsu Jan
Registered User
 
Join Date: Oct 2010
Posts: 27
Default Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3

For some users, the problem is deeper than a crash in Shell or Evolution. See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=661253
Tsu Jan is offline   Reply With Quote
Old 03-06-12, 02:22 PM   #36
brblueser
Registered User
 
Join Date: Dec 2002
Location: Rio de Janeiro, Brazil
Posts: 88
Default Re: [Regression] 295.17 / 295.20 segfault when searching in gnome3

Same problem (gnome-shell crashing on app search using "super" key), F16 x86_64, 9800 GT.
brblueser is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:09 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.