Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-03-03, 06:48 AM   #1
pilpi
Registered User
 
Join Date: Sep 2003
Location: Tampere, Finland
Posts: 4
Send a message via ICQ to pilpi
Question TwinView trouble

A couple of screenshots:
http://milk.ton.tut.fi/~pilpi/nvidia/

I've got the 4496 of the nVidia driver installed on my SuSE 9 box. Tux Racer runs fine , but when I try to set up TwinView to my TV (with SaX2 - I tried earlier to go to XF86Config myself but that was a disaster), I get the error message shown in the second screen shot:

(WW) NVIDIA: No matching Device section for instance (BusID PCI:1:0:0) found
(EE)Screen 0 deleted because of no matching config section.

I never was quite sure about what to select for BusID. If I select ScreenID 0 I don't get an error message nor an image on my TV. On W2K TwinView works fine.

Any help or attempt to help will be appreciated =)
pilpi is offline   Reply With Quote
Old 09-03-03, 10:20 AM   #2
pilpi
Registered User
 
Join Date: Sep 2003
Location: Tampere, Finland
Posts: 4
Send a message via ICQ to pilpi
Default Twinview trouble II

Some of the information requested in the posting instructions:

According to SaX2, the graphics card is NVidia GeForce4 MX 440.

Undex /proc/driver, there is no /nvidia/cards/0 while X is running

Processor: AMD 1600+, 512 MD RAM

attached: XF86Config
Attached Files
File Type: txt xf86config.txt (6.7 KB, 140 views)
pilpi is offline   Reply With Quote
Old 09-03-03, 10:35 AM   #3
eliu
Registered User
 
eliu's Avatar
 
Join Date: Jul 2003
Posts: 34
Default

Modify /etc/X11/XF86Config-4, you must substitute 1024x768 with 1280x1024 if your resolution is 1280x1024.

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce2 DDR (generic)"
Driver "nvidia"
Option "DPMS"
Option "TwinView" "True"
Option "TwinViewOrientation" "Clone"
Option "TVStandard" "NTSC-M"
Option "MetaModes" "1024x768,640x480; 640x480,640x480"
EndSection

Note that if you use (Mandrake 9.1 XFree4.3). You cannot switch to 640x480 by pressing control-alt-+.
It's a bug in XFree86 4.3
eliu is offline   Reply With Quote
Old 09-03-03, 11:00 AM   #4
pilpi
Registered User
 
Join Date: Sep 2003
Location: Tampere, Finland
Posts: 4
Send a message via ICQ to pilpi
Default

Thanks (=.

So this is your configuration? It's muchly the same as mine, so do you have an idea about what's wrong with mine? Is the generic driver better somehow? I wouldn't like to risk hand-editing XF86Config unless sure.

BTW, what is that DPMS option, didn't see it in the nvidia documentation.
pilpi is offline   Reply With Quote
Old 09-03-03, 08:49 PM   #5
eliu
Registered User
 
eliu's Avatar
 
Join Date: Jul 2003
Posts: 34
Default

problem 1: missing quote
Option "ConnectedMonitor" "CRT

problem 2: tvstandard is not defined
Option "TVStandard" "NTSC-M"
eliu is offline   Reply With Quote
Old 09-04-03, 04:05 AM   #6
pilpi
Registered User
 
Join Date: Sep 2003
Location: Tampere, Finland
Posts: 4
Send a message via ICQ to pilpi
Default

Thanks! (=

It works.

I guess I'm going to let that SaX2 just lie in its own stools.
pilpi is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Twinview? ghorsepower NVIDIA Linux 2 10-11-02 12:46 PM
XF86Config for a Quadro4 without TwinView? Twirlip NVIDIA Linux 1 10-09-02 10:36 AM
Suse Linux 8.0 - Geforce 4 TwinView TA00 NVIDIA Linux 8 08-30-02 03:24 AM
Twinview with TV-out karlaugust NVIDIA Linux 10 08-28-02 04:20 PM
How do I configure TwinView on Dell Inspiron rutgerclaes NVIDIA Linux 6 08-01-02 03:20 AM

All times are GMT -5. The time now is 05:45 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.