Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-04-03, 01:53 AM   #1
Pagan
GeForce4 (Linux 2.4.22
 
Pagan's Avatar
 
Join Date: Apr 2003
Location: North America
Posts: 8
Default 2.4.21 / 2.4.22 Nvidia 4496 corrupted display after X logout.

I"m running SuSE Linux with a custom 2.4.21 / 2.4.22 kernel build. I've tried the installer and compiling drivers myself. I get the same result all ways...

After I end my x session and return to text mode, my screen is corrupted and I can't see anything.
Only solution is have is to blindly type:
shutdown -r now
and let it reboot.

I'm running a GeForce4 440 AGP
IRQ:16
Video BIOS: 04.17.00.45.00
Kernels 2.4.21 & 2.4.22
GigaByte 845PE667Ultra2 mobo
512 MB DDR ram
SuSE Linux 8.1 pro.

THe same drivers run fine on wife's geforce2 and my son's 5200.

Any suggestions?
__________________
Pagan

Last edited by Pagan; 09-04-03 at 02:09 AM.
Pagan is offline   Reply With Quote
Old 09-04-03, 11:43 PM   #2
frycarson
Registered User
 
Join Date: Sep 2003
Posts: 1
Default

I have the same problem with the corrupted display

Pentium Celeron
Geforce 4 MX440 128 ram AGP

anyone have suggestions other then an older driver?

Frycarson

UPDATE:

the 1.0-4363 driver in Nvidia's archive won't cause corruption. It might just be an issue for now.

Last edited by frycarson; 09-05-03 at 12:08 AM.
frycarson is offline   Reply With Quote
Old 09-06-03, 03:50 AM   #3
Pagan
GeForce4 (Linux 2.4.22
 
Pagan's Avatar
 
Join Date: Apr 2003
Location: North America
Posts: 8
Default More Info...

I just upgraded to SuSE Linux 8.2 Pro and the problem remains...

Wonder why it's fine in the previous version?

Ran the installer upon installation finalization, and got the same results...
3-D is fast in X, but upon logout it's corrupted...
I guess If I ran at graphical login it's fine, but what do ya do the first time ya need a text console?

My son's running the same MoBo as I am, with a 5200 card and it's fine.

Wife's PC is running a GigaByte socket 370 series with a Geforce2 FX with newest drivers, hers is fine too...
__________________
Pagan
Pagan is offline   Reply With Quote
Old 09-10-03, 06:57 PM   #4
another_mike
Registered User
 
Join Date: Sep 2003
Posts: 2
Default

Hi folks.

The same with me!

1.0-4496:
No errors during installation.
3D acceleration works fine, but no terminal is visible.

1.0-4363:
Everything works fine.

A little system information:
Suse 8.2 (FTP installation)
standard kernel 2.4.20, updated via Yast Online Update

AOpen BX-Board
Celeron 1000 FCPGA2 running on modified Socket370-Adapter
ASUS V3800 Deluxe (Riva TNT2 AGP Board, 32MB)

I can live with the 'old' driver, but it would be nice to benefit of the latest features/fixes.


I hope, anybody will reply.

Thanks in advance,
mike
another_mike is offline   Reply With Quote
Old 09-10-03, 07:18 PM   #5
another_mike
Registered User
 
Join Date: Sep 2003
Posts: 2
Default

Hi, again.

Maybe, I found the solution for this strange behaviour:

Quote:
After trying to get the twinview going i have the exact same "garbled screen after switching from x to terminal" problem!!

Ive found that this only happens with my tv hooked to the card. pulling the cable from the tv without any changes to the config stops this odd behavior....
hmmm these colours really look like a 1982 vga game

but.... would be great to fix this problem, because i like the 2d speed of the new driver set so much!


best,
lars
I haven't tried to reinstall the latest driver, but: My TV is hooked to my graphics card....

mike
another_mike is offline   Reply With Quote
Old 09-11-03, 06:20 AM   #6
dj1471
...
 
Join Date: Jun 2003
Location: UK
Posts: 13
Default

I am also having this problem with the following setup: -

Redhat 9
Kernel 2.4.22-ac1
GeForce 440 Go

It's nothing to do with TV out...

I hope nVidia fix this in the next release - it's driving me mad!
dj1471 is offline   Reply With Quote
Old 09-11-03, 08:38 PM   #7
Pagan
GeForce4 (Linux 2.4.22
 
Pagan's Avatar
 
Join Date: Apr 2003
Location: North America
Posts: 8
Default

Quote:
Originally posted by another_mike
Hi, again.

Maybe, I found the solution for this strange behaviour:



I haven't tried to reinstall the latest driver, but: My TV is hooked to my graphics card....

mike
I'm not running tv out, and there's no cable or anything hooked up to that port... Only change is the nvidia drivers...

And BTW the nvidia installer did NOT install the nvigia gl headers into /usr/include/GL on three tested systems! I've had to manually copy them into place, and recompile wine... just a heads up!
__________________
Pagan
Pagan is offline   Reply With Quote
Old 09-12-03, 03:14 AM   #8
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default

What could help is to change the handling of the textmode screen from that FB stuff that SuSE is using into a normal text console.

I think there is an option for this somewhere.

I am running SuSE 8.2 myself, but I recompiled the kernel (for another reason) and while doing that I removed the FB support.

It then boots up with a standard dull 80x24 text screen instead of the nice graphic screen with SuSE logo, but I don't care.
I did this after reading about difficulties switching between X and textmode screens.
At first it worked fine, but after I had configured my card to use 2 X screens (CRT and TV) the trouble returned. Now, when I switch to textmode, that is output on the TV. The CRT has text but it is not updated when I type.

Well, why would one want to exit X?
Use graphical login, and shutdown from the login screen.
pe1chl is offline   Reply With Quote

Old 09-13-03, 01:49 AM   #9
Pagan
GeForce4 (Linux 2.4.22
 
Pagan's Avatar
 
Join Date: Apr 2003
Location: North America
Posts: 8
Default FrameBuffer and Exiting X

I had some suspicions about that... I've tried it with vga=792 vga=exteneded, and no vga kernel parameter... same result and this is a custom 2.4.22 kernel build...

And to answer your question about exiting x:
I do a lot of work in a text console... both remote and local... liek forexample when compiling something large I'll use vc2 [ctrl+alt+f2] to compile and then switch back to x with alt+f7

Sometimes I won't be in x for days...
__________________
Pagan
Pagan is offline   Reply With Quote
Old 09-13-03, 03:42 AM   #10
yS_
Registered User
 
Join Date: Aug 2003
Posts: 9
Default

There is another post about this. Perhaps it can help you.

http://www.nvnews.net/vbulletin/show...&threadid=6611
yS_ is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Russian Masterpieces Put on Display Using NVIDIA GPU Technology News Archived News Items 0 06-25-12 04:10 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM

All times are GMT -5. The time now is 01:38 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.