Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-03-03, 06:45 AM   #1
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default drive can't identify card

I recently updated glibc, gcc and some other system libraries on my RH9 box to 3.3.1 from rawhide, and now when I try to start x, I get an error stating that the driver can't identity the card. This was the only recent change I've made, so I'm fairly certain this is the problem and X was fine before this change. Any ideas other than downgrading those libs? Anyone else run into this?
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 09-03-03, 07:12 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

What's the exact error message (it'd be good if you could post the XFree86 log file)?
zander is offline   Reply With Quote
Old 09-03-03, 07:37 AM   #3
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default

That is the error, "can't identify card". It then goes on with enumerating modes, etc., sucessfully. However, since it seems that since it can't identify the card, it refuses to load X.
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 09-03-03, 08:02 AM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

I don't think the NVIDIA driver emits this error message; could you post the complete XFree86 log file?
zander is offline   Reply With Quote
Old 09-03-03, 10:56 AM   #5
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default

It does, and I'll post the log later that shows it.
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 09-03-03, 08:27 PM   #6
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default

Ok... I was a bit off on the error... but still... Here's the log. The exact error is:

(EE) NVIDIA(0): Failed to determine chip name
(II) NVIDIA(0): NVIDIA GPU detected as: NVxx

XFree86 log file
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 09-04-03, 02:11 AM   #7
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

Judging from the log file, you're using a GeForceFX 5900 ((--) PCI:*(3:0:0) nVidia Corporation unknown chipset (0x0331) rev 161, Mem @ 0xda000000/24, 0xd0000000/27) and 1.0-4363, which likely really doesn't know this card. The log file also indicates that the driver initializes and works just fine, though - is that not the case? Either way, you'll want to use 1.0-4496 with your card, not just to have the driver detect, recognize and report it as what it is.
zander is offline   Reply With Quote
Old 09-04-03, 03:41 PM   #8
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default

Yep, 5900. Worked fine the first few days I had it in the box. Then, as I said, I updated glibc and some related libraries. Now, X starts for a moment and immediately exits. It does this even when logged in as root.

Now, however, since I installed the 4496 driver, I get the infamous "No Screens" error when trying to start X. I'll post the full log after I get back home. Forunately, I'm at least able to ssh into the box and run my apps. I may also just scrap the box and put the new RH beta on it this weekend if I don't have it working by then.
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote

Old 09-04-03, 09:32 PM   #9
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default

OK, updating some more libs and XFree86 got me back in. However, now I'm getting Xlib: extension "XFree86-DRI" missing on display ":0.0"

On we go...
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Measuring card memory usage peter_ga NVIDIA Linux 0 05-24-12 08:07 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
Video card upgrade advice needed Billy34 NVIDIA GeForce 7, 8, And 9 Series 5 08-28-02 05:19 PM
New Western Digital drive performance Nemesis General Hardware 6 08-15-02 07:29 AM

All times are GMT -5. The time now is 10:30 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.