Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-28-12, 04:35 AM   #1
jody
Registered User
 
Join Date: Feb 2012
Posts: 4
Default "OpenGL Stereo" on QuadroFX 5000

Hi
We got a Quadro FX5000 and a Acer GN245HQ Monitor which can do 120Hz.
I have installed nvidia-driver 290.10 and nvidia-settings 260.19.29

Currently the stereo mode seems not to be enabled: both "glxgears --stereo" as well as a medical Software which can use OpenGL Stereo report that the device is not stereo capable.

I know that under Windows there is a Nvidia Control Panel where you can set something like "Enable OpenGL Stereo" (or similar). But under Linux there is no nVidia control panel, and the nvidia settings don't have any "Stereo" button (as far as i could see...)

How can i enable the Stereo Mode for this cards under linux?

Thank You
Jody

Last edited by jody; 02-28-12 at 04:51 AM. Reason: Additional information
jody is offline   Reply With Quote
Old 02-28-12, 12:50 PM   #2
rdupitas
Registered User
 
Join Date: Feb 2012
Posts: 3
Default Re: "OpenGL Stereo" on QuadroFX 5000

What does your xorg.conf file look like?
rdupitas is offline   Reply With Quote
Old 02-29-12, 01:20 AM   #3
jody
Registered User
 
Join Date: Feb 2012
Posts: 4
Default Re: "OpenGL Stereo" on QuadroFX 5000

Hi

This what my xorg.conf looks like:
Code:
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputClass"
        Identifier "mouse-all"
        Driver "evdev"
        MatchIsPointer "on"
EndSection

Section "InputClass"
        Identifier "keyboard-all"
        Driver "evdev"
        Option "XkbLayout" "us"
        MatchIsKeyboard "on"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       30.0 - 190.0
    VertRefresh     56.0 - 125.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro FX 5000"
    Option         "Stereo" "3"
    Option         "AllowDFPStereo" "true"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1920+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Module"
  	Load "glx"
EndSection
To explain the TwinView setup: I have the Acer monitor on the left side (DFP-0), and a "normal" monitor (Samsung) on the right (DFP-1).

Thank You for any suggestions
Jody
jody is offline   Reply With Quote
Old 03-01-12, 05:51 AM   #4
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: "OpenGL Stereo" on QuadroFX 5000

Are you using "Stereo" "3" Or "Stereo" "10"? Are you using external IR emitter Or monitor's inbuilt IR emitter?

Also add in xorg.conf:

Section "Extensions"
Option "Composite" "Disable"
EndSection
sandipt is offline   Reply With Quote
Old 03-01-12, 06:46 AM   #5
jody
Registered User
 
Join Date: Feb 2012
Posts: 4
Default Re: "OpenGL Stereo" on QuadroFX 5000

Thank You for your reply

Quote:
Are you using "Stereo" "3" Or "Stereo" "10"?
I don't explicitly use a particular sort of stereo - i only wanted do enable stereo for this monitor so that the applications with stereo options recognize the monitor as stereo-enabled.

Quote:
Are you using external IR emitter Or monitor's inbuilt IR emitter?
I never found any info on how to access any emitter (internal or external)

I have found a test program by bob somers which allows the controlling of nvidias external emitter.

If you have any information on how to control the monitor's internal emitter i would be very thankful for it.


Another problem i encountered: If i remember correctly you need a refresh rate of 120Hz for stereo. By default this moniotor has 60Hz, but i k found out how to set it to 120Hz. However, each time i restart, it is reset to 60Hz. Can you help me here as well?

Thanks a lot
jody
jody is offline   Reply With Quote
Old 03-01-12, 06:52 AM   #6
BibhutiP
NVIDIA Corporation
 
BibhutiP's Avatar
 
Join Date: Jun 2007
Posts: 1
Default Re: "OpenGL Stereo" on QuadroFX 5000

Yes, Stereo is incompatible with the Composite extension.
Please try by disabling Composite.

Also please include the nvidia-bug-report.log file when reporting a problem.
http://www.nvnews.net/vbulletin/showthread.php?t=46678
__________________
Thanx,
./Bibhuti
BibhutiP is offline   Reply With Quote
Old 03-01-12, 06:58 AM   #7
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: "OpenGL Stereo" on QuadroFX 5000

Just add line in xorg.conf file :

Option "Stereo" "10"

OR do : `nvidia-xconfig -stereo=10`

and restartX . You will see blue color led of monitor become green. And check the resolutions and frequency in nvidia-settings.

You can manually set resolution 1920x1080 with 120 Hz
sandipt is offline   Reply With Quote
Old 03-01-12, 08:32 AM   #8
jody
Registered User
 
Join Date: Feb 2012
Posts: 4
Default Re: "OpenGL Stereo" on QuadroFX 5000

It works!!

Thank you very much for your help.

One final question:
When i reboot the machine, and log in, some text in a blue rectangle appears which amongst other things tells you to "turn off stereo if your not watching stereo"

Is the stereo mode harmful for the operation of the monitor?

Thank You
Jody
jody is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:15 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.