Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-09-12, 09:49 AM   #1
finr
Registered User
 
Join Date: Jan 2012
Posts: 3
Default Metamodes/Twinview depending on connected displays

Hi all,

I'm using my notebook either in a docking station with two connected LCDs (DFP-2 and DFP-3) or without the dock, ie. only with the internal display. So I'd like to have a twinview configuration that selects the two external displays if they are connected, or reverts to just the internal display (DFP-0) if they are not. I tried the setting
Code:
Option         "metamodes" "DFP-2: nvidia-auto-select +0+0, DFP-3: nvidia-auto-select +1920+0; DFP-0: nvidia-auto-select +0+0"
but it did not work: When the notebook is in the dock, I get the following output:
Code:
[  2815.163] (--) NVIDIA(0): Connected display device(s) on NVS 4200M at PCI:1:0:0
[  2815.163] (--) NVIDIA(0):     CRT-0
[  2815.163] (--) NVIDIA(0):     Seiko/Epson (DFP-0)
[  2815.163] (--) NVIDIA(0):     DELL 2407WFP (DFP-2)
[  2815.163] (--) NVIDIA(0):     DELL 2407WFP (DFP-3)
...
[  2815.165] (**) NVIDIA(0): TwinView enabled
[  2815.166] (II) NVIDIA(0): Display Devices found referenced in MetaMode: DFP-0, DFP-2,
[  2815.166] (II) NVIDIA(0):     DFP-3
[  2815.166] (WW) NVIDIA(0): There are only 2 heads available, trimming display device list
[  2815.166] (WW) NVIDIA(0):     from "DFP-0, DFP-2, DFP-3" to "DFP-0, DFP-2".
...
[  2815.201] (II) NVIDIA(0): Assigned Display Devices: DFP-0, DFP-2
[  2815.201] (II) NVIDIA(0): Validated modes:
[  2815.201] (II) NVIDIA(0):
[  2815.201] (II) NVIDIA(0):     "DFP-2:nvidia-auto-select+0+0,DFP-3:nvidia-auto-select+1920+0"
[  2815.201] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select+0+0"
[  2815.201] (II) NVIDIA(0): Virtual screen size determined to be 3520 x 1200
...
[  2815.736] (II) NVIDIA(0): Setting mode
[  2815.736] (II) NVIDIA(0):     "DFP-2:nvidia-auto-select+0+0,DFP-3:nvidia-auto-select+1920+0"
With the last line, I'd assume that the two external displays should be in use, but DFP-2 is on position +0+0 (ok so far) and DFP-0 (ie the internal display instead of the second external LCD on DFP-3) is on position +1920+0, with DFP-3 disabled.

If the book is not in the dock, I get the following output:
Code:
[  3071.183] (--) NVIDIA(0): Connected display device(s) on NVS 4200M at PCI:1:0:0
[  3071.183] (--) NVIDIA(0):     CRT-0
[  3071.183] (--) NVIDIA(0):     Seiko/Epson (DFP-0)
...
[  3071.186] (**) NVIDIA(0): TwinView enabled
[  3071.186] (II) NVIDIA(0): Display Device found referenced in MetaMode: DFP-0
[  3071.186] (WW) NVIDIA(0): TwinView requested, but only 1 display devices found.
...
[  3071.202] (II) NVIDIA(0): Assigned Display Device: DFP-0
[  3071.202] (WW) NVIDIA(0): Invalid display device in Mode Description
[  3071.202] (WW) NVIDIA(0):     "DFP-3:nvidia-auto-select+1920+0"
[  3071.202] (WW) NVIDIA(0): Not using mode description "DFP-3:nvidia-auto-select+1920+0";
[  3071.202] (WW) NVIDIA(0):     unable to map to display device
[  3071.202] (II) NVIDIA(0): Validated modes:
[  3071.202] (II) NVIDIA(0):
[  3071.202] (II) NVIDIA(0):     "DFP-2:nvidia-auto-select+0+0,DFP-3:nvidia-auto-select+1920+0"
[  3071.202] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select+0+0"
[  3071.202] (II) NVIDIA(0): Virtual screen size determined to be 1600 x 900
...
[  3071.743] (II) NVIDIA(0): Setting mode
[  3071.743] (II) NVIDIA(0):     "DFP-2:nvidia-auto-select+0+0,DFP-3:nvidia-auto-select+1920+0"
and, as I want, only the internal display is active.

Interestingly, CRT-0 always shows as connected even though it is not, neither with nor without the dock.

It would be great if anyone could point me towards what is wrong here...

BTW: An additional bonus would be if there were a third option for presentations in which the driver automatically cloned the internal display to CRT-0 if a CRT is connected .

EDIT: Driver version is 280.13 on Ubuntu 11.10 x86_64.

Thanks!
finr is offline   Reply With Quote
Old 01-10-12, 02:02 AM   #2
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: Metamodes/Twinview depending on connected displays

Please attach bug report by running nvidia-bug-report.sh as root for both cases .
sandipt is offline   Reply With Quote
Old 01-13-12, 02:14 AM   #3
finr
Registered User
 
Join Date: Jan 2012
Posts: 3
Default Re: Metamodes/Twinview depending on connected displays

Hi,

please find the bug reports attached.

Thanks!
Attached Files
File Type: gz nvidia-bug-report-in-dock.log.gz (58.6 KB, 33 views)
File Type: gz nvidia-bug-report-standalone.log.gz (52.8 KB, 34 views)
finr is offline   Reply With Quote
Old 01-31-12, 01:51 AM   #4
finr
Registered User
 
Join Date: Jan 2012
Posts: 3
Default Re: Metamodes/Twinview depending on connected displays

Anyone?
finr is offline   Reply With Quote
Old 04-20-12, 06:13 PM   #5
doclight
Registered User
 
Join Date: Apr 2012
Posts: 1
Default Re: Metamodes/Twinview depending on connected displays

I'm also experiencing the same problem with any driver after 275.09.07. The internal LCD display is recognized (DFP-0), as is the external VGA display. However, the external LCD (DFP-1) is recognized, but removed from the list of valid displays.

Where do I file a bug report?
Attached Files
File Type: gz nvidia-bug-report.log.gz (32.8 KB, 39 views)
doclight is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:32 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.