Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-20-03, 09:14 AM   #1
chaghi
Registered User
 
Join Date: Jul 2003
Location: Buenos Aires, Argentina
Posts: 9
Default Why does the center channel wander?

This is annoying!
I can't get the 5.1 sound working propperly under Linux.
The first release of the nVidia "official" drivers (nvaudio) used to support only stereo.
So I installed ALSA.
It works... but the problem is that the center channel jumps from time to time to another speaker. It seems pretty aleatory, although it has a "preference" for the rear left speaker. Unmuting/Muting the channels and "playing" with the alsamixer magically solves the problem... for a couple of minutes
Yesterday I decided to give the new nVidia drivers a try.
Now, the 5.1 sound does work, but with the same problem as regards the center channel. It jumps arround all the time!!!
Besides, nVidia doesn't provide us with any mixer to "fix" the problem.

Can anyone tell me how to avoid this?
Is there a workarround for this?

I have this problem playing DVDs, both with Xine and MPlayer.

Thanks for your help!
chaghi is offline   Reply With Quote
Old 09-07-03, 12:21 PM   #2
Stephen
Registered User
 
Join Date: Sep 2003
Posts: 1
Lightbulb

I am getting 5.1 sound on my Abit NF7-S in linux but in order for the sound to come out of the correct speakers, I have to swap the black and orange analogue sound leads over.

I need to swap back again when using 4 channel sound.

The colours of the speaker leads in windows where all works well do not correspond with the correct sockets (I have an Abit NF7-S).

Black lead ...... Orange Socket
Orange lead ... Black Socket

When working in linux this arrangement works fine until 5.1 sound is used.

But with linux nforce audio and 5.1 sound the plugs go in the correct colour sockets. Weird. And this leads me to the conclusion that the 5.1 part of the linux audio driver was written by a guy with an Abit NF7 who rigged up the sound leads colour for colour and proceeded to get the sound working "properly".

The socket colour mismatch is Abit's mistake as changing the windows audio driver for a generic realtek makes no difference to the mapping.
Stephen is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chip Shot: Intel Science and Technology Center for Cloud Computing Wins Joulesort Com News Archived News Items 0 06-18-12 09:50 PM
Chip Shot: Boost Your Productivity with Intel AppUpā?* center News Archived News Items 0 05-06-12 03:00 AM
Dual Channel DDR ryank1979 CPUs, Motherboards And Memory 3 08-13-02 06:37 AM
GF4 Ti4200 - how center tv out image? kipper NVIDIA Linux 2 08-01-02 11:56 PM

All times are GMT -5. The time now is 08:53 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.