Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-16-12, 11:19 PM   #1
Todd
Guest
 
Posts: n/a
Default Unable to run nvidia-x11-drv since upgrade to SL 6.2

Hi All,

I am running Scientific Linux 6.2 (Red Hat Enterprise Linux 6.2 clone), 64 bit with Xfce 4.8.

Under 6.1, I was able to run the nvidia-x11-drv from elrepo. As on 6.2 I no longer can. These are the RPMs I am using:

kmod-nvidia-295.20-1.el6.elrepo.x86_64.rpm
nvidia-x11-drv-295.20-1.el6.elrepo.x86_64.rpm
nvidia-x11-drv-32bit-295.20-1.el6.elrepo.x86_64.rpm

When I boot up, the X11 display does not open. I recorded both the errors when trying to start Xfce (startxfce4) and Xorg.0.log. Anyone know what I am doing wrong?

Many thanks,
-T

Xfce start errors:
Quote:
/usr/bin/startxfce4: Starting X server


X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: spacewalk 2.6.32-71.29.1.el6.x86_64
Current Operating System: Linux rn4.foo.local 2.6.32-220.7.1.el6.x86_64 #1 SMP Tue Mar 6 15:45:33 CST 2012 x86_64
Kernel command line: ro root=/dev/mapper/luks-948a228f-13ec-462e-9e9e-fa9b4c4bd2e0 rd_LUKS_UUID=luks-948a228f-13ec-462e-9e9e-fa9b4c4bd2e0 rd_LUKS_UUID=luks-857c8618-2461-4dfc-b5bb-69949a804c6d rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us crashkernel=129M@0M rhgb quiet nouveau.modeset=0 rdblacklist=nouveau
Build Date: 15 December 2011 08:42:40AM
Build ID: xorg-x11-server 1.10.4-6.el6_2.1
Current version of pixman: 0.18.4
Before reporting problems, check https://www.redhat.com/apps/support/
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Mar 16 20:51:51 2012
(==) Using default built-in configuration (30 lines)
(EE) [drm] failed to open device
(EE) The PCI device has a kernel module claiming it,
(EE) this driver cannot operate until it has been unloaded.
(EE) Try appending "nomodeset" to your boot options
(EE) open /dev/fb0: No such device
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the Red Hat, Inc. support
at https://www.redhat.com/apps/support/
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

giving up.
xinit: No such file or directory (errno 2): unable to connect to X server
xinit: No such process (errno 3): unexpected signal 2.
Xorg.0.log
Quote:
[ 387.317]
X.Org X Server 1.10.4
Release Date: 2011-08-19
[ 387.317] X Protocol Version 11, Revision 0
[ 387.317] Build Operating System: spacewalk 2.6.32-71.29.1.el6.x86_64
[ 387.317] Current Operating System: Linux rn4.foo.local 2.6.32-220.7.1.el6.x86_64 #1 SMP Tue Mar 6 15:45:33 CST 2012 x86_64
[ 387.317] Kernel command line: ro root=/dev/mapper/luks-948a228f-13ec-462e-9e9e-fa9b4c4bd2e0 rd_LUKS_UUID=luks-948a228f-13ec-462e-9e9e-fa9b4c4bd2e0 rd_LUKS_UUID=luks-857c8618-2461-4dfc-b5bb-69949a804c6d rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us crashkernel=129M@0M rhgb quiet nouveau.modeset=0 rdblacklist=nouveau
[ 387.318] Build Date: 15 December 2011 08:42:40AM
[ 387.318] Build ID: xorg-x11-server 1.10.4-6.el6_2.1
[ 387.318] Current version of pixman: 0.18.4
[ 387.318] Before reporting problems, check https://www.redhat.com/apps/support/
to make sure that you have the latest version.
[ 387.318] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 387.318] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Mar 16 20:51:51 2012
[ 387.318] (II) Loader magic: 0x7d68e0
[ 387.318] (II) Module ABI versions:
[ 387.318] X.Org ANSI C Emulation: 0.4
[ 387.318] X.Org Video Driver: 10.0
[ 387.318] X.Org XInput driver : 12.2
[ 387.318] X.Org Server Extension : 5.0
[ 387.319] (--) PCI:*(0:3:0:0) 10de:0e22:3842:1370 rev 161, Mem @ 0xf8000000/33554432, 0xd8000000/134217728, 0xd4000000/67108864, I/O @ 0x0000bc00/128, BIOS @ 0x????????/524288
[ 387.319] (==) Using default built-in configuration (30 lines)
[ 387.319] (==) --- Start of built-in configuration ---
[ 387.320] Section "Device"
[ 387.320] Identifier "Builtin Default nouveau Device 0"
[ 387.320] Driver "nouveau"
[ 387.320] EndSection
[ 387.320] Section "Screen"
[ 387.320] Identifier "Builtin Default nouveau Screen 0"
[ 387.320] Device "Builtin Default nouveau Device 0"
[ 387.320] EndSection
[ 387.320] Section "Device"
[ 387.320] Identifier "Builtin Default vesa Device 0"
[ 387.320] Driver "vesa"
[ 387.320] EndSection
[ 387.320] Section "Screen"
[ 387.320] Identifier "Builtin Default vesa Screen 0"
[ 387.320] Device "Builtin Default vesa Device 0"
[ 387.320] EndSection
[ 387.320] Section "Device"
[ 387.320] Identifier "Builtin Default fbdev Device 0"
[ 387.320] Driver "fbdev"
[ 387.320] EndSection
[ 387.320] Section "Screen"
[ 387.320] Identifier "Builtin Default fbdev Screen 0"
[ 387.320] Device "Builtin Default fbdev Device 0"
[ 387.320] EndSection
[ 387.320] Section "ServerLayout"
[ 387.320] Identifier "Builtin Default Layout"
[ 387.320] Screen "Builtin Default nouveau Screen 0"
[ 387.320] Screen "Builtin Default vesa Screen 0"
[ 387.320] Screen "Builtin Default fbdev Screen 0"
[ 387.320] EndSection
[ 387.320] (==) --- End of built-in configuration ---
[ 387.320] (==) ServerLayout "Builtin Default Layout"
[ 387.320] (**) |-->Screen "Builtin Default nouveau Screen 0" (0)
[ 387.320] (**) | |-->Monitor "<default monitor>"
[ 387.320] (**) | |-->Device "Builtin Default nouveau Device 0"
[ 387.320] (==) No monitor specified for screen "Builtin Default nouveau Screen 0".
Using a default monitor configuration.
[ 387.320] (**) |-->Screen "Builtin Default vesa Screen 0" (1)
[ 387.320] (**) | |-->Monitor "<default monitor>"
[ 387.320] (**) | |-->Device "Builtin Default vesa Device 0"
[ 387.320] (==) No monitor specified for screen "Builtin Default vesa Screen 0".
Using a default monitor configuration.
[ 387.320] (**) |-->Screen "Builtin Default fbdev Screen 0" (2)
[ 387.320] (**) | |-->Monitor "<default monitor>"
[ 387.320] (**) | |-->Device "Builtin Default fbdev Device 0"
[ 387.320] (==) No monitor specified for screen "Builtin Default fbdev Screen 0".
Using a default monitor configuration.
[ 387.320] (==) Automatically adding devices
[ 387.320] (==) Automatically enabling devices
[ 387.320] (==) FontPath set to:
catalogue:/etc/X11/fontpath.d,
built-ins
[ 387.320] (==) ModulePath set to "/usr/lib64/xorg/modules"
[ 387.320] (II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AutoAddDevices.
[ 387.320] (II) LoadModule: "extmod"
[ 387.321] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[ 387.321] (II) Module extmod: vendor="X.Org Foundation"
[ 387.321] compiled for 1.10.4, module version = 1.0.0
[ 387.321] Module class: X.Org Server Extension
[ 387.321] ABI class: X.Org Server Extension, version 5.0
[ 387.321] (II) Loading extension SELinux
[ 387.321] (II) Loading extension MIT-SCREEN-SAVER
[ 387.321] (II) Loading extension XFree86-VidModeExtension
[ 387.321] (II) Loading extension XFree86-DGA
[ 387.321] (II) Loading extension DPMS
[ 387.321] (II) Loading extension XVideo
[ 387.321] (II) Loading extension XVideo-MotionCompensation
[ 387.321] (II) Loading extension X-Resource
[ 387.321] (II) LoadModule: "dbe"
[ 387.322] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[ 387.322] (II) Module dbe: vendor="X.Org Foundation"
[ 387.322] compiled for 1.10.4, module version = 1.0.0
[ 387.322] Module class: X.Org Server Extension
[ 387.322] ABI class: X.Org Server Extension, version 5.0
[ 387.322] (II) Loading extension DOUBLE-BUFFER
[ 387.322] (II) LoadModule: "glx"
[ 387.322] (II) Loading /usr/lib64/xorg/modules/extensions/nvidia/libglx.so
[ 387.329] (II) Module glx: vendor="NVIDIA Corporation"
[ 387.329] compiled for 4.0.2, module version = 1.0.0
[ 387.329] Module class: X.Org Server Extension
[ 387.329] (II) NVIDIA GLX Module 295.20 Mon Feb 6 21:28:16 PST 2012
[ 387.329] (II) Loading extension GLX
[ 387.329] (II) LoadModule: "record"
[ 387.330] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[ 387.330] (II) Module record: vendor="X.Org Foundation"
[ 387.330] compiled for 1.10.4, module version = 1.13.0
[ 387.330] Module class: X.Org Server Extension
[ 387.330] ABI class: X.Org Server Extension, version 5.0
[ 387.330] (II) Loading extension RECORD
[ 387.330] (II) LoadModule: "dri"
[ 387.330] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[ 387.330] (II) Module dri: vendor="X.Org Foundation"
[ 387.330] compiled for 1.10.4, module version = 1.0.0
[ 387.330] ABI class: X.Org Server Extension, version 5.0
[ 387.330] (II) Loading extension XFree86-DRI
[ 387.330] (II) LoadModule: "dri2"
[ 387.330] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[ 387.330] (II) Module dri2: vendor="X.Org Foundation"
[ 387.330] compiled for 1.10.4, module version = 1.2.0
[ 387.330] ABI class: X.Org Server Extension, version 5.0
[ 387.330] (II) Loading extension DRI2
[ 387.330] (II) LoadModule: "nouveau"
[ 387.330] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[ 387.331] (II) Module nouveau: vendor="X.Org Foundation"
[ 387.331] compiled for 1.10.4, module version = 0.0.16
[ 387.331] Module class: X.Org Video Driver
[ 387.331] ABI class: X.Org Video Driver, version 10.0
[ 387.331] (II) LoadModule: "vesa"
[ 387.331] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[ 387.331] (II) Module vesa: vendor="X.Org Foundation"
[ 387.331] compiled for 1.10.4, module version = 2.3.0
[ 387.331] Module class: X.Org Video Driver
[ 387.331] ABI class: X.Org Video Driver, version 10.0
[ 387.331] (II) LoadModule: "fbdev"
[ 387.331] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[ 387.331] (II) Module fbdev: vendor="X.Org Foundation"
[ 387.331] compiled for 1.10.4, module version = 0.4.2
[ 387.331] ABI class: X.Org Video Driver, version 10.0
[ 387.331] (II) NOUVEAU driver
[ 387.331] (II) NOUVEAU driver for NVIDIA chipset families :
[ 387.331] RIVA TNT (NV04)
[ 387.331] RIVA TNT2 (NV05)
[ 387.331] GeForce 256 (NV10)
[ 387.331] GeForce 2 (NV11, NV15)
[ 387.331] GeForce 4MX (NV17, NV18)
[ 387.331] GeForce 3 (NV20)
[ 387.331] GeForce 4Ti (NV25, NV28)
[ 387.331] GeForce FX (NV3x)
[ 387.331] GeForce 6 (NV4x)
[ 387.331] GeForce 7 (G7x)
[ 387.331] GeForce 8 (G8x)
[ 387.331] GeForce GTX 200 (NVA0)
[ 387.331] GeForce GTX 400 (NVC0)
[ 387.331] (II) VESA: driver for VESA chipsets: vesa
[ 387.331] (II) FBDEV: driver for framebuffer: fbdev
[ 387.331] (--) using VT number 7

[ 387.335] drmOpenDevice: node name is /dev/dri/card0
[ 387.350] drmOpenByBusid: Searching for BusID pci:0000:03:00.0
[ 387.350] drmOpenDevice: node name is /dev/dri/card0
[ 387.354] drmOpenByBusid: drmOpenMinor returns -1
[ 387.354] drmOpenDevice: node name is /dev/dri/card1
[ 387.357] drmOpenByBusid: drmOpenMinor returns -1
[ 387.357] drmOpenDevice: node name is /dev/dri/card2
[ 387.361] drmOpenByBusid: drmOpenMinor returns -1
[ 387.361] drmOpenDevice: node name is /dev/dri/card3
[ 387.365] drmOpenByBusid: drmOpenMinor returns -1
[ 387.365] drmOpenDevice: node name is /dev/dri/card4
[ 387.368] drmOpenByBusid: drmOpenMinor returns -1
[ 387.369] drmOpenDevice: node name is /dev/dri/card5
[ 387.372] drmOpenByBusid: drmOpenMinor returns -1
[ 387.372] drmOpenDevice: node name is /dev/dri/card6
[ 387.376] drmOpenByBusid: drmOpenMinor returns -1
[ 387.376] drmOpenDevice: node name is /dev/dri/card7
[ 387.380] drmOpenByBusid: drmOpenMinor returns -1
[ 387.380] drmOpenDevice: node name is /dev/dri/card8
[ 387.384] drmOpenByBusid: drmOpenMinor returns -1
[ 387.384] drmOpenDevice: node name is /dev/dri/card9
[ 387.388] drmOpenByBusid: drmOpenMinor returns -1
[ 387.388] drmOpenDevice: node name is /dev/dri/card10
[ 387.391] drmOpenByBusid: drmOpenMinor returns -1
[ 387.391] drmOpenDevice: node name is /dev/dri/card11
[ 387.395] drmOpenByBusid: drmOpenMinor returns -1
[ 387.395] drmOpenDevice: node name is /dev/dri/card12
[ 387.399] drmOpenByBusid: drmOpenMinor returns -1
[ 387.399] drmOpenDevice: node name is /dev/dri/card13
[ 387.403] drmOpenByBusid: drmOpenMinor returns -1
[ 387.403] drmOpenDevice: node name is /dev/dri/card14
[ 387.406] drmOpenByBusid: drmOpenMinor returns -1
[ 387.406] drmOpenDevice: node name is /dev/dri/card15
[ 387.410] drmOpenByBusid: drmOpenMinor returns -1
[ 387.410] drmOpenDevice: node name is /dev/dri/card0
[ 387.416] drmOpenDevice: node name is /dev/dri/card0
[ 387.420] drmOpenDevice: node name is /dev/dri/card1
[ 387.424] drmOpenDevice: node name is /dev/dri/card2
[ 387.428] drmOpenDevice: node name is /dev/dri/card3
[ 387.431] drmOpenDevice: node name is /dev/dri/card4
[ 387.435] drmOpenDevice: node name is /dev/dri/card5
[ 387.439] drmOpenDevice: node name is /dev/dri/card6
[ 387.443] drmOpenDevice: node name is /dev/dri/card7
[ 387.446] drmOpenDevice: node name is /dev/dri/card8
[ 387.450] drmOpenDevice: node name is /dev/dri/card9
[ 387.454] drmOpenDevice: node name is /dev/dri/card10
[ 387.458] drmOpenDevice: node name is /dev/dri/card11
[ 387.461] drmOpenDevice: node name is /dev/dri/card12
[ 387.465] drmOpenDevice: node name is /dev/dri/card13
[ 387.469] drmOpenDevice: node name is /dev/dri/card14
[ 387.473] drmOpenDevice: node name is /dev/dri/card15
[ 387.476] (EE) [drm] failed to open device
[ 387.476] (EE) The PCI device has a kernel module claiming it,
[ 387.476] (EE) this driver cannot operate until it has been unloaded.
[ 387.476] (EE) Try appending "nomodeset" to your boot options
[ 387.476] (WW) Falling back to old probe method for vesa
[ 387.476] (II) Loading sub module "fbdevhw"
[ 387.476] (II) LoadModule: "fbdevhw"
[ 387.477] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[ 387.477] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 387.477] compiled for 1.10.4, module version = 0.0.2
[ 387.477] ABI class: X.Org Video Driver, version 10.0
[ 387.477] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[ 387.477] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[ 387.479] (EE) open /dev/fb0: No such device
[ 387.479] (WW) Falling back to old probe method for fbdev
[ 387.479] (II) UnloadModule: "fbdev"
[ 387.479] (II) Unloading fbdev
[ 387.479] (II) UnloadModule: "fbdevhw"
[ 387.479] (II) Unloading fbdevhw
[ 387.479] (EE) Screen(s) found, but none have a usable configuration.
[ 387.479]
Fatal server error:
[ 387.479] no screens found
[ 387.479]
Please consult the Red Hat, Inc. support
at https://www.redhat.com/apps/support/
for help.
[ 387.479] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 387.479]
  Reply With Quote
Old 03-24-12, 09:17 PM   #2
Todd
Guest
 
Posts: n/a
Default Re: Unable to run nvidia-x11-drv since upgrade to SL 6.2

Solved:

Phil over on the ELRepo mailing list helped me solve this.

The post install scripts were not recreating /etc/X11/xorg.conf.

Solution:

AFTER installing the drivers (they will rename xorg.conf on you), run:

Code:
ln -s /etc/X11/XF86Config /etc/X11/xorg.conf
and reboot.

Thanks to all that helped me on this!

-T
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:20 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.