Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-02-12, 01:13 PM   #13
purdy
Registered User
 
Join Date: May 2012
Posts: 1
Unhappy Re: Xorg server crash in nvidia 295.20.

I'm also having this problem and it happens randomly ... I'll see this in my syslog after a crash. I can trigger a crash by watching a video on YouTube, but sometimes it just does it randomly while I'm in a different application (and flash video isn't involved), like eclipse, libreoffice, etc.

Code:
May  2 13:57:27 jason-desktop kernel: [168045.740414] NVRM: Xid (0000:02:00): 6, PE0001 
May  2 13:57:27 jason-desktop gnome-session[16065]: Gdk-WARNING: gnome-session: Fatal IO error 11 (Resource temporarily unavailable) on X server :7.#012
May  2 13:57:29 jason-desktop kernel: [168047.562770] eclipse[16156] trap divide error ip:7fde64112f68 sp:7fff175ccde0 error:0 in libgtk-x11-2.0.so.0.2400.10[7fde63fe9000+42d000]
May  2 13:57:30 jason-desktop pulseaudio[26326]: [pulseaudio] client-conf-x11.c: xcb_connection_has_error() returned true
May  2 13:57:31 jason-desktop pulseaudio[26334]: [pulseaudio] pid.c: Stale PID file, overwriting.
May  2 13:57:33 jason-desktop pulseaudio[26334]: [pulseaudio] bluetooth-util.c: Error from ListAdapters reply: org.freedesktop.DBus.Error.AccessDenied
May  2 13:57:33 jason-desktop acpid: client 15866[0:0] has disconnected
May  2 13:57:33 jason-desktop acpid: client 15866[0:0] has disconnected
May  2 13:57:33 jason-desktop acpid: client connected from 26340[0:0]
May  2 13:57:33 jason-desktop acpid: 1 client rule loaded
May  2 13:57:33 jason-desktop pulseaudio[26334]: [pulseaudio] server-lookup.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NoServer: Failed to connect to socket /tmp/dbus-tSc8FaAGQY: Connection refused
May  2 13:57:33 jason-desktop pulseaudio[26334]: [pulseaudio] main.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NoServer: Failed to connect to socket /tmp/dbus-tSc8FaAGQY: Connection refused
May  2 13:57:35 jason-desktop acpid: client connected from 26340[0:0]
May  2 13:57:35 jason-desktop acpid: 1 client rule loaded
May  2 13:57:41 jason-desktop rtkit-daemon[2565]: Successfully made thread 26436 of process 26436 (n/a) owned by '123' high priority at nice level -11.
May  2 13:57:41 jason-desktop rtkit-daemon[2565]: Supervising 1 threads of 1 processes of 2 users.
May  2 13:57:42 jason-desktop rtkit-daemon[2565]: Successfully made thread 26459 of process 26436 (n/a) owned by '123' RT at priority 5.
May  2 13:57:42 jason-desktop rtkit-daemon[2565]: Supervising 2 threads of 1 processes of 2 users.
May  2 13:57:42 jason-desktop rtkit-daemon[2565]: Successfully made thread 26460 of process 26436 (n/a) owned by '123' RT at priority 5.
May  2 13:57:42 jason-desktop rtkit-daemon[2565]: Supervising 3 threads of 1 processes of 2 users.
May  2 13:57:42 jason-desktop rtkit-daemon[2565]: Successfully made thread 26463 of process 26463 (n/a) owned by '123' high priority at nice level -11.
May  2 13:57:42 jason-desktop rtkit-daemon[2565]: Supervising 4 threads of 2 processes of 2 users.
May  2 13:57:42 jason-desktop pulseaudio[26463]: [pulseaudio] pid.c: Daemon already running.
May  2 13:57:48 jason-desktop gnome-session[26529]: EggSMClient-WARNING: Desktop file '/usr/share/gnome/autostart/webilder_indicator.desktop' has malformed Icon key 'camera48.png'(should not include extension)
May  2 13:57:51 jason-desktop gnome-session[26529]: WARNING: Failed to start app: Unable to start application: Failed to execute child process "avant-window-navigator" (No such file or directory)
May  2 13:57:52 jason-desktop gnome-session[26529]: WARNING: Failed to start app: Unable to start application: Failed to execute child process "autokey-gtk" (No such file or directory)
May  2 13:58:42 jason-desktop goa[27239]: goa-daemon version 3.4.0 starting [main.c:112, main()]
All this happened when I upgraded my Ubuntu from 11.10 to 12.04, if that helps. I'm also attaching an nvidia-bug-report.
Attached Files
File Type: gz nvidia-bug-report.log.gz (56.6 KB, 54 views)
purdy is offline   Reply With Quote
Old 05-02-12, 09:56 PM   #14
sangu
Registered User
 
Join Date: Feb 2005
Posts: 84
Default Re: Xorg server crash in nvidia 295.20.

Xorg Still crashes in 302.07.
Attached Files
File Type: gz nvidia-bug-report.log.gz (50.9 KB, 66 views)
sangu is offline   Reply With Quote
Old 05-07-12, 03:13 AM   #15
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: Xorg server crash in nvidia 295.20.

Any improvement with 295.49 driver?
sandipt is offline   Reply With Quote
Old 05-18-12, 01:54 AM   #16
sangu
Registered User
 
Join Date: Feb 2005
Posts: 84
Default Re: Xorg server crash in nvidia 295.20.

Quote:
Originally Posted by sandipt View Post
Any improvement with 295.49 driver?
No Change.

And, this bug still happens in 295.53 driver.
Attached Files
File Type: gz nvidia-bug-report.log.gz (52.0 KB, 55 views)
sangu is offline   Reply With Quote
Old 05-18-12, 12:37 PM   #17
wxwok
Registered User
 
Join Date: May 2012
Posts: 2
Default Re: Xorg server crash in nvidia 295.20.

295.53 still happens.
My system is ubuntu 12.04. CPU I5, RAM:8G.
syslog:
kernel: [ 4252.501359] NVRM: Xid (0000:01:00): 6, PE0001
Attached Files
File Type: gz nvidia-bug-report.log.gz (87.2 KB, 52 views)
wxwok is offline   Reply With Quote
Old 05-18-12, 03:40 PM   #18
davidryderuk
Registered User
 
Join Date: May 2012
Posts: 1
Default Re: Xorg server crash in nvidia 295.20.

I'm also suffering from this problem.

I'm running Ubuntu 12.04, with an Nvidia Geforce 320M. I've generated the nvidia-bug-report.log.gz file, but can't attach because the log file is too big.

In any case, I've read the forums and can't see any direct link to the issue on Launchpad, so thought I would attach a link just in case.

https://bugs.launchpad.net/ubuntu/+s...rs/+bug/973096

I'm running Unity 2D. The problem occurs when using Flash, VMD, Vdpau (through Mythtv or Gnome Mplayer) and sometimes seems to be completely without cause. I've tried Nvidia versions 295.33, 295.40 and 295.49 without any success. I'm running Kernel version 3.2.0.24 and X Server version 1.11.3.

Note the issue does not occur immediately, it seems slightly random, but definately happens at least once, and sometimes multiple times a day.
davidryderuk is offline   Reply With Quote
Old 05-20-12, 10:49 AM   #19
Raceman
Registered User
 
Join Date: May 2012
Posts: 1
Default Re: Xorg server crash in nvidia 295.20.

Same problem here with a clean Ubuntu 12.04 LTS 64bit, and tested with latest 295.53 drivers.
G80 [Quadro FX 4600] card.

I can let it crash quickly with watching the Travel Journal demo video at http://www.adobe.com/devnet/flash/ar...ith-flash.html
Most of the times it crashed at the first play within a few seconds, sometimes I need a second play, and then it will crash.

But as others told the system crashed randomly (not when idle).
Attached Files
File Type: gz nvidia-bug-report.log.gz (71.1 KB, 50 views)
Raceman is offline   Reply With Quote
Old 05-21-12, 07:27 AM   #20
hutou
Registered User
 
Join Date: May 2012
Posts: 1
Default Re: Xorg server crash in nvidia 295.20.

Hi,
Same problem here : random crash of gnome3 AND shutdown freeze (each time) since 295.20 and up on Laptop Dell XPS m1530 (with GeForce 8600M GT) running ArchLinux 32 bits.
hutou is offline   Reply With Quote

Old 06-20-12, 10:41 AM   #21
Kururu
Registered User
 
Join Date: Jun 2012
Posts: 4
Default Re: Xorg server crash in nvidia 295.20.

I have a similar problem.
Sometimes the system freezes at random but it doesn't stop immediately. The video freezes, but the mouse pointer is still active for 5-10 seconds, then it starts to slow down for 2-3 seconds and the system freeze and needs a physical reset.
Some other time only Xorg crashes.

My video card is a GT250 1G RAM, and the system is a Gentoo-x86 with gentoo-kernel from 3.2.11 to 3.2.14 and Xorg 1.11.4.
I tested all the 295 and the 302.17 drivers, with the same result.

The system works fine with the 290.10 release if the PowerMizer is setted to MaximuPerformance, otherwise the system or Xorg crash at random even with this driver
Kururu is offline   Reply With Quote
Old 06-21-12, 03:34 PM   #22
heckleme
Registered User
 
Join Date: Jun 2012
Posts: 1
Default Re: Xorg server crash in nvidia 295.20.

Here to add another data point.

Since updating to the 295.x series I've been getting seemingly random X crashes while browsing, swichting desktops, or just idling (no browsers open). Every one is accompanied by a "NVRM: Xid (0000:01:00): 6, PE0001" error.

-seemingly random
-Chrome 21.0.1180.0 dev and Firefox (Iceweasel) 10.0.5
-11.2.202.235
-KDE 4.8.4 (and previously 4.7.x)
-Kwin
-Geforce 8800GT, Debian Wheezy x86 (3.2.0-1-686-pae kernel)
-kdm

I've had this issue before updating to X server 1.12 as well, and had to revert to the 290.10 driver for a few months (which never crashed), but it seems that's no longer compatible with the new server. I'll probably end up on nouveau if this persists, but I'd rather not have to do that.
Attached Files
File Type: gz nvidia-bug-report.log.gz (65.4 KB, 44 views)
heckleme is offline   Reply With Quote
Old 06-22-12, 07:43 AM   #23
sandipt
NVIDIA Corporation
 
sandipt's Avatar
 
Join Date: Dec 2010
Posts: 260
Default Re: Xorg server crash in nvidia 295.20.

We are able to reproduce X server crash issue with G80(Quadro FX 4600) card . Will keep you updated ...
sandipt is offline   Reply With Quote
Old 06-30-12, 05:38 AM   #24
windchine
Registered User
 
Join Date: Jun 2012
Posts: 3
Default Re: Xorg server crash in nvidia 295.20.

This sounds similar to my problem. The system runs Fedora17 with Gnome3. About 1 minute after login to Gnome the GUI freezes. It always fails in about this timescale seemingly regardless of what I do. From memory, I think there is initially a little mouse movement remaining then that also freezes. I don't know about any other form of system access (tty, LAN). No keyboard controls (ctl-alt-del, switch to virtual console, etc.) have any effect. Recovery requires a hard reboot.

I have only just tried the nVidia driver so cannot comment on how new this problem is. For the time being I have switched back to neaveau which works fine if a little slow. The system reports the following graphics card type:

01:00.0 VGA compatible controller: nVidia Corporation G92M [Quadro FX 3600M] (rev a2)
windchine is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:46 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.