Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-18-12, 11:32 PM   #1
Vadim P.
Registered User
 
Join Date: Mar 2008
Posts: 28
Default Can't start X anymore w/ 8600GTM

My laptops screen doesn't seem to be turning on, while the laptop boots up fine and I can connect to it via SSH. I connected an external display to it via VGA, but it seems that a) nvidia drivers were refusing to start because the graphics card stopped showing up on lspci, and b) X itself is refusing to start at all, claiming there are no displays. This is what startx gives:

Quote:
$ cat /var/log/Xorg.0.log
[ 733.095]
X.Org X Server 1.10.4
Release Date: 2011-08-19
[ 733.095] X Protocol Version 11, Revision 0
[ 733.095] Build Operating System: Linux 2.6.24-29-server x86_64 Ubuntu
[ 733.095] Current Operating System: Linux vadi-11 3.0.0-17-generic #30-Ubuntu SMP Thu Mar 8 20:45:39 UTC 2012 x86_64
[ 733.095] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.0.0-17-generic root=UUID=5a261133-b5a0-46a2-81ff-c1af4edb821e ro quiet splash video=uvesafb:mode_option=1440x900-24,mtrr=3,scroll=ywrap vt.handoff=7
[ 733.095] Build Date: 19 October 2011 05:21:26AM
[ 733.095] xorg-server 2:1.10.4-1ubuntu4.2 (For technical support please see http://www.ubuntu.com/support)
[ 733.095] Current version of pixman: 0.22.2
[ 733.095] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 733.095] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 733.096] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar 19 14:30:50 2012
[ 733.096] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 733.096] (==) No Layout section. Using the first Screen section.
[ 733.096] (==) No screen section available. Using defaults.
[ 733.096] (**) |-->Screen "Default Screen Section" (0)
[ 733.096] (**) | |-->Monitor "<default monitor>"
[ 733.096] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 733.096] (==) Automatically adding devices
[ 733.096] (==) Automatically enabling devices
[ 733.096] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 733.096] Entry deleted from font path.
[ 733.097] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[ 733.097] Entry deleted from font path.
[ 733.097] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[ 733.097] Entry deleted from font path.
[ 733.097] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[ 733.097] Entry deleted from font path.
[ 733.097] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[ 733.097] Entry deleted from font path.
[ 733.097] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/Type1,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
built-ins
[ 733.097] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 733.097] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 733.097] (II) Loader magic: 0x7e0220
[ 733.097] (II) Module ABI versions:
[ 733.097] X.Org ANSI C Emulation: 0.4
[ 733.097] X.Org Video Driver: 10.0
[ 733.097] X.Org XInput driver : 12.3
[ 733.097] X.Org Server Extension : 5.0
[ 733.098] (II) Open ACPI successful (/var/run/acpid.socket)
[ 733.098] (II) LoadModule: "extmod"
[ 733.101] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[ 733.101] (II) Module extmod: vendor="X.Org Foundation"
[ 733.101] compiled for 1.10.4, module version = 1.0.0
[ 733.101] Module class: X.Org Server Extension
[ 733.101] ABI class: X.Org Server Extension, version 5.0
[ 733.101] (II) Loading extension MIT-SCREEN-SAVER
[ 733.101] (II) Loading extension XFree86-VidModeExtension
[ 733.101] (II) Loading extension XFree86-DGA
[ 733.101] (II) Loading extension DPMS
[ 733.101] (II) Loading extension XVideo
[ 733.101] (II) Loading extension XVideo-MotionCompensation
[ 733.101] (II) Loading extension X-Resource
[ 733.101] (II) LoadModule: "dbe"
[ 733.102] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[ 733.102] (II) Module dbe: vendor="X.Org Foundation"
[ 733.102] compiled for 1.10.4, module version = 1.0.0
[ 733.102] Module class: X.Org Server Extension
[ 733.102] ABI class: X.Org Server Extension, version 5.0
[ 733.102] (II) Loading extension DOUBLE-BUFFER
[ 733.102] (II) LoadModule: "glx"
[ 733.103] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 733.103] (II) Module glx: vendor="X.Org Foundation"
[ 733.104] compiled for 1.10.4, module version = 1.0.0
[ 733.104] ABI class: X.Org Server Extension, version 5.0
[ 733.104] (==) AIGLX enabled
[ 733.104] (II) Loading extension GLX
[ 733.104] (II) LoadModule: "record"
[ 733.104] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[ 733.104] (II) Module record: vendor="X.Org Foundation"
[ 733.104] compiled for 1.10.4, module version = 1.13.0
[ 733.104] Module class: X.Org Server Extension
[ 733.104] ABI class: X.Org Server Extension, version 5.0
[ 733.104] (II) Loading extension RECORD
[ 733.104] (II) LoadModule: "dri"
[ 733.105] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[ 733.105] (II) Module dri: vendor="X.Org Foundation"
[ 733.105] compiled for 1.10.4, module version = 1.0.0
[ 733.105] ABI class: X.Org Server Extension, version 5.0
[ 733.105] (II) Loading extension XFree86-DRI
[ 733.105] (II) LoadModule: "dri2"
[ 733.105] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[ 733.105] (II) Module dri2: vendor="X.Org Foundation"
[ 733.105] compiled for 1.10.4, module version = 1.2.0
[ 733.105] ABI class: X.Org Server Extension, version 5.0
[ 733.105] (II) Loading extension DRI2
[ 733.105] (==) Matched vesa as autoconfigured driver 0
[ 733.105] (==) Matched fbdev as autoconfigured driver 1
[ 733.105] (==) Assigned the driver to the xf86ConfigLayout
[ 733.105] (II) LoadModule: "vesa"
[ 733.106] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 733.106] (II) Module vesa: vendor="X.Org Foundation"
[ 733.106] compiled for 1.10.2, module version = 2.3.0
[ 733.106] Module class: X.Org Video Driver
[ 733.106] ABI class: X.Org Video Driver, version 10.0
[ 733.106] (II) LoadModule: "fbdev"
[ 733.106] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 733.106] (II) Module fbdev: vendor="X.Org Foundation"
[ 733.106] compiled for 1.10.0, module version = 0.4.2
[ 733.106] ABI class: X.Org Video Driver, version 10.0
[ 733.106] (II) VESA: driver for VESA chipsets: vesa
[ 733.106] (II) FBDEV: driver for framebuffer: fbdev
[ 733.106] (--) using VT number 8

[ 733.108] (WW) Falling back to old probe method for vesa
[ 733.108] (WW) Falling back to old probe method for fbdev
[ 733.108] (II) Loading sub module "fbdevhw"
[ 733.108] (II) LoadModule: "fbdevhw"
[ 733.109] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 733.109] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 733.109] compiled for 1.10.4, module version = 0.0.2
[ 733.109] ABI class: X.Org Video Driver, version 10.0
[ 733.109] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 733.109] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 733.109] (II) FBDEV(0): using default device
[ 733.109] (EE) FBDEV(0): Specified depth (24) is greater than the fbbpp (1)
[ 733.109] (II) UnloadModule: "fbdev"
[ 733.109] (II) Unloading fbdev
[ 733.109] (II) UnloadModule: "fbdevhw"
[ 733.109] (II) Unloading fbdevhw
[ 733.109] (EE) Screen(s) found, but none have a usable configuration.
[ 733.109]
Fatal server error:
[ 733.109] no screens found
[ 733.109]
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 733.109] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 733.109]
[ 733.121] ddxSigGiveUp: Closing log
vadi@vadi-11:~$
Can anyone help?
Vadim P. is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:13 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.