Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-13-12, 05:31 AM   #1
crushcardinale
Registered User
 
Join Date: Sep 2011
Posts: 4
Default Cannot set fan speed below 55% on 295.40 drivers. Previously worked.

With the previous drivers I was able to lower the fan speed of my GPU to 20%. Now I can only set it to 55% (the default speed after X is started) or higher. None of the following methods work:

a) Setting the fan speed in the nvidia-settings GUI. Any value I try below 55%, it just sets back to 55%.

b)
Code:
nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUCurrentFanSpeed=20"
Output:
Code:
  Attribute 'GPUFanControlState' (NightFury:0[gpu:0]) assigned value 1.

  Attribute 'GPUCurrentFanSpeed' (NightFury:0[fan:0]) assigned value 20.
But the fan speed remains the same if I try to set it below 55% (I can hear it so and I can check it in the nvidia-settings GUI).

c) "nvclock -f -F 20" previously worked, but now I get a segmentation fault. I know nvclock isn't something officially supported, but I thought you should know anyway.

I want to mention that the GPU temperature is not an issue. Previously with 20% fan speed it would stay around 55C. Now it's at 47C.

I have attached the output from nvidia-bug-report.sh
Attached Files
File Type: gz nvidia-bug-report.log.gz (32.0 KB, 65 views)
crushcardinale is offline   Reply With Quote
Old 05-05-12, 12:37 PM   #2
jcdole
Registered User
 
Join Date: May 2011
Posts: 11
Default Re: Cannot set fan speed below 55% on 295.40 drivers. Previously worked.

Same problem.

see : http://www.nvnews.net/vbulletin/newr...reply&t=179766


/usr/bin/nvidia-settings -t --query GPUCoreTemp is working
/usr/bin/nvidia-settings -t --query GPUCoreTemp is working
but
nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUCurrentFanSpeed=20" is not working.


Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.49  (buildmeister@swio-display-x86-rhel47-07.nvidia.com)  Tue May  1 00:54:24 PDT 2012

########################################################
#											#
#											#
#	/etc/X11/Xorg.conf							#
#											#
#											#
########################################################
#
# Configuration manuelle
#
########################################################
# RPM Fusion - nvidia-xorg.conf
#

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 6800 GS"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Videocard0"
# initial    Option         "Coolbits" "4"
    Option         "Coolbits" "5"
    SubSection     "Display"
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection
Have to return to 295.33 until nvidfia-settings would set fan speed.
__________________
Thank you for helping. JCD
_______________
SAMBA-LDAP PDC server 12.1--qosmio x500 win XP & desktop (12.1>)11.4 -- KDE -- acer aspire 7736g win 7 pro - scan EPSON V500 - Brthr HL2150N - Samsung CLP-325W
jcdole is offline   Reply With Quote
Old 05-05-12, 01:41 PM   #3
jcdole
Registered User
 
Join Date: May 2011
Posts: 11
Default Re: Cannot set fan speed below 55% on 295.40 drivers. Previously worked.

Found on internet that to set also /etc/X11/xorg.conf.d/50-device.conf

Now the command is accepted.

Code:
linux:/local/zypper_install # nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUCurrentFanSpeed=80"

  Attribute 'GPUFanControlState' (linux-srv:0[gpu:0]) assigned value 1.

  Attribute 'GPUCurrentFanSpeed' (linux-srv:0[fan:0]) assigned value 80.
linux:/local/zypper_install # 

linux:/local/zypper_install # /usr/bin/nvidia-settings -t --query [fan:0]/GPUCurrentFanSpeed 
80
linux:/local/zypper_install #
I continue to digg to see if I can remove /etc/X11/xorg.conf and keep only /etc/X11/xorg.conf.d/50-device.conf.
__________________
Thank you for helping. JCD
_______________
SAMBA-LDAP PDC server 12.1--qosmio x500 win XP & desktop (12.1>)11.4 -- KDE -- acer aspire 7736g win 7 pro - scan EPSON V500 - Brthr HL2150N - Samsung CLP-325W
jcdole is offline   Reply With Quote
Old 05-05-12, 03:42 PM   #4
jcdole
Registered User
 
Join Date: May 2011
Posts: 11
Default Re: Cannot set fan speed below 55% on 295.40 drivers. Previously worked.

/etc/X11/xorg.conf.d/50-device.conf have to be modified.

Code:
Section "Device"
#		Identifier "Default Device"
    Identifier  "Video Card"

#		Driver "radeon"
    Driver    "nvidia"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

    Option    "Coolbits" "5"

EndSection
Have removed /etc/X11/xorg.conf.

Command are accepted :

Code:
linux-srv:/local/zypper_install # /usr/bin/nvidia-settings -t --query [fan:0]/GPUCurrentFanSpeed 
53
Code:
linux-srv:/local/zypper_install # nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUCurrentFanSpeed=90"

  Attribute 'GPUFanControlState' (linux-srv:0[gpu:0]) assigned value 1.

  Attribute 'GPUCurrentFanSpeed' (linux-srv:0[fan:0]) assigned value 90.
Code:
linux-srv:/local/zypper_install # /usr/bin/nvidia-settings -t --query [fan:0]/GPUCurrentFanSpeed 
90
Code:
linux-srv:/local/zypper_install # nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUCurrentFanSpeed=30"

  Attribute 'GPUFanControlState' (linux-srv:0[gpu:0]) assigned value 1.

  Attribute 'GPUCurrentFanSpeed' (linux-srv:0[fan:0]) assigned value 30.
Code:
linux-srv:/local/zypper_install # /usr/bin/nvidia-settings -t --query [fan:0]/GPUCurrentFanSpeed 
30
__________________
Thank you for helping. JCD
_______________
SAMBA-LDAP PDC server 12.1--qosmio x500 win XP & desktop (12.1>)11.4 -- KDE -- acer aspire 7736g win 7 pro - scan EPSON V500 - Brthr HL2150N - Samsung CLP-325W
jcdole is offline   Reply With Quote
Old 06-17-12, 03:36 AM   #5
crushcardinale
Registered User
 
Join Date: Sep 2011
Posts: 4
Default Re: Cannot set fan speed below 55% on 295.40 drivers. Previously worked.

@jcdole

I did what you said - remove xorg.conf and create /etc/X11/xorg.conf.d/50-device.conf - but it still doesn't work. I can't get the fan speed below 55%. I even tried with the latest drivers - 302.17.

Any other ideas?
crushcardinale is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:11 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.