Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-11-12, 08:20 AM   #1
bostik
Registered User
 
Join Date: Jun 2006
Posts: 4
Default FreeBSD 9.0-RELEASE

Hi all,

i just updated my freebsd box to 9.0 RELEASE and i tried to rebuild my NVIDIA-FreeBSD-x86_64-290.10 device driver.

It seems they check for FreeBSD Release and i get this error:

Code:
In file included from nvidia_ctl.c:14:
nv-freebsd.h:25:2: error: #error This driver does not support FreeBSD 9.x/-CURRENT!
*** Error code 1

Stop in /usr/local/src/NVIDIA-FreeBSD-x86_64-290.10/src.
*** Error code 1

Stop in /usr/local/src/NVIDIA-FreeBSD-x86_64-290.10.
I'm triying to use nv drivers (xorg driver) but i wonder when driver will be updated so that i can use them with my favorite OS.

Thanx
Roberto
bostik is offline   Reply With Quote
Old 01-11-12, 10:36 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: FreeBSD 9.0-RELEASE

You can remove the #error from the nv-freebsd.h header file to allow the driver to build/install. I'll file a bug to get the driver updated.
zander is offline   Reply With Quote
Old 01-11-12, 05:51 PM   #3
bostik
Registered User
 
Join Date: Jun 2006
Posts: 4
Default Re: FreeBSD 9.0-RELEASE

Hi Zander
thanx for your quick reply.

I've already think about skipping error the way you suggest and it compile correctly ("make") but entering "make install" command i get another error:

Code:
===> x11 (install)
===> x11/driver (install)
===> x11/extension (install)
===> x11/bin (install)
===> x11/man (install)
===> doc (install)
ERROR: Failed to load the NVIDIA module!
*** Error code 1

Stop in /usr/local/src/NVIDIA-FreeBSD-x86_64-290.10.
I think is something related to kernel module loading.

in my dmesg i see:

Code:
KLD nvidia.ko: depends on kernel - not available or version mismatch
linker_load_file: Unsupported file type
If you think it can help please update the bug with those info.

Thanx
Roberto
bostik is offline   Reply With Quote
Old 01-12-12, 02:23 PM   #4
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: FreeBSD 9.0-RELEASE

Are you sure your kernel source matches the running kernel?
adamk75 is offline   Reply With Quote
Old 01-14-12, 04:42 PM   #5
bostik
Registered User
 
Join Date: Jun 2006
Posts: 4
Default Re: FreeBSD 9.0-RELEASE

Hi adamk75,

yes my sources match my kernel release:

just updated with cvsup

Code:
[root@mrburns ~]# uname -ri
9.0-RELEASE GENERIC
same error:

Code:
[root@mrburns ~]# kldload nvidia
kldload: can't load nvidia: Exec format error
bostik is offline   Reply With Quote
Old 01-22-12, 01:01 AM   #6
rhurlin
FreeBSD in Science
 
rhurlin's Avatar
 
Join Date: Jan 2007
Location: Northeim, Germany
Posts: 22
Default Re: FreeBSD 9.0-RELEASE

Quote:
Originally Posted by bostik View Post
Hi adamk75,

yes my sources match my kernel release:

just updated with cvsup

Code:
[root@mrburns ~]# uname -ri
9.0-RELEASE GENERIC
same error:

Code:
[root@mrburns ~]# kldload nvidia
kldload: can't load nvidia: Exec format error
Are you really sure you rebuilt your kernel after updating the kernel sources? This is the vital step. The kernel must be of the same age or younger than the sources are. (After your cvsup the sources are younger than the kernel!)

In a second step you have to build and install new nvidia driver (don't forget to 'make clean' before).

BTW, isn't it easier to patch the existing nvidia port a little bit to let him build and install the driver for you? Changing the version number in x11/nvidia-driver/Makefile and after that doing 'make makesum' should be enough to prepare the drivers build.

Hope this helps,
Rainer
rhurlin is offline   Reply With Quote
Old 01-23-12, 04:37 AM   #7
bostik
Registered User
 
Join Date: Jun 2006
Posts: 4
Default Re: FreeBSD 9.0-RELEASE

Hi Rainer,

thanx for help, I succesfully solved modifiyng Makefile to download new driver version 290.10 following instruction here:
http://forums.freebsd.org/showthread...nvidia+freebsd
http://forums.freebsd.org/showthread...nvidia+freebsd

and installed misc/compat8x and everithing worked fine

Ciao
Roberto
bostik is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:28 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.