Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-13-03, 07:54 AM   #1
bored_SuSE_user
Registered User
 
Join Date: Aug 2003
Posts: 11
Default /dev/fb0 doesn't exist

I am having problems trying to get an application to run, it says that it cannot find /dev/fb0.
At the moment I have vga=normal in my grub, because if I change this, I get the corruption.
Is there anyway to convince the linux system I do have a frame buffer?

Incidentally I am getting similar problems on my old linux box, which I am hoping to turn into a mame machine. I get errors identical to my nvivida laptop. I cannot find a vga= parameter which will turn on the fb. I have even tried setting the device to vesa->framebuffer device in Sax2 but it doesn't test it properly - comes back with the same error above.

Maybe you have to do this, then restart? I'm not sure, but I don't want to muck my configuration up.
bored_SuSE_user is offline   Reply With Quote
Old 09-13-03, 09:25 AM   #2
Vadim
Registered User
 
Join Date: May 2003
Location: Moscow, Russia
Posts: 10
Default

you should add options like "vga=0x317 video=vesa:mtrr,ypan" to your kernel command line. videomode can be different (you can find list in /usr/src/linux*/Documentation/fb/vesafb.txt), but there no way to change mode after boot.
Vadim is offline   Reply With Quote
Old 09-13-03, 10:40 AM   #3
bored_SuSE_user
Registered User
 
Join Date: Aug 2003
Posts: 11
Default

Thanks for the quick reply.
My friend thought it was possible to install a fb driver like rivafb or sisfb but one for my card does not exist (only the installed nvidia one).

I will try that and hopefully it will work!
bored_SuSE_user is offline   Reply With Quote
Old 09-13-03, 11:00 AM   #4
bored_SuSE_user
Registered User
 
Join Date: Aug 2003
Posts: 11
Default

No...the highest my mame linux box will go to is 217 according to 'scan'. It doesn't enable the fb therefore. I presume that the card doesn't support the framebuffer.

I haven't tried my laptop with the video=vesa: command, but before I got corruption due to nvidia buggy drivers.
bored_SuSE_user is offline   Reply With Quote
Old 09-13-03, 02:18 PM   #5
Vadim
Registered User
 
Join Date: May 2003
Location: Moscow, Russia
Posts: 10
Default

vesafb modes have nothing with scan output
Vadim is offline   Reply With Quote
Old 09-13-03, 04:44 PM   #6
bored_SuSE_user
Registered User
 
Join Date: Aug 2003
Posts: 11
Default

I found the problem: my bios on my old linux box doesn't support framebuffer, if I select a number like 317, the screen goes blank (i.e. video card output dies).

On my dell with nivida I am getting the error that vesafb doesn't allow creation of new modes (trying to run advance menu).

Seems everytime I fix something or work out why it is causing an error, I get another problem.
bored_SuSE_user is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 05:32 PM
Error msg: "GLcore" module does not exist!!! number9 NVIDIA Linux 2 09-15-02 07:45 AM

All times are GMT -5. The time now is 09:26 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.