Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-15-03, 10:12 AM   #1
Wisekrak
Registered User
 
Join Date: Aug 2003
Posts: 3
Unhappy Suse 8.2 cannot compile Kernel Module because of wrong version of gcc???

I have been running version 4496 for some time now without trouble. Yesterday I used the update utility and my kernel got updated. The update told me that I would probably need to re-install the NVIDIA driver. No Problem I thought.....
Here is the output from the failed install log...

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Aug 14 14:16:44 2003

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel include path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Kernel include path: '/lib/modules/2.4.20-64GB-SMP/build/include'
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f nv.o os-agp.o os-interface.o os-registry.o nv-linux.o nv_compiler.h *
.d NVdriver nvidia.o
-> Building kernel module:
executing: 'cd ./usr/src/nv; make nvidia.o SYSINCLUDE=/lib/modules/2.4.20-64
GB-SMP/build/include'...

You appear to be compiling the NVIDIA kernel module with
a compiler different from the one that was used to compile
the running kernel. This may be perfectly fine, but there
are cases where this can lead to unexpected behaviour and
system crashes.

If you know what you are doing and want to override this
check, you can do so by setting IGNORE_CC_MISMATCH.

In any other case, set the CC environment variable to the
name of the compiler that was used to compile the kernel.

*** Failed cc sanity check. Bailing out! ***
make: *** [gcc-check] Error 1
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

I ran the following to find out which version of gcc was used to compile the kernel...

cat /proc/version

Linux version 2.4.20-64GB-SMP (root@SMP_X86.suse.de) (gcc version 3.3 20030226 (prerelease) (SuSE Linux)) #1 SMP Wed Aug 6 18:30:02 UTC 2003

and the following for gcc...
gcc -v
Reading specs from /usr/lib/gcc-lib/i486-suse-linux/3.3/specs
Configured with: ../configure --enable-threads=posix --prefix=/usr --with-local-prefix=/usr/local --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib --enable-languages=c,c++,f77,objc,java,ada --disable-checking --enable-libgcj --with-gxx-include-dir=/usr/include/g++ --with-slibdir=/lib --with-system-zlib --enable-shared --enable-__cxa_atexit i486-suse-linux
Thread model: posix
gcc version 3.3 20030226 (prerelease) (SuSE Linux)

seems the same version to me... any thoughts???/
Wisekrak is offline   Reply With Quote
Old 08-15-03, 10:29 AM   #2
damage
Registered User
 
Join Date: Aug 2003
Posts: 6
Default

I had the same problem. I just set the environment variable IGNORE_CC_MISMATCH with
"export IGNORE_CC_MISMATCH=yes"
and it worked without problems.
damage is offline   Reply With Quote
Old 08-15-03, 12:15 PM   #3
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default

Quote:
Originally posted by damage
I had the same problem. I just set the environment variable IGNORE_CC_MISMATCH with
"export IGNORE_CC_MISMATCH=yes"
and it worked without problems.
Discussed in some other threads.
Indeed this solves it.
Hopefully NVIDIA modifies the installer to handle the complicated version string!
pe1chl is offline   Reply With Quote
Old 08-15-03, 05:09 PM   #4
Wisekrak
Registered User
 
Join Date: Aug 2003
Posts: 3
Default

Well I rebuilt the module and it did compile which was great. Now however.. After configuring the driver using Sax2 The X server fails with the following error.

(EE) NVIDIA(0): Failed to allocate config DMA context
(EE) Screen(s) found, but none have a usable configuration.

I'm still in the process of digging up the answer to this one... Just thought I'd update this thread for anyone using SUSE 8.2 and having the same frustration.
Wisekrak is offline   Reply With Quote
Old 08-15-03, 05:54 PM   #5
damage
Registered User
 
Join Date: Aug 2003
Posts: 6
Default

I remember having exactly the same problems after the module was finally compiled. I then used a HOWTO on the suse ftp to configure the kernel. I found it again, here is the link:

ftp://ftp.suse.com/pub/suse/i386/sup...nstaller-HOWTO

Hope that helps.

The important part of this document for SuSE 8.2:

Quote:
1) Kernel sources must be installed and configured. Usually this means
installing the 'kernel-source' RPM with YaST2 and configure it then
with the following commands:

cp /boot/vmlinuz.config /usr/src/linux/.config
cp /boot/vmlinuz.version.h /usr/src/linux/include/linux
cp /boot/vmlinuz.autoconf.h /usr/src/linux/include/linux
cd /usr/src/linux
make cloneconfig dep

2) Use the nvidia installer.

export IGNORE_CC_MISMATCH=yes
sh NVIDIA-Linux-x86-1.0-4363.run

3) Enable 3D support with SaX2.
damage is offline   Reply With Quote
Old 08-16-03, 10:38 AM   #6
Wisekrak
Registered User
 
Join Date: Aug 2003
Posts: 3
Default

That fixed it. Thank you all for the help. It's funny because I had to do that to the kernel source the last time I installed the driver. But I did not have to set the mismatch for gcc.
I guess that was what med me forget that step.

Again Thank You All... =)
Wisekrak is offline   Reply With Quote
Old 08-16-03, 04:42 PM   #7
brakezone
Registered User
 
Join Date: Aug 2003
Posts: 5
Default some kinda simular prob

A NEWB

okay well the story begins on august 11th when i'm sitting at home using unpatched version of windows XP behind a firewall. I am messing with hardware router/firewall configuration at the time and sometimes it will unstealth while i'm setting it up if i do the wrong thing- suddenly bam i get hit by this worm and my machines like shuttingdown and stuff. So i go in msconfig and find msblaster, i turn it off and i restart w/o the program running only to be crashed, so i reset the firewall, turn it on and patch and remove the worm. The next day my brother comes home with SuSe 8.2 linux edition so. I figure hey this is cool I can put this on. So i install it never having used linux before.

during installation I was prompted about the reinstalation of the nvidia driver for my geforce 4 mx 440, under the condition that I install the kernel it offered me. I clicked yes and moved on figuring these were things I had to do anyways. So in this case I assume that I am in the catagory of the how to text where I must follow these instructions in consol only boot up.

1) Kernel sources must be installed and configured. Usually this means
installing the 'kernel-source' RPM with YaST2 and configure it then
with the following commands:

cp /boot/vmlinuz.config /usr/src/linux/.config
cp /boot/vmlinuz.version.h /usr/src/linux/include/linux
cp /boot/vmlinuz.autoconf.h /usr/src/linux/include/linux
cd /usr/src/linux
make cloneconfig dep

2) Use the nvidia installer.

export IGNORE_CC_MISMATCH=yes
sh NVIDIA-Linux-x86-1.0-4363.run

3) Enable 3D support with SaX2.

I believe step one, kernel-souruce RPM installation with YaST2, has been completed during update.

I goto the consol and type cp /boot/vmlinuz.config /usr/src/linux/.config
result- it claims that the /usr/src/linux is not a directory or something, so i go and look for that directory in the x-window interface, its not there, so i created it (at this point i have no idea if i'm doing the right or completely wrong thing) then i go back and type cp /boot/vmlinuz.config /usr/src/linux/.config.

it didn't say anything then so i have to assume that i am doing the right thing.

Then i create directories and type the rest of the copy's

I then run the installer, and I did type export IGNORE_CC_MISMATCH=yes before hand. It says it can't find a suitable kernal or something of the likes and fails and also says some kernal file isn't where it wants to find it. So in any event I can't figure it out yet. If somebody could tell me the names of the files it wants, where I should put them, or if even that is not enough, in preperation of running the installer. And there is a message at the end of the installers failure that says I should use a command in the commandline to indicate where some kernal is. Where exactly is the commandline, is it inside the installation program or do i type it before installation somehow.
brakezone is offline   Reply With Quote
Old 08-16-03, 04:54 PM   #8
leibold
Registered User
 
Join Date: May 2003
Posts: 66
Default Re: some kinda simular prob

Quote:
Originally posted by brakezone

I believe step one, kernel-souruce RPM installation with YaST2, has been completed during update.
No, the reason you didn't have /usr/src/linux was because you never installed the kernel-source RPM. You probably should remove the directory you created before installing the kernel-source package.
leibold is offline   Reply With Quote

Old 08-16-03, 06:34 PM   #9
brakezone
Registered User
 
Join Date: Aug 2003
Posts: 5
Default

that would make sense I guess. i'ms orry for sounding like such a newb, but how would i install the kernal-source.rpm?

I know i installed something dealing with a kernal from yast2 on the update feature. And i start yast2 and I go to online update and I clicked on this thing that said kernel source, and it said taht installing it would have no effect. So i did it anyways because thats what somebody said to do and it made no difference. I must be missing something obvious.

Is there a place i can download the newest kernal-source RPM, and then i can just try to install it with Yast2 i guess.
brakezone is offline   Reply With Quote
Old 08-16-03, 11:57 PM   #10
brakezone
Registered User
 
Join Date: Aug 2003
Posts: 5
Talking it works!

I finally got yast2 to install the kernal, so then when i went to type in those commands from the how-to text, the commands were carried out. So i followed the instructions and it worked! I also deleted those folders I said i created like u said to. The installer worked and now i got 3d graphics! ty ty thread and for all the people who displayed thier infos.

Now all i need to do is figure out how to install some kewl linux games lolz
brakezone is offline   Reply With Quote
Old 09-05-03, 09:43 AM   #11
shigeru_go
Registered User
 
Join Date: Aug 2003
Posts: 2
Default

can you show me how u install and config the kernel-source rpm with yast2?

thanks.
shigeru_go is offline   Reply With Quote
Old 09-05-03, 10:11 AM   #12
Thorsten Lange
Registered User
 
Join Date: Aug 2003
Location: Cologne, Germany
Posts: 6
Default

Quote:
Originally posted by pe1chl
Discussed in some other threads.
Indeed this solves it.
Hopefully NVIDIA modifies the installer to handle the complicated version string!
Better yet, SuSE stopped shipping prerelease versions of the gcc, which might lead to problems anyway (anyone remember Red Hat's gcc "2.96"?)

However, a (release) gcc 3.3.1 can be downloaded from ftp.suse.com (or its mirrors) - look for the /pub/projects/gcc directory (which is not available on all mirrors).

But make sure you recompile your kernel *and* the nvidia module, if you install it. ;-)
Thorsten Lange is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM

All times are GMT -5. The time now is 06:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.