Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-12-12, 05:12 AM   #1
norrland
Registered User
 
Join Date: May 2012
Posts: 2
Default [SOLVED] 295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage

Hi, hopefully I'm not the only one with this problem.

Running Debian Wheezy with linux kernel 3.2.0.2-amd64 and the 295.40 drivers from debian non-free repository.
Using LXDE as DE and not that much fancy stuff.

But as of yesterday the Xorg process started hogging all cpu when I were switching between windows. So currently I'm using the nouveau drivers just to have a usable system.

Here are some info about my system.

Code:
# uname -a
Linux tchang 3.2.0-2-amd64 #1 SMP Mon Apr 30 05:20:23 UTC 2012 x86_64 GNU/Linux

# dpkg -l | grep xorg
ii  xorg                                  1:7.6+12                           X.Org X Window System
ii  xorg-docs-core                        1:1.6-1                            Core documentation for the X.org X Window System
ii  xserver-xorg                          1:7.6+12                           X.Org X server
ii  xserver-xorg-core                     2:1.11.4-1                         Xorg X server - core server
ii  xserver-xorg-input-evdev              1:2.7.0-1                          X.Org X server -- evdev input driver
ii  xserver-xorg-input-kbd                1:1.6.1-1                          X.Org X server -- keyboard input driver
ii  xserver-xorg-input-mouse              1:1.7.1-1+b1                       X.Org X server -- mouse input driver
ii  xserver-xorg-video-fbdev              1:0.4.2-4+b2                       X.Org X server -- fbdev display driver
ii  xserver-xorg-video-nouveau            1:0.0.16+git20111201+b5534a1-1     X.Org X server -- Nouveau display driver
ii  xserver-xorg-video-nvidia             295.40-1                           NVIDIA binary Xorg driver

# dpkg -l | grep nvidia
ii  glx-alternative-nvidia                0.2.1                              allows the selection of NVIDIA as GLX provider
ii  libgl1-nvidia-alternatives            295.40-1                           transition libGL.so* diversions to glx-alternative-nvidia
ii  libgl1-nvidia-glx:amd64               295.40-1                           NVIDIA binary OpenGL libraries
ii  libglx-nvidia-alternatives            295.40-1                           transition libgl.so diversions to glx-alternative-nvidia
ii  nvidia-alternative                    295.40-1                           allows the selection of NVIDIA as GLX provider
ii  nvidia-glx                            295.40-1                           NVIDIA metapackage
ii  nvidia-installer-cleanup              20111111+3                         Cleanup after driver installation with the nvidia-installer
ii  nvidia-kernel-common                  20111111+3                         NVIDIA binary kernel module support files
ii  nvidia-kernel-dkms                    295.40-1                           NVIDIA binary kernel module DKMS source
ii  nvidia-support                        20111111+3                         NVIDIA binary graphics driver support files
ii  nvidia-vdpau-driver:amd64             295.40-1                           NVIDIA vdpau driver
ii  xserver-xorg-video-nvidia             295.40-1                           NVIDIA binary Xorg driver
Hope this will help. I've attached the nvidia-bug-report.log.gz
Attached Files
File Type: gz nvidia-bug-report.log.gz (70.4 KB, 95 views)

Last edited by norrland; 05-13-12 at 10:11 AM. Reason: Solved
norrland is offline   Reply With Quote
Old 05-12-12, 10:01 AM   #2
poltsy
Registered User
 
Join Date: Jan 2010
Posts: 26
Default Re: 295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage

Was yesterday also the day you installed libcairo2 1.12.x? It seems to expose some wonderful new bugs in the drivers and performance really falls off a cliff. Going back to 1.10.2-7~bpo60+1 from backports seems to fix it for me.
poltsy is offline   Reply With Quote
Old 05-13-12, 10:11 AM   #3
norrland
Registered User
 
Join Date: May 2012
Posts: 2
Default Re: 295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage

Quote:
Originally Posted by poltsy View Post
Was yesterday also the day you installed libcairo2 1.12.x? It seems to expose some wonderful new bugs in the drivers and performance really falls off a cliff. Going back to 1.10.2-7~bpo60+1 from backports seems to fix it for me.
Thanks!
Works like a charm
norrland is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:24 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.